New USB mouse not working - General Hardware - Laptop - Dell Community

New USB mouse not working


Laptop computer Forums (Audio, General Hardware, Video)

New USB mouse not working

  • I got a new mouse, Logitech USB mouse.  Came home, plugged it into my USB port on my 9100, and it doesn't work.  The computer doesn't even recognize it's there.  The optical light is on, so I know it's getting power, but I don't understand why it's not being detected and working.  Can anyone help me out here? 
  • Does your "USB Connected" sound do its thing when you connect it? It's like a da-ding. Or is the sound ding-ding-ding, which is a "USB device failed to connect"? If you dont get either of those sounds, try switching USB ports.

    Message Edited by carvex on 03-03-2005 09:41 PM

  • Nope, and I've switched ports, but nothing happens there either
  • It is a plug and play mouse, right? It didn't come with a CD or anything to install it with?
  • Plug and play


    EDIT: Ok, I've determined that it isn't the mouse.  I tried to put another device in the USB ports and Windows doesn't detect it either.  I tried updating the chip set, didn't fix anything.  Any other ideas?

    Message Edited by AliCat929 on 03-04-2005 02:09 AM

  • The only thing I can think of is Windows Update. It might have the drivers for the USB ports.
  • Didn't.  All it had was .NET framework.

    I've also looked at the BIOS, and the USBs are enabled.  I have no idea what is going on, or how long this has been a problem.  I never use the USB ports on my laptop.  Not usually.  I had a mouse a few months ago, but it shot craps one day.  Somewhere between then and now, something has happened to my USB ports and they don't work anymore.

    Anyone else have anymore ideas of what I could try?
  • Alright then.  I just installed window xp on my inspiron 8000 with a new 30 GB hard drive.  Everything works fine until I install plug and play USB mouse and PS/2 mouse.  The OS detectsd the new USB mouse and installs accordingly but the cursor is not responding at all.  Then I plug PS/2 mouse in and it doesn't respond either.  The only pointing device I can use is touchpad.  Could anybody tell me how to resolve the problem?  Thank you. 
  • I had a similar problem, and Dell support told me that basically the computer is "confused" with the IRQ assignments because it doesn't know WHAT to recognize so its not recognizing ANYTHING--check your IRQ assignments (mine were MISSING where the mouse/usb stuff should be so said Dell support)  I also could only use the touchpad, which worked for a while until the touchpad froze for some reason too and now I am stuck and posting here for help with that ick--

    Anyway, my suggestion after going through the hassle is to try to use the CD that can reload your drivers/utilities and see if it worksbefore messing with individual settings too much--anyone with more computer expertise than me agree/disagree with that??

  • To update....

    My USB wireless mouse actually started to work after I posted to this thread.  I changed my BIOS setting from Touchpad/PS 2 to PS 2.  After the computer "got used to" the setting, the touchpad and USB wireless mouse could work at the same time.

    Logically I couldn't think of any conflict between a USB mouse and PS/2 one.  Plus my laptop had 3 different kinds of pointing devices worked at the same time (USB wireless mouse, touchpad and PS/2 mouse) when my OS was Window 2000. 

    That was a day ago.  My bigger problem now is that my hard drive is not working any more..... :P