F2 (setup) & F12 (Boot Option) doesn't work when Hard Drive installed - General Hardware - Laptop - Dell Community

F2 (setup) & F12 (Boot Option) doesn't work when Hard Drive installed


Laptop computer Forums (Audio, General Hardware, Video)

F2 (setup) & F12 (Boot Option) doesn't work when Hard Drive installed

  • Bought a new primary hard drive for my Latitute C600.  Physically installed the drive but can't get the system to boot from CD or Floppy. 
    With the new hard drive physically installed, the BIOS startups up but freezes before it completes.  If I press F2 (Setup) or F12 (Boot Sequence); the proper message appears (like ....Starting Setup) but it eventually freezes too.
    If I remove the hard drive and boot up with no hard drive at all, I can boot from CD and Floppy with no problem.  But obviously if I do this, I can't plug in the hard drive after the boot since it won't sense it is there.
    Using the technique above, I have removed the hard drive from the boot sequence entirely.  Unplugged the power and the batteries and tried again but the problem repeats itself.  Would love some suggestions.
  • What BIOS version is installed??? Could be you need to update the BIOS to the latest version to see the new HDD. A23 is the newest but if you now have something like A07 or earlier you should upgrade to A12-A17 first. There have been reports of going from one of the EARLY BIOS's to the newest causes the notebook to become non-functional. I personally have upgraded a few C600 to the newest A23 BIOS with NO problems but I believe they were already at A16 or higher to begin with. Also ONLY USE THE FLOPPY DRIVE METHOD to update the BIOS and DO NOT DO THE UPDATE WITH THE NOTEBOOK IN A DOCKING STATION.

    Please read this thread for some of the problems encounter when updating the BIOS on a C600.


    Message Edited by Ed C on 01-09-200508:38 AM

    Message Edited by Ed C on 01-09-2005 08:38 AM

  • Upgraded BIOS from A21 to A23 but no change in behaviour.  Here is a recap and a bit of new info:
    With Hard Drive physically installed, the system freezes at 100% of Bios load.  If I press F2 (Setup) or F12(Boot) the system still freezes.  In all cases I am trying to boot from either a DOS Floppy or the Recovery CD.   This new primary hard drive was purchased direct from DELL.
    If I remove the hard drive, I can boot from floppy or CD. 
    Now some new info.... 
    (1) Loaded a Diagnostics CD from Gateway into the CDROM,
    (2) Pulled out the new hard drive,
    (3) Powered up and pressed F12(Boot Options),
    (4) Just before the BIOS load got to about 95%, I pushed in the new hard drive,
    (5) Boot menu came up and I selected Boot from CDROM
    (6) Gateway CD basically does a DOS boot and has something called GWSCAN
    (7) Ran GWSCAN and it found the hard drive, checked its integrity AND reported back the correct serial number and part number (obviously it found the Hard Drive and said it was ok),
    Tried to do the same trick with the DELL recovery CD (doesn't have disk diagnostics only Windows reload).  Windows reload processes (loads drivers, etc.) gets all the way to Windows Setup and freezes. 
    I am a reasonably clever guy but I've never encountered this before.  Thanks for your earlier reply...
  • I hate to say it but I think the HDD is bad. Do you have the old drive or is that totally dead. If you have the old drive does the system boot or at least get by POST with that drive installed.
  • I have another C600 in good working order.  Any harm if I pop out its hard drive and install this new one to see if I can isolate the problem?    If I can get this new hard drive working then I know I have some other problem with the first C600.   But I don't want to screw up my second computer... 
  • Yes try that and also try the other HDD in the first C600.
  • OK.... Looks like I bought a hard drive when I didn't need to..   I put both the old hard drive that I thought was defective and the new hard drive into the second C600.  Used the recovery disk to boot and reload Windows in both of them.  They both work in the second C600. 

    Neither is working in the first C600- so what I thought was a hard drive problem and a related BIOS problem is something else.

    The symptoms persist... The original C600 freezes before boot up while the BIOS is loading.  F2 and F12 don't work.  So I have some other problem not hard drive related per se.

    Thanks for your time Ed C.  I will keep researching my problem... Anyone have any ideas please reply.

    Best wishes to all,



  • Looks like it's time for a new motherboard on that one C600. There is no other way to fix your problem as the HDD connector is on the board.