Dell Vostro 1720 Function (fn) keys dont work on windows 7 - General Hardware - Laptop - Dell Community

Dell Vostro 1720 Function (fn) keys dont work on windows 7


Laptop computer Forums (Audio, General Hardware, Video)

Dell Vostro 1720 Function (fn) keys dont work on windows 7

This question is not answered

Hello there,

I've installed windows 7 (64 bit) on my Dell Vostro 1720 and now the function keys do not work anymore, ive tried several hotfixes from windows and installed all the windows 7 x64 drivers that are on the website.

Please help im out of ideas and dont know where to look anymore

Thanks in advance for all your help

All Replies
  • Hi Cyril Brugman,

    Welcome to the Community.

    For the issue with function keys not working after Windows 7 installation, please try the following step :

    Go to Control Panel > Hardware and Sound > Windows Mobility Centre and change the 'Function Key Row' from Multimedia to Function Key.

    Hope this helps resolve the issue for you.

    Please let us know if you have any further queries.

    Thanks and Regards,
    Prateek K

  • im having this same problem, after a fresh win7 32bit install.


    I tried the above, but there isn't  a "function key row" option in my mobility center.

    the function keys worked prior to this.


    I should note, I recently replaced the keyboard, due to several failing buttons. ive tried 2 different keyboards now, both with the same issue, and both were new.


    the up/down arrow keys work, but the FN/brightness controls do not.


    Did you ever manage to get this problem fixed? I'm experiencing the same issue and it's very frustrating. The only difference in my case is that I've installed win7 64bit. 

    I tried downloading drivers from the Dell website for my Monitor too and that wouldn't install. I couldn't find any for my Keyboard which I would presume is the main issue since none of my function keys work.

    Also, I don't see the "function key row" option in my mobility center either!

    Does anyone have any other ideas of how to fix this? This is NOT a compatibility issue with Windows 7 because I only re-installed Windows. It's the same one that I've been happily running for the last couple of years :(

  • I did get it fixed.


    I was missing the drivers for the GPU. this laptop has the upgraded GPU, and dell was completely worthless for the graphics. I had to go to the manufacturer to get them.

    all my function keys work like they're supposed to now.