Laptop screens fades in and out

Laptop

Laptop
Laptop computer Hardware and Software discussion

Laptop screens fades in and out

This question has suggested answer(s)

I've got an Inspiron N7110 laptop that I've owned for about 10 months.  Recently my screen has started to fade to black and then back.  Sometimes it goes back and forth rather quickly.  Other times it seams to fade out when I remove something from a USB port; once I touch the touchpad, it seems to come back.

All Replies
  • Hi REObroker,

    I will recommend you to run the LCD BIST (LCD diagnostics) on your system to make sure the functionality of the LCD is fine:

    • Turn off the system.
    • Press and hold 'D' and press the power button at the same time; make sure you do not release 'D' until the diagnostics initiates.
    • Please check if the screen fades/flickers when the color bars are displayed.

    In case the LCD diagnostics pass, I will recommend you to change the power plan settings on your system:

    1. Click on 'Start' and type 'Power options' in the search box.
    2. Type 'Power options' in the search box and click on 'Power options'.
    3. Click on 'Change plan settings' depending on the power plan selected on your system.
    4. Click the drop down arrow next to 'Dim the Display' and change it to 'Never' for 'On Battery' as well as for 'Plugged in'.
    5. Click on 'Save changes' and observe your system.

    In case the issue still persists, check your system in BIOS if the screen dims:

    • Restart your system and keep tapping 'F2' as soon as the Dell logo appears.
    • The system should enter the system setup (BIOS).

    Keep me posted. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • It appeared to have passed the LCD diagnostics.  I changed the power options, but there still seems to be a blackout of the screen when I unplug anything from the USB ports.  I don't understand what I am supposed to do in BIOS.  I can get there, but don't know what to do then.

  • Hi REObroker,

    When your system is in BIOS, check if the screen fades out when you remove something from the USB. Also, move the lid back and forth to see if that makes a difference. In case the system works fine in BIOS, uninstall and re install the video driver:

    To uninstall the video driver:

    • Click on 'Start' and right click on 'Computer'.
    • Click on 'Manage' and click on 'Device manager'.
    • Expand 'Display adapters'.
    • Right click the video driver and click on 'uninstall'
    • Once the driver is uninstalled, click on 'Start' and click on 'Control Panel'.
    • Click on 'Programs and features'.
    • A list of applications will be listed.
    • Look for the video driver's application.
    • Right click on it and click on 'uninstall'.
    • Once done, restart the system.

    To re install the video driver:

    • Click on the link: http://dell.to/QjjZDA
    • Enter your system's Service Tag and select the operating system.
    • Go to 'Video' and select the appropriate video card driver depending on the video card your system has.
    • Click on 'Download File'.
    • Select 'Single-file download' and click on 'Continue'.
    • Click on 'Save' and save the driver on the desktop.
    • Right click on the driver from the desktop and select 'Run as administrator'.
    • Install the driver following the on screen instructions.
    • Restart the system after the installation is done and check if the issue is fixed.

    Keep me posted. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • I am experiencing the same problem on my vostro.  The screen intermittently fades to black and with mouse or keyboard movement it flickers on but immediately fades again.  Then for no apparent good reason it persists staying on (like right now).   It first started when I plugged something into a USB port.  I also plugged in a second display and it shows the same behaviour.

    I have run the screen and video card diagnostics.   I'm willing to try the video driver reinstall but there is something that is unclear.  

    If I deinstall the driver then reboot, what controls the video so I can do the post-boot steps?   I don't want to deinstall the driver then not be able to see what I need to do because the screen becomes disabled with no driver.   Please advise.

  • Mark and REObroker/

    You both seam to have the same problem.First thought connectoon From Monitor Ribben Cable connection. because lap top/

    lot of motion eatch time open and use computer,but you haved external montor problem still exsist,

    you boath have the reaction (conning USB DRIVES triger /Maybe Hardware problem,/USB ports 5VOLT POWER suply.in common with video card&display)check if any warranty stillin efect,? possable lose connector inside comptter,

    Also in BIOS in some show voltage 12volt+ 12volt- and 5volt chect if BIOS showes Voltages/hope this might help boath

    of You,

                        Good luck   4ROB

  • Hi

    My Inspiron N5050 has experienced the same symptoms as the OP(s) experienced.  The LCD check was ok and upgrading the video drivers made no difference.  I also tried disabling USB emulation in the BIOS but it didn't help.

    However, I can work around the fading problem by setting all the power saving settings to 'Never'.

    Dell have suggested that I return the device under warranty to have the motherboard checked but I'm not sure it is worth the hassle & I personally suspect it is a driver / interoperability issue rather then pure hardware anyway [I don't have a general problem with the USB ports or when opening the screen etc].

    I am running Windows 7 Home Premium 64-bit, MS Office 2007 & 2013 and also McAfee - perhaps others experiencing this defect can confirm what they are running?

    Thanks,

  • Dell sent me a new motherboard and card with USB ports.  I had them installed and things worked well for a bit, but the "strobing" returned.  I tried uninstalling and reinstalling my video driver.  Like the replaced motherboard, I had initial success but it returned.

  • Hi REOBROKER

    Odd - so do you just have to live with the problem now?  Have you tried the laptop power settings that I used as a workaround.

    Are you running Windows 7 or 8 (maybe these laptops were built with 8 in mind..).  Also what about other software such as McAfee?

    Thanks -

  • I've just had to learn to live with it.  I haven't tried putting "never" on all power settings.  I shouldn't have to--Dell should have been able to come up with an answer.

    I have Windows 7 and hope to avoid Windows 8.  I have McAfee through my internet provider on this and the other six machines I own and the Dell is the only machine that has problems.

    My problem still seems to be related to the USB ports.  It tends to happen when I either plug in or unplug something.

    Dell has been a pain to work with.  They sent me the motherboard with no instructions of any sort.  There was a return label for shipping.  I assumed it was in case I returned the part.  Turns out I was supposed to mail back my original motherboard.  They sent me a bill for over $100.  Luckily, I had kept it and sent it back to them.  They have outsourced their technical support to India.  So much for buying American-made products.

    At one point Dell had that ad campaign where the one teen says to another, "Dude, you got a Dell."  It was inferring quality.  I don't know if they were ever quality or not, but this is my second Dell and I won't buy a third.

  • Hi

    I uninstalled McAfee, reverted the power saving settings to Dell's default plan & am now running Norton antivirus.  The fading problem has been resolved.  Looks like there's an incompatibility between the laptop and McAfee which isn't great given that the Dell is bundled with it...  At least I don't have this very annoying problem any more.