Latitude 10 - Boot to USB


Laptop computer Forums (Audio, General Hardware, Video)

Latitude 10 - Boot to USB

This question has suggested answer(s)

I recently received my Dell Latitude 10 Tablet. I have created a USB install of Windows 8 Pro. The tablet cannot boot to USB. I have tried multiple USB drives and have verified the drives will boot on my Latitude laptop. I have verified USB boot is enabled in the BIOS. When pressing f12 for boot options USB is not an option. When entering the BIOS setup it is not listed as a boot device either. Clicking add boot device does not show it either. I've tried using the USB port on the table and the USB ports on the productivity dock. I have also tried creating the install on a SD card, that does not show as an available boot device either.


The bios has been upgraded to A03 and I'm running version,  A04 of the clovertrail chipset. Any suggestions would be much appreciated.


Thank you! 

All Replies
  • Same thing here!  Any response would be great!

    Did this answer the question? Yes
  • What File System have you used to format the USB's with? It will need to be FAT32 to enable the UEFI BIOS to support it. NTFS is not recognised.

    Did this answer the question? Yes No