Dell Instant touch buttons on Inspiron 14R - 5420 - General Hardware - Laptop - Dell Community

Dell Instant touch buttons on Inspiron 14R - 5420


Laptop computer Forums (Audio, General Hardware, Video)

Dell Instant touch buttons on Inspiron 14R - 5420

This question is not answered

Hi Friends,


I recently obtained an Inspiron 14R (5420) system.  I have noticed 3 instant buttons at the upper right side of system above the keyboard.  Of the three, only one is working, the one with the square and star, which I have configured to launch a program.  The other 2 buttons only lights up when press but theres no functionality.

Can anybody tell me what is the purpose of these 2 buttons ?

Hope to hear from you.





All Replies
  • Hi fervde,

    The three button on the top right corner are Quick launch buttons. The first one is Windows Mobility Center Launch Button, second one is Preset Audio Mode Launch Button and the third is Dell Instant Launch Button (this is User programmable). I suggest that you reinstall the 'Quickset' software to have this issue fixed. The following steps will help you in reinstalling 'Quickset':

    Go to Start menu> Control Panel> Programs and Features. Once the program window opens, search for 'Quickset' and uninstall that by right clicking on it. Once done, restart the system and download the 'Quickset' software from the following link:

    Restart the system and check the functionality of the Quick launch buttons.

    I hope this helps.

    Please let me know in case of any queries.

    Thanks and regards
    Harish R

    Thanks and Regards,
    Harish R
    Dell Social Media and Community Professional
    Order Status :
    Download Drivers :

  • Hi Harish

    I also have similar problem on my Inspiron 5420 which I purchased recently, and only two of the quick launch buttons work, ie the one for the mobility center doesn't work.

    I tried out uninstalling and reinstalling the quickset64 software and restarted the system but it didn't help. It is still the same as before.

    So, i wanted to know what the problem is, and if there is any other solution.



  • This problem still exists - just purchased an Inspiron 17R Special Edition that has the same issue.  Pity you can't customize these - that would make Windows 8 an easier pill to swallow.

  • Have the same problem here. I would really like to use this button, isn't there any other way to activate some functionality here?


  • how do i change the 3rd button's config...i have configured it to mute which i would like to change...

  • press and hold it for around 5 seconds.