Dell XPS 14: My rear USB port stopped working, but my other works.


Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 14: My rear USB port stopped working, but my other works.

This question is not answered

I was playing a game of Diablo 3 and I realized that my laptop was getting hot. I have my laptop cooler (because Dell laptops get unGodly hot) plugged into my rear USB port and my mouse plugged into my side port.

Well, my port stopped working sometime while playing Diablo 3. I tried plugging other things into the port and nothing works. I don't even get a message, sound, or anything. My side port seems to work fine, though.

As I said, the USB port was working fine earlier and it randomly just stopped working. 

I tried restarting and restoring to an earlier point. I also went through the device manager and set all the power options on the usb roots so they couldn't turn them off due to power.

I don't know what else to do, and I find it odd that my port would just stop working like it did.

Help is appreciated.

All Replies
  • Hi imthedan,

    Welcome to the Community,

    So its the USB 2.0 port which is on the rear of the system.Apart from what you have tried already you can try Disable and re-enable the USB controller.This lets the controllers recover the USB port from its unresponsive condition.

    To disable and re-enable the USB controllers, follow these steps:

    1.Open Device Manager

    2.Expand Universal Serial Bus controllers( Note :You might have to scroll down the list to find this item).

    3.Right-click the first USB controller under Universal Serial Bus controllers, and then click Uninstall to remove it.

    4. Repeat step 3 for each USB controller that is listed under Universal Serial Bus controllers.

    Restart the computer. After the computer starts, Windows will automatically scan for hardware changes and reinstall all the USB controllers that you uninstalled.

    Check the USB device to see whether it is working.

    Let me know if this helps.

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community

  • Thanks for the help!

    Oddly, it started working last night somehow. I tried everything and was ready to give up. Then I plugged my mouse in and it started to work. I don't know why... but it actually works.

  • Glad its working.

    Please post back for any other help.

    Dell | Social Media Outreach | Global Social Media & Community