Dell touchpad causes cursor/mouse to move/select items on its own

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell touchpad causes cursor/mouse to move/select items on its own

This question is not answered

Hello. My Dell Lattitude laptop acts "possessed"- without touching the USB mouse, touchpad or pointer, the cursor moves and icons are selected/clicked on its own in all programs. An IT friend said it was probably a hardware issue with the touchpad so I turned off the touchpad and pointer and the problem is solved. I know 100% that I am not accidently touching the touchpad and pointer when the computer selects things. I have tried different mice and the same problem occurs.It is difficult to have to use a USB mouse everywhere. Are there any ideas to fix this or do I need to see if dell will replace the touchpad/pointer since the laptop is less than one year old. Thanks.

All Replies
  • Hi,

    Welcome to the community

    What is the model of your latitude? I can try to help you getting the service warranty for this laptop. Please accept my friend request. And send me the service tag of the computer. Glad to help.

    Regards,

    Dell | Social Media Outreach | Global Social Media & Community

  • I just did the update on my computer of the software for the mouse and a few other things recently through dell website. These last few days, my mouse on laptop is moving by itself. I feel like I have a virus or spyware but my comodo firewall or Microsoft security essential and malewarebyte havent made sent up any type of warnings. So now I can assume that something is wrong with the dell software that I recently installed. By reading other peoples comments on this issue, it clearly is a dell mouse pad problem.

    Here are a few comments by user on cnet forum:

    "Touchpads on Dell laptops are notorious for this problem. A slight vibration caused by the disk drive causes the touchpad to move the mouse. See if you can disable the touchpad (From right mouse button menu on the My Computer icon, Manage, device manager) or from the Mouse icon in the control panel."

    "Switching off the ''Enhance Pointer Position'' in the mouse section of Control Panel seemed to fix this problem for me."

    "I found the solution for Mouse move my itself or eratically. On XP, go to contro panel, click on mouse then check mark the Disable the Touch Pad/ Stick when USB pointer in use. Then upgrade the driver from the manufacture."

    I guess, you can try these last two steps, which I will see if they work for me. And then I will post again.

    Hope it helps you.

  • Alex,

    Thanks for the post. I spent a long time trying to fix this damn problem on my dell touchpad. By following what you wrote:

    "I found the solution for Mouse move my itself or eratically. On XP, go to contro panel, click on mouse then check mark the Disable the Touch Pad/ Stick when USB pointer in use. Then upgrade the driver from the manufacture."

    My mouse is working without moving like crazy again. I hope others can benefit from this answer.