Latitude E6400 BIOS update not possible


Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6400 BIOS update not possible

This question has suggested answer(s)


I'm trying to update my Latitude E6400 to the latest BIOS revision A32 from A31, but it is not possible. Whenever it restarts and the BIOS flash program comes up, I get the following error:

"The BIOS update could not be performed, because a valid ROM image file could not be found."

After getting this error by trying to update from Windows, I tried it from an bootable USB stick, but that doesn't help. I tried several switches, "/forceit", "/forcetype", "/jabil", but they don't work either.

Then I tried to reflash the same version which is already installed, A31, and this also doesn't work anymore! Same error! I never got a problem like this, I started with A03 or something like this several years ago and flashed every single BIOS revision without any problem since then.

I remember that I activated the new feature of BIOS revision A30, the new "signed firmware update" feature, which can't be deactivated anymore. And it was possible to flash A31 after activating this security feature.

But now, I'm stuck with A31 and can't flash ANY BIOS revision, not even A31 itself. I tried loading the BIOS default settings, but that doesn't help.

Any suggestions?

All Replies
  • No ideas?

  • こんにちは。









  • My computer is Latitude E6400 and during updating the Bois from A31 to A32, an error as mh001 occurs. I have reinstalled the OS and it does no  difference as before.

    So anyone can supply a accessible way to carry out this updating procedure?