Dell XPS 13 TrackPad Issues after Driver Update - General Hardware - Laptop - Dell Community

Dell XPS 13 TrackPad Issues after Driver Update


Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 13 TrackPad Issues after Driver Update

This question has been answered by SteveClow

After updating my XPS 13 Ultrabook's Cypress drivers to the newest drivers released yesterday on the Dell Support Downloads page, all gestures (Though still enabled) have stopped working. The trackpad itself still seems to work fine after the driver update, but no gestures work any longer. They all worked right before the update.

I've tried the normal set of enable/disable, reboot, update. But has anyone else had this problem or know how to resolve?


Verified Answer
  • After much investigation, and the help of Terry B with sending me a second XPS 13 and taking my previous one back to the lab, I've found that the issue is actually one with my Antivirus software. I use AVG, and I'm at a loss to explain how, but I can restore scrolling and other gestures by uninstalling it. I can reproduce losing them agian by installing it agian and preforming a reboot.

    I'm at a loss as to why, AVG allows the driver to start up and function properly by any other measure, however, I'm back to two fingers scrolling through web pages for a new virus scanner!

All Replies
  • For me, Cypris track-pad driver improved palm rejection, allowed me to use word & excel with "click to tap" enabled (previously when enabled I would get random mouse movements and random button presses). It does seem to have disabled some 2 finger gestures (I don't use 3 finger gestures. With, I can zoom but I can't scroll using 2 finger gestures.

  • Same here, My zooming is working and My scrolling is not. Palm rejection has not been an issue at all since I updated the driver.

  • Scrolling died for me as well. but zoom still works :( however zoom works flawless now.

    Funny thing, after i deselect enable Multi-gestures and click apply they still work. 

    Also enabling side trackpad scrolling and bottom scrolling makes touch-pad freeze for a couple of seconds.

    PS: All of this using Win8 CP edition. Everything used to work pretty well with A06 driver on Win8. 

  • On another note;

    whenever i try to side scroll in METRO UI, the computer first erratically scrolls, then opens up the search bar and types in random letters, while all of that is happening, track-pad is unresponsive, however all of the input that i do, will be reflected on the screen with a lag.

  • I actually decided to wipe the OEM install and do a fresh install of Win 7 with the latest drivers from Dell all the way from  he start.

    The scrolling originally worked, but it appears that after doing the rounds of windows updates necessary to bring the system up to date, 2 fingered scrolling broke. So this would seem to be an issue of one of the hundreds of windows updates that gets applied to a fresh system seems to cause the scrolling to stop working.

  • I am having the same frustrating problem with my new XPS 13 ultrabook, but with the original Windows 7 OS; after installing the new Cypress drivers (3/21/2012 release date) I can no longer use 2-finger scrolling.  Settings show that it's enabled, but it doesn't work.  Only seems to affect vertical scrolling also, as horizontal works.

    Dell has been NO help thus far.  Spent a significant amount of time on the phone with tech support to no avail.  They want to replace the touch pad, which seems pointless, since it clearly works (and did work until the driver update.)

    I have reproduced the problem multiple times.  When I first received the system and installed the new driver, scrolling worked and all functions were flawless.  At some later point (probably as other updates were installed) scrolling stopped working.  Only solution was to restore the factory image which brought back the original sluggish, but working functionality.  Did the same thing and updated the driver and same thing happened.  Restored the system AGAIN and did not install the new driver.  Called Dell and as stated previously, they were no help.  They recommended that I try again to install the new driver and if that didn't work I could re-install the old one from the CD.

    At this point everything else on the system has been updated and all my files installed.  I loaded the new driver, rebooted and bam, NO vertical scrolling!  Tried to install the old driver and still no scrolling!  Luckily I had enough sense to create a restore point prior to doing any of this and restoring back to that point brough back scrolling, although sluggish as before.

    So, at this point Dell says that's the newest driver and they appear happy with it, even though it doesn't work correctly.  No plans for a fix I'm told.

    At this point my choices are; 1) keep the original driver which offers sluggish performance,, but allows 2-finger scrolling, 2) install the new driver, which has better response, but doesn't allow 2-figner scrolling (which is something I absolutely can't live without as I use it all the time on my XPS15, or 3) return the machine and give up....?

    If anyone has any other suggestions or help I would greatly appreciate it.

    Pretty happy with the machine other than this issue.



  • When I called support I discovered that because I had just purchased the laptop I had 60 Days of free premium support. The premium support guys actually remote into the computer and try to address the problem. Honestly after watching them working on it for well over an hour I just gave up. Clearly Dell did not have any idea how to fix this.

    What seems to be odd though is the number of people it appears to be working for despite windows updates. I'd wiped my system clean and did a fresh install and updated the track pad driver first, then caught up on my windows updates. I'm now wondering if I waited and did the windows updates first, and then updated the track pad if I'd still be encountering the issue. I may try for another fresh install of Windows and try agian.

    BTW there is an owner's thread over on going where I asked the same question. No answer though, even though I know at least one dell Representative was monitoring the thread at one point:

  • I am sorry to read that you all are having problems with finger gestures not working after updating to version A01 of the Cypress drivers.  Thanks for reporting it.  I will send your posts to engineers and hopefully can come up with an answer shortly.


    Specialize in Laptops, Mobile Devices

  • Thanks for reply Terry, My specs on laptop are i5 with 128gig running Win8

    maybe that will help.


    Sincerely German S. 

  • I have the same model, but I am running Windows 7. I've had the issue on the factory install and then later on the clean Win7 install that I preformed.

    On the Factory install, I had the problem after running windows update, and it affected the Original Driver install. When I upgraded to the newer drivers it did not go away. When I did the clean install I upgraded the track pad drivers first thing before windows updates, and had the issue only after the windows updates.

  • I have the i7 with 256ssd.  Everything works great, except the trackpad.  The scrolling worked for a couple of days after the updated driver install, but after that nothing seems to work.  No 2 finger or 3 finger gestures.  Scrolling, if turned on, is a nightmare, cursor jumping all over the place, like chicken with its head cut off. NICE.  I have disabled everything.  Works like a 5 year old trackpad now.  It works, but, I can't wait to get my mouse, so that I can actually do something.

  • I am still waiting a reply from engineering.  I will post here as soon as I receive any updates.  Happy Friday everyone.


    Specialize in Laptops, Mobile Devices

  • I have a 128gb windows 7 pro 64bit. Thank you!!!

  • I am having the exact same problem. The gestures did work but have now stopped working. Only thing that works is the two finger horizontal scrolling

  • It was after I installed a windows update that the gestures stopped working so Dell just needs to release a new driver for the trackpad that is compatible with whatever the update was.