Can't Boot my Inspiron from USB? Seriously?? - General Hardware - Laptop - Dell Community

Can't Boot my Inspiron from USB? Seriously??


Laptop computer Forums (Audio, General Hardware, Video)

Can't Boot my Inspiron from USB? Seriously??

This question has suggested answer(s)

I have installed the most current BIOS available from the Dell website for my Inspiron 7500, which upgraded it from A06 to A14. The only apparent effect was to spiff up the Dell graphic in silent boot mode... no new options/capability whatsoever in the BIOS itself.

The whole point of this endeavour was to get the capability to boot from a USB device, which does not even appear as an option in my previous or current BIOS. This seems pretty ridiculous, since the system clearly recognizes a bootable hard drive in an external USB enclosure, can read and write from/to it, and recognizes files on it as being system files, etc., as appropriate.

Is there a BIOS upgrade/replacement available for this system that will allow boot from USB? This would be a MAJOR breakthrough for me! Thanks for any/all advice.

All Replies
  • If the BIOS does not support boot from USB you can try using the Plop-Bootmanager.It works perfectly on my 7 year old Acer laptop.



    I used the following option to install Plop(because this option does not change the MBR)

    "3.Windows boot menu (NT, 2K, XP, VISTA and Win7)"


    It's worthwhile studying the manual and make sure that you backup your important files

  • Thanks for your reply MicroTest.

    I tried the Plop Bootmanager, with no success. When I select USB as the boot device, it says "No Boot Device Found, Please Re-Try It". Nevertheless with a normal internal hard drive boot the system sees/recognizes the external USB drive and all its contents.

    Note that the OS on the external USB drive is Windows 98SE, and on the internal hard drive is Windows XP. Is that the problem? What's the point of an alternate boot device if it can't run an alternate OS?

    Thanks again for your input and any additional comment

  • I don't think that it is possible to boot Windows 98 from a USBstick - I have never tried it but there might be some workaround on the internet.

    A good source of USB information is this site


    To test if the Plop bootmanager works on your machine in general visit

    Download "YUMI" and create a bootable disk with one of the many applications available.I would try "FREE DOS" or "DBAN" (Drive Nuker) as they are very small in size and quickly downloaded.You could also install a Linux distribution that's offered in the list but depending on the age of your laptop the graphic card might not be supported when loading Linux.(LinuxMint10 runs perfectly on my Acer but LinuxMint 11 and 12 don't - distorted screen)

    Anyway - as soon as Plop has access to the YUMI boot menu you know Plop works.....


    If you need Win98 for some older programs you could install VMware player(it's free) and run Win98 in a virtual box - for instance I run WindowsXP inside Windows 7 - that way I can still use my "beloved" software from the good old days...

    Read the manual and check if your laptop meets the requirements VMware player needs

  • Was just googling - don't know if it works, just read some comments...

    but you will still need Plop !! So test Plop with YUMI first