Auto Disable Synaptics Touchpad when USB Mouse is connected

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Auto Disable Synaptics Touchpad when USB Mouse is connected

This question has been answered by Eddiecutezt

HI

Anyone any idea how to get the " Auto Disable Synaptics Touchpad when USB Mouse is connected" feature active again.  I found an old entry in a forum that referenced changing a setting in Registry to Hex 33 and implied that this would make the OPTION become visible in the Mouse settings in Control Panel.  But  it appeared to simply disable the touchpad ALL the time.So I assume Synaptics have changed things since this 'fix' was posted in 2009 I think. .

I have W7  XPS,  and Driver version 15.3.22.0 for Synaptics Touchpad. 

Cheers

K.

Verified Answer
  • SOLVED SOLVED SOLVED!!!

    All - I've read through this and many forums and have found no solution. I figured it out on my own, so I am happy to share with you!

    This solution applies to those who do not have a touchpad disable button on an F key at the top of your keyboard and have the Synaptics driver that does not show the option to disable the touchpad when the external device is present. This also applies to those where the registry key update does not work (as it did not for me).

    Here's the solution.

    1. Go to the Dell website and get the latest driver for your touchpad. Install it.

    2. Once installed, go to c:\program files\synaptics\syntp in your windows explorer.

    3. Open the program called DellTpad.exe (there is also one called DellTouchpad.exe -- don't use this one)

    4. Once open, click Device Settings.

    5. And voila, the old checkbox is there at the bottom! Just click to make this active and it works like a charm.

  • Whats the name of that dell touchpad driver shown in the video. i need to download it. thanks

All Replies
  • Hi K,

    Welcome to the Community. Please add your system model/OS when posting on the Community. You should find that settings in control panel, mouse, touchpad settings. If you do not see it there, you may have to uninstall and reinstall the Touchpad drivers. To uninstall, click on start, right click on computer, click on properties, click on device manager, click on the symbol next to pointing devices, right click on Synaptics touchpad, and click on uninstall, click ok to confirm. Once its removed do not restart the computer, but log on to support.dell.com, click on home users, drivers and downloads, enter your service tag, and download the synaptics driver which will be under Input. After installation restart your computer, and then go back to start, control panel, mouse, click on the touchpad image ( it will take some time to appear ) there you should have an option to check disable touchpad when a USB mouse is connected.

    Thank you

    Royan

  • Thanks for the info..

    I cannot uninstall until I can get the driver from Dell and, bizarrely,  the online DELL system will NOT accept the TAG value. 

    Thisis a new LATOP,. I have a separate question with Cust Services. But unitl they recognise the TAG I cannot get at the correct driver. 

    I thought I added the model.  Sorry..      Laptop XPS 702X , W7.

    The settings required are definatley not in the Touch pad setitngs via Control panel.

    Cheers for reply.
    Kev.

  • HI agian....  reinstalled Synaptics driver.  No effect.  No option to disable when USB connected.  Sames as before.

  • So my conclusion is that this is NOT POSSIBLE.  THere appears to be no feature on any config or settings screen for the Synaptics Touchpad that will 'disable' the touchpad when USB mouse connected.  Unless someone can guide me to an option ?

  • As Dell-Royan already mentioned there should be an option to disable the touchpad when connecting an external mouse.Here is an example for an inspiron 1545

    at  0:30 you see the option at the bottom of the video