Dell XPS 15z no upload speed over ethernet - General Hardware - Laptop - Dell Community

Dell XPS 15z no upload speed over ethernet

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 15z no upload speed over ethernet

This question is not answered

Within the last couple of days my 3 month old 15z hasn't been able to upload over a wired ethernet connection. My usual upload speed is around 0.4Mbps but now it's barely getting 0.04Mbps.

This only happens with an ethernet connection, wifi still works normally and all the other devices in my house including 2 desktop pcs are fine too. I've tested it with 3 different ethernet cables and all of them have the same result.

Normally this wouldn't be a problem but the response time of the wireless connection instead of wired is just too slow for what it's usually used for.

All my drivers are up to date, temp fiels are clear, all unnecessary programs with an active connection were closed. I also called Dell technical support and after around 40 minutes and a shared desktop session all that happened was that my wireless connection is a tiny bit faster.

I think this might be caused by a problem with the laptop's network card but I don't want to try opening the laptop in case it voids the warranty.

Any advice?

All Replies
  • Have you tried updating the network drivers?

  • I have the same problem. Just bought a Dell XPS 15z and I only get around 0,19 mbit/s upload speed on the ethernet cable (both on test sites and uploading to youtube, facebook, dropbox etc.) on a ADSL2+ connection (24/1 mbit/s down/up). Spent two hours on the phone with the ISP to trying to figure out what was wrong with no result. Now I plug the cable into another HP laptop and suddenly the upload speed is up to 0,77 mbit/s - not fantastic, but a lot better.

    So my conclusion is that it has something to do with my dell laptop - any suggestions of what to do?

    Thanks in advance.

  • Wow, when I switch to wi-fi my download speed drops down to 7 mbit/s (before 15), but my upload speed increases vastly to around 0,8 mbit/s (from 0,19).

    So to summarize: It's something to do with the ethernet connection in the Dell XPS 15z - whether it's hardware or software to blame is still unclear. I have updated all the network drivers to the latest version, still the problem persists.

    Any ideas to how I can narrow it down further?

  • Ha, I found the sinner!

    It's the program HotSpot Shield that makes a virtual vpn to allow you to surf anonymously on the web. Thing is, the vpn apparenty limits the upload speed, and this seems to be the case AS LONG AS THE PROGRAM IS INSTALLED ON YOUR COMPUTER. 

    What did I do to find out?

    First I formatted the whole pc and thus experienced a normal upload speed. Then I began installing all of my programs again and suddenly the upload speed was back to 1/5 of before. Natural to assume that one of the programs is the sinner. I don't know why, but my suspicion fell on HotSpot Shield as the first one (it's so packed with ads that makes you think: this software just can't be any good). And it looks like I nailed it in the first try. After uninstalling the program my upload speed is now back to normal. Jeez what a mess over a small program. 

    The strangest part is that it only affects the ethernet cable connection and not wi-fi...

    Hope this can help some people save the time that I didn't. 

    Cheers.

  • I am having exactly the same problem

    Where is this program, I can't find it, is it a Dell installed application?

    Thanks

    Trevor

  • No, it's a separate program, so if you don't know it chances are that you don't have it installed. It's called "HotSpot Shield" and you should be able to find it via the Control Panel - Uninstall programs. I doubt the hardware is to blame - it's possibly got something to do with some software you have installed.

    Cheers

    E.