Vostro V131 Video Flicker

Laptop

Laptop
Laptop computer Hardware and Software discussion

Vostro V131 Video Flicker

This question is answered

Hi I have a brand new Vostro V131.  It seems like the screen flickers and is jittery when on battery mode, but it seems to disappear when it is plugged in.  What should I do.  It's less than a week old?

Verified Answer
All Replies
  • Hi Dellnewb,

    Welcome to the Community. I suggest you update your Bios and your Video drivers and let us know if that helped. Below are the links for drivers for your system.

    support.dell.com/.../driverslist.aspx

    Thank you

    Royan

  • thanks.  it looks likes there is a newer version that was causing the problem. I reverted back to the older version found on Dell's website and it fixed my flicker issue in battery mode

  • I am facing the same problem. I purchased Dell vostro v131 few days ago and the screen fickers momentarily while on battery mode... Please help me resolve this issue..

  • Well i had same problem, how i solved it

    1. right click on display/graphics properties/(go in advanced mode)/power/ choose battery and uncheck intel saving technology.

    Somehow shimmer was rarer but still there.

    2. choose baterry icon/more power options/hide additional plans and choosed high performance.

    Now the shimmer is gone.

    I haven't updated bios, maybe I should, but somehow i haven't done it before and i know it's dangerous.

  • Hi,

    I have the same problem as you guys and it drives me crazy. Choosing high performance plan isn't the real solution. When I'm on battery the most important thing for me is to extend battery life as much as possible so that why I use power saver. So is there any solution?? I have latest video drivers and bios updated as well.

  • Was anyone able to resolve this? Driving me crazy!

  • Try this: Adjust the Intel video settings in the power plan to Maximum Performance on battery (via Balanced profile) leave all other settings the same. Worked for me and has not really had any impact on battery life.

  • Thanks, that did the trick! Must be a software problem with the latest Intel HD3000 driver.

    The option is in Control Panel --> Power Options --> Change plan settings --> Change advanced power settings --> Intel(R) Graphics Settings (select Maximum Performance).

    The HD3000 is power efficient already, so I doubt this will really affect battery life.

  • I have the same EXACT issue but only with windows 8 pro 64bit no issues with win7.

    I am going to try this :

    The option is in Control Panel --> Power Options --> Change plan settings --> Change advanced power settings --> Intel(R) Graphics Settings (select Maximum Performance).\\