Inspiron 1545 - reset to factory settings without 'Repair your Computer' - General Hardware - Laptop - Dell Community

Inspiron 1545 - reset to factory settings without 'Repair your Computer'


Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 1545 - reset to factory settings without 'Repair your Computer'

This question has been answered by ejn63

I've been handed an Inspiron 1545 (originally Vista-64bit) to try and sort out.  The owner's 'friend' 'had a go' and installed Win7ult on it and this has caused the F8 menu no longer to have the option 'Repair Your Computer' although the restore partition looks to be untouched.

Is there any way I can perform this restore without the 'Repair Your Computer' option or even any way I can get that option back?

I do have the original DVDs so at worst I could do a complete restore from that but it means having to reload all the drivers, etc and would take quite a long time.

Obviously I've already got all data backed up.

Just as background, the reason I want to go back to the original is because the system is far too slow to be able to use.  This is being caused (I believe) by a lot of SATA controller errors (I've checked the disk and it's fine and works perfectly under other OSs).  It's almost workable in safe mode but normal mode can take half an hour to start up and then half an hour every time it tries to do anything.  Additionally, I don't think this friend actually installed a valid Win7 version.  I suspect he didn't install the correct drivers which is why it's behaving so badly, though, of course, it could be a real hardware issue.

Verified Answer
All Replies
  • There is, yes.  You will need a Windows DVD to do this.

  • Many thanks, I'll give that a try.  I felt sure there must be some way of getting it going!

  • In case anyone else heads down this line, I had a few teething problems when I tried this.

    I tried to use the Vista reinstall disk but couldn't get to where I needed to be because there wasn't a Vista installation to repair (it was now Win7)

    I tried to use a Vista repair disk but again that gave the same problem.

    I then tried a Win7 disk and that got me to the required command prompt but it wouldn't run imagex because it said it was the wrong OS.  I assumed because it was for Vista and I was running Win7 but that wasn't the case... it was because it was 64bit and I'd used a Win7-32 bit disk.  When I tried again with Win7-64 bit I was able to do the restore.

    Why do Dell/Microsnot make it so hard to do this?!  :-(