Dell XPS 15z CD eject button doesn't work, Help Please. - General Hardware - Laptop - Dell Community

Dell XPS 15z CD eject button doesn't work, Help Please.


Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 15z CD eject button doesn't work, Help Please.

This question is not answered

Hi all, I just bought a Dell XPS 15z and the CD eject button doesn't work. (I pressed function key+eject key on the keyboard as instructed in the manual.)

Tried to update my keyboard drivers from the cd provided but there isn't any keyboard drivers in the cd... CD can be ejected by right clicking on the dvd drive and choose "eject".


All Replies
  • Hi Zhuter18,

    Welcome to the Community. You may need to update you Quickset Drivers, use the below link to download and update it from the support site.

    Hope this helps.

    Thank you


  • My Dell XPS 15z has an eject key between F12 and Insert keys on top row, i.e. third key from right on top row.

  • I was exploring my 15z and saw that the hinge under the screen, on the right hand side, was not straight. I pushed on it (pushing it upward), and it ejected the DVD. I can't find the documentation for this, but it works.

  • I think you just push the eject key. You don't need to push the function key too.  Or so I think any way. I just got the same laptop and I'm still figuring it out. Smile

  • I just received my new XPS 15z and am experiencing the same problem. The CD eject key worked for the first couple of days but now it does nothing.

    I attempted to update my Dell Quickset Drivers as advised in the forum, but was warned that my drivers are newer version than able at. As I said, my laptop is brand new!

    Thank you kindly for any advice,


  • You can eject by going into file manager, right clicking the DVD drive, and selecting the eject option.

  • Thanks tugela01, the eject function works fine from the menu option, nevertheless I do feel that the eject key should also work. I do wish Dell, would simply say, "yes" we know there is a problem and we will advise when a fix has been determined/tested. Is this asking too much; for a company to stand behind there product?

  • My computer is less than a week old and I'm having the same issue. It seems as though its the simple things that go wrong with this computer... I, too, think the eject button should work. Between that and the spastic touchpad, I'm thinking my xps m1530 was better. Too bad it crapped out on me. I would think the newer xps would have been better than the older one... I'm questioning it.

  • Hey Dell - get it together! People are posting the SAME issue over and over, and yet...NO REPLY.  This is my 3rd XPS notebook that has had horrible issues with CD eject. I'm starting to wonder why I keep coming back for more.  This may be my last.   

  • Oh, Dell support canon... where is normal answer? i too have this problem from 1st day when i bought xps 15z.

    Please Show your respect. This model is a premium class and support should be appropriate.

    thank you.

  • thousand apologies. download i download update.. now problem fixed. sorry again.


  • Thankq dude.. it worked.. :) Smile

  • This link is invalid. Why doesnt Dell fix this issue? If you run QuickSet then your system video settings get set to Windows Basic. I can't believe there isn't a solution for this and that Dell hasn't figured it out yet!

  • I can't believe it has been this long with no fix. The eject issue just started for me. I did a format and re-install on my computer which does hint at it being a driver issue since I got the latest of everything.

    Maybe we need to revert to an older and see if that works.

  • I just found my old drivers disk and used those, now the eject button works with no problem so far, and I have been throwing dvd's in and out of there like it was an XXX rated movie!!!