Vostro 1520 will not charge battery - General Hardware - Laptop - Dell Community

Vostro 1520 will not charge battery


Laptop computer Forums (Audio, General Hardware, Video)

Vostro 1520 will not charge battery

This question is not answered

I have just gotten my third house call on the same problem and just hours after it was fixed, the same problem occurs again. BIOS says the battery can not be identified and cannot be charged. Running on AC alone works so the AC adapter is clearly out of the picture. I have already tested the same battery on my friend's laptop (Same model thankfully :D) It worked fine, not problems whatsoever. I tried his on my laptop, same thing, it would not charge. The laptop would boot on battery power itself, but would not charge on AC. I figured it would be the motherboard. I have had to talk with dell 3 times to replace my motherboard. They replaced it twice, the third time was something different(They input the service tag). The problem was fixed after the third house call. I thought my nightmare was finally over but it wasn't -.-


Dell chat is useless, Calling dell is a pain because their tech support either has terrible accents or will push you to buy their merchandise. I don't know what to do. I'm sure it is the motherboard, but I just don't get it. I don't want to waste anymore time with dell tech support because I know I won't get anything useful from them. 

All Replies
  • If the system BIOS does recognize the AC adapter (i.e., it's not showing "unknown") then chances are it's the battery that's the problem.

    If the system is showing "unknown" for the adapter, it's either the adapter itself, or the mainboard that's the problem.

    If the battery is original to the system, it's well beyond its expected lifespan and due for replacement.

  • The battery works fine, I tested it on my friend's vostro 1520. It charges and works perfectly

  • Does your system correctly identify the AC adapter (F2, bios setup at powerup)?

  • yes

  • I had a similar problem and fixed it by straightening the battery connector pins on the bottom of the PC.  I used a small wood matchstick to make sure all pins were aligned perpindicular to the bottom.  Then I reinserted the battery and it began charging.