Dell XPS 15 - USB 3.0 Problem - General Hardware - Laptop - Dell Community

Dell XPS 15 - USB 3.0 Problem


Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 15 - USB 3.0 Problem

This question has been answered by Phylter00

 I have just purchased a Dell XPS 15. I decided to buy a 2.5" USB 3.0 caddie to plug my existing laptop hard drive into so I could transfer the data across. The drive from my old laptop is a 500GB hard disk. 

When you plug in the caddie with the 500GB drive in, you get one of two things happen. Either the driver fails to install, or the drive is not detected what so ever. 

I work for a Dell reseller so we have other Dell XPS 15 laptops in stock, so I decided to test on one of those and it does the exact same thing.

I decided to change the hard drive in the caddie - I changed it for a 160GB hard drive - this works absolutely fine on USB 3.0.

I put my 500GB hard drive back in the caddie and plugged it into my friends desktop system which also has USB 3.0 - it works absolutely fine which confirms it is not a fault with the caddie.

I decided it could need either a bios update or the latest USB 3.0 drivers installed. On checking on the website the latest bios is A03 which is the version I already have on my laptop. I checked the drivers under chipset and found "Renesas USB3.0 Host Controller" - I downloaded and installed this but during installation it pops up saying:


My next diagnostic would be to put another 500GB hard drive in the caddie of a different manufacturer (current is Samsung) and see if that works to confirm if it is a compatibility issue, or if the system cannot handle a 500GB hard drive in the USB 3.0 port. Unfortunately at the moment I don't have a spare 500GB drive.

Can Dell give any clarification on this matter? Do any of Dells other laptops use the same controller for USB 3.0 as the XPS 15?

Verified Answer
  • I just got a Dell XPS 15 today. I connected a USB mouse and used it for a few minutes and then nothing. The USB mouse didn't seem to be recognized anymore. I tried both USB 3.0 ports with the same result, the mouse wouldn't work. I connected the mouse to the one USB 2.0 port (right side) and it worked just fine. This is a Dell USB mouse and I've used it on two other computers frequently and without issue. 


    I wonder what's going on with the USB 3.0 bus controller.

All Replies
  • I am getting really tired and angry whit the USB 3.0 problem. No Solution from Dell for a well-known problem and no answer to my emails to the technical support. I am getting really really angry.

  • I have a dell XPS 17 L701X. Impossible to use the USB3 slots as USB3. They work as UBS2. Installing the Rersenas Version does not do any good. I can see from a parallele forum taht this is a generalized problem with these machines. Do you have a better idea? I went through the usual route with Dell support for several hours and I am still frustrated. Nobody was able to help.

    Thank you for any help you might provide.

    Serge Gracovetsky   <ADMIN NOTE:Email id removed per privacy policy>

  • I have the same issue with iomega ego 3.0 500gb drive. 

    I get this intermittent error in event viewer Event ID 51, "An error was detected on device \Device\Harddisk1\DR10 during a paging operation." 

    When I connect the hard drive on usb 3 plugs I get this error, but it's ok on lateral usb 2 plug. If I plug a usb 2 device on the usb 3 controler, it's ok.  I updated the firmware to Version, and used the dell drivers in the link given as well as the older drivers with no luck.  Any help would be appricated. 

  • I also have the same problem with the 500gigs Iomega USB3 that I bought with the XPS 17 L701x. I hope the Dell technical people take it seriously. If not, I will return the laptop because the USB3 port is a deal breaker for me. Since the system is now three weeks old, returning it should be no problem because Dell has made performances promises that it cannot deliver. I will then either wait until another Dell machine comes without the USB3 problem or buy from somebody else. The whole thing is ridiculous. Is there anybody at Dell listening and willing to reply with a solution????

  • I doubt Dell will pay any attention to this, that''s just the way they do things.

  • This is the epilogue to the USB3 problems that I had with my Dell XPS17 L701X and the Iomega 500gig USB3 drive.

    I had all the symptoms described by many in this forum. I spent many hours talking to Dell technical people. We tried many avenues to no avail. I was very frustrated and got a return authorization number for my laptop and I intended to pack everything back to Dell after Xmas.

    Then I had a doubt because many years ago, with my old Dell Inspiron under XP, I had a western Digital USB2 that gave me a lot of trouble. I circumvented it by discarding it and buying a SeaGate and everything went fine. Consequently, I decided that before returning my Dell XPS, I had to try the new Verbatim 750gig USB3 drive model SNG750GB from Amazon with express delivery. I plugged the drive and it mounted immediately. I noticed a flash installation of something by the drive. Since then, the Verbatim USB3 works like a charm. ZERO USB3 problems. I transferred 700 gig of data, cloned the C drive, repartitioned etc.. A full night of work. The drive is still  there humming along. Perfect. So far so good.

    I then re plugged the Iomega USB3 drive. It mounted then after a few minutes the same problems reappeared. That Iomega 500gig USB3 drive will be returned to Dell for a refund since it is clearly the offender.


    The UBS3 problem that everyone complained about is coming from the manufacturer of the USB drives, especially Iomega which is definitely not compatible with this Dell machine. It is possible, as was suggested ealier, that the chipset was too new for that Iomega drive, and this is why I took the latest Verbatim drive, hoping that some consistency would prevail. The driver is the same Renesas My advice to those who are frustrated is to go and buy the same Verbatim 750gig drive that I did.

    In retrospect, I was very frustrated, but with a cooler head I must admit that the Dell technical service was very good and clearly beyond reproach in the step by step debugging process. I cannot divulge the name of the person that helped me because of the rules of that forum. He sent me a new Iomega drive (same symptoms), sent me a new internal SSD (256 gig) just in case something was wrong with my C drive, send me a return authorization to refund me for the computer, spent several hours taking control of my machine, etc.. I can hardly fault Dell. The problem has nothing to do with Dell but the Iomega drive.

    I also realize that it is fashionable to criticize Dell. That would be wrong in that instance. In fact, my bottom line is that my next machine will be a Dell because I know that if I get into trouble, I will receive a fair hearing.

    I have an advice for Dell. I bought the Iomega with the laptop because Dell advertized it as part of the XPS 17 sale. That was a mistake. Dell should immediately remove any recommendation for that Iomega drive, and be more careful in the future before endorsing anything.

  • Hello it seems that some external HDD drives /cases/docks that contains a jmicrom chip are incompatible with the NEc Renesas usb 3.0 chip found on the XPS.
    Investigate before purchasing an external HDD solution. 

  • Hello,


    As explained in my previous post, I don't agree with the assumption that the controller is incompatible with some of the HDD drives because I tried this Iomego eGo 1TB 2,5"  USB 3.0 hdd at the usb plugs of the samsung R510 notebook which has the same renesas usb 3.0 controller and it worked directly fine without any troubles. There might be another reason why it is especially not working on our XPS 15 notebooks. I really expect an answer from the dell techcenter otherwise they will lose their customers.

  • They explained to me that this is probably because of a power issue... Personally I believe that they simply cannot figure out exactly what is the matter.

    Or probably that is the problem of the chip inside the laoptop. I do doubt if they dare to launch a callback of laptops.

  • I need an external HDD dock, but I really do not know which one to buy, I suspect that the Vantec ones are not going to work, due to the JMicron chip.

    It they are not solving this issue, Then our solution right now is to test every external storage solution, and see which ones work with our laptops. Or send the notebook back if any fully functional storage solution is found.


  • Not necessarily because the drive tha caused me problems (and I understand as well as several others) is the iomega 500gig superspeed and NOT the 1 terabits. The controller of the different drives may not be the same.

    Hence the incompatibility mentioned earlier between the drive and teh Rensas controller hardware inside the computer is so far the most plausible explanation. Dell cannot be held responsible for maintaining compatibility with all  the drives on the market. The problem is that Dell did not warn the customers (i.e me for instance) of the incompatibility problems with some drives. My guess is that this will change because by now they are acutely aware of the difficulties.

  • I have the same problem with my new Dell XPS 15.  When I connect my Iomega eGo 1TB USB 3.0 external hard drive and copy photos and videos to this new laptop’s internal hard drive – the copying process freezes and does not even respond to cancelling or closing it.  After researching the problem, I found many people have the same problem that I have and it is believed that problem lies with - the Renesas USB 3.0 host control.

    As many suggested,  I downloaded the Renesas USB3.0 Host Controller drive from Dell website and reinstalled the drive but the problem still exists.   I submitted a support request to Dell on 12/21/10 and they have not responded back to me since. 

    It should not take Dell more than a few days to plug in their XPS laptops with the USB 3.0 hard drives available from major brands to test and make sure they work properly – especially the Iomegar eGo  USB 3.0 portable hard drive that Dell is selling to their customers.

    Dell broke two performance promises when they sold their XPS laptops to their customers:   the usb3.0 and the customer support – either has functioned as promised.  I suspect some of the comments posted on this forum are written by Dell very own staff to excuse Dell from fault.


    I read that "hvp0109" suspect that "some of the comments posted on this forum are written by Dell very own staff to excuse Dell from fault". Since I wrote something that was favorable to Dell after a long frustrating investigation on my own problem, I suppose that the comment applies to me.

    I suggest that Hyp0109 Google my name "gracovetsky" and sees for himself from the thousands of hits that it is not my habit to play this kind of game. I believe my Iomega problem was solved when I threw out the drive since the best logical explanation (first suggested by Pituky but challenged by LordEdward above) was a mismatch between the Iomega drive and the Renesas controller. And again, it is not for Dell to insure compatibility with a specific manufacturer, but to insure compatibility with most of them. My solution was to buy the latest Verbatim 750 gig from Amazon. I have it for 10 days now and I am delighted.

    The problem of Dell has been to recommend the Iomega ego drive. That was a bad mistake. So I suggest Hvp0109 return the Iomega drive and move on. Enough time has been lost on what is now a well know issue and a well known solution.


  • I have the iomega ego 500 gb drive, that I bought with the laptop which was recommended by dell.  I am past the return policy, so what should I do.


    Dell needs to fix this with a driver update, or this will be my last dell.  Sorry I sound mean, but like the poster above said, they should test compatibility if they are going to sell them with the laptops with a discount.  

  • I belive you have a legitimate beef to complain because it has nothing to do with the 30 days return policy of a hiden defect since it is fundamentally a Dell problem. From my perspective Dell acted negligently when it recommended the drive.

    I found with Dell that persistence pays off. Just clim the ladder as I had to do. Overall, my grumbling to Dell paid at less than minimum wage (dividing the refund by the hours on the phone), but since I am retired, I saw it as a sporting event.

    Good luck.

    Nevertheless, to night I will observe a minute of silence on your behalf.