Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Disabling SpeedStep in the BIOS does not work

This question is not answered

Hi,

I have an Inspiron 15R (N5010) laptop and there is an option in the BIOS to disable SpeedStep.
Well, I doesn't seem to work.

When booting Windows 7, my processor's frequency is still adjusted dynamically according to CPU load. I can see this with Core Temp when the CPU frequency is shown in the system tray.

Has somebody here tried to disable SpeedStep in the BIOS? Is this successful?

Thanks.

NB: my Windows 7 power scheme is set up so that SpeedStep should not operate either. Control Panel > Power Options > High Performance > Change Settings > Change Advanced Settings. Under Processor power management: minimum processor state: 100% maximum processor state: 100%

 

All Replies
  • Disabling speedstep doesn't do what you want it to do - it locks the CPU at its lowest frequency.

    You want to set the system to "always on" in the power management in the control panel.  Note:  notebooks ARE NOT designed to run flat-out all the time, and if you do this, you will severely shorten the lifespan of the mainboard, drives, and other heat-sensitive components inside the system.

     

  • You are misreading my message.

    I want to disable the dynamic adjustement of the processor frequency, no matter if my processor frequency is low in the end. I don't care if my processor is slow in the end.

    Disabling SpeedStep is supposed to do just that. And that doesn't work.

     

  • In power settings, set both the minimum and maximum states to 5% (for low speed always) or 100% (for high speed always). If you set it on high speed always, you will get less battery life, and possibly the other problems listed in the last post. I don't think you can lock it into a medium speed, as numbers below 50% are always low and above 50% are high, but you can experiment.

    XPS M1530, Windows 8.1.1 Pro 32-bit
    Inspiron E1705, Windows 8.1.1 Pro 32-bit
    Dimension 9100, Windows 8.1.1 Pro 32 bit
    Inspiron 660, Windows 8.1.1 Home - 64 bit
    Compaq DX 4370G, Windows 8.1.1 Home - 64 bit
    Asus T100 Tablet, Windows 8.1.1 Home - 32 bit

  • Unfotunately it doesn't work, see my other post, "Force CPU to run at low speed".

     

  • What version of Windows is on the system - and if you installed this yourself, did you install the Dell notebook system software and the Intel chipset driver?  Both are needed for power management.

     

  • Dell's drivers for the Intel HM57 chipset are installed.

    Dell "System Software" is installed.

    I did a few more experiments. When SpeedStep is disabled in the BIOS, the dynamic frequency change will occur regardless of the power options in Windows 7: the frequency will go between 1.3 and 2.3 Ghz. And yes I did say with SpeedStep disabled.

    If I ENABLE SpeedStep now and I set minimum power state = 5%, maximum power state = 5%, my CPU in idle mode will be a 1.3 Ghz. If I run a program that just has an empy loop (while (true) { }), the frequency goes down to 933 Mhz, which is the expected minimum frequency.

    I just don't understand...

     

  • With SpeedStep enabled and both max and min at 5%, I get steady 780 Mhz. Same if both set at 0%. At 59% on Max and 5% on min, I can get 1180 max/780 min. At 79% on max with 5% on min, I get 780/1180/1580. At 100% I get all 4 speeds, 2000 max.

    Try yours with both at 0%. If it won't lock, then there is a difference between our units as to how Win 7 interacts with thew system BIOS, and you may not be able to lock in at a low speed. Setting all at 100% should allow you to lock into the highest speed.

    XPS M1530, Windows 8.1.1 Pro 32-bit
    Inspiron E1705, Windows 8.1.1 Pro 32-bit
    Dimension 9100, Windows 8.1.1 Pro 32 bit
    Inspiron 660, Windows 8.1.1 Home - 64 bit
    Compaq DX 4370G, Windows 8.1.1 Home - 64 bit
    Asus T100 Tablet, Windows 8.1.1 Home - 32 bit