Inspiron Mini 910 BIOS Flash - Now won't power on - General Hardware - Laptop - Dell Community

Inspiron Mini 910 BIOS Flash - Now won't power on


Laptop computer Forums (Audio, General Hardware, Video)

Inspiron Mini 910 BIOS Flash - Now won't power on

This question has suggested answer(s)

Hey all,

I've got a Mini 9, Inspiron 910 with some issues.  I had a 3 cell battery pack that wouldn't charge anymore around 2 months after the warranty expired.  I purchased a 6 cell battery that was compatible in another Mini 9 I had, but would not work in this particular one.  I flashed the BIOS to the latest and greatest (A05 or A06), and found no change.  I then proceeded to try and downgrade to A00 to see if that would work.

Where the first flash was successful, the second downgrade flash started, then the screen went blank.  Power was supplied via a UPS and the power cord or power buttons were not touched.  Now the Mini 9 will not power on.  I don't have a battery in it, and it's plugged in with a known working charger.  No LED's light up and it simply won't power on.  I've pretty much accepted that this is a paper weight at this point, but is there anything I can try?  I've had it unplugged and without battery for a week, and that didn't do anything.

Thanks in advance,


All Replies
  • There are two options- have the BIOS chip removed and flashed externally or replace the system board. Either procedure is likely to cost almost as much as a replacement netbook - so is likely not worth the expenditure.


  • Do you know if the BIOS chip is socketed or soldered?

  • It is soldered to the system board.


  • Hi there,

    Sorry for your pain. I'm guessing you never solved the issue. I appear to have bricked my Mini 9 during a failed BIOS flash to address the popular "won't run from the battery" issue.If you did manage to get your Mini 9 working let me know what you did.



  • NO! Bad information. There is a BIOS recovery feature built into the unit.


    You remove the battery, and unplug the power. Then, you plug in a floppy disk, CD-ROMor USB key with the recovery image (someone from DELL please supply the link).You then hold the fn and 'B' keys and plug in the power. Next press the power button while holding the fn + B keys. The unit should beep and recover the BIOS from the media.


    What we need is for a Dell tech to supply the image with the recovery information.

  • The post above is 100% correct. You do not have to replace the bios chip or trash the computer if your BIOS is corrupt.

    Follow the instructions at the link below.  This process worked perfectly for me.  The only minor drawback is you need a USB floppy drive.  You have to register at "mydellmini" in order to download the recovery utility file.

    Good luck!



  • Thanks for the encouraging post but this isnt working for me. I downloaded and extracted the recovery file onto a floppy disk. When I plug the floppy drive into the mini and hold fcn and B keys as instructed and push the power button there is no activity from the floppy drive or the mini. The power light on the mini lights up but that's it.

    Thanks for any suggestions.


  • Hi there,

    Make sure you do the steps in exactly this order:

    Remove the battery and unplug the AC adapter from the laptop.

    Plug your USB floppy with the recovery disk into a USB port - (I used the right hand side USB port)

    Hold the Fn and B keys down with one hand

    With your other hand plug the AC adapter into the laptop while still holding Fn and B down

    While holding Fn and B, press the power button.

    Release Fn and B - you should see your USB floppy start to work.

    You will hear a series of beeps as the BIOS is restored. When it is finished, it should power down and reboot by itself.

    You have to follow the steps exactly in this order.  If you hold Fn and B while power is applied to the laptop it won't work.

    Good luck!



  • I realize this is an old posting, but figured it was worth a shot ... I recently acquired a Dell Inspiron 910 that starts to boot, but then the screen just goes blank. I see the message at the bottom to hit <2> for BIOS or <0> for boot options...neither of these options work - just a blank screen.  I have created an account on the MyDellMini site and followed the links in this forum, but I cannot download any of the BIOS recovery utilities. I receive an error stating that my account does not have sufficient privileges, but I cannot seem to figure out how to contact the administrator or modify my access levels.  You mentioned that you were able to download these files and I wondered if I had done something wrong.

    If anyone has any suggestions for gaining the necessary rights on the MyDellMini site or knows an alternate location for downloading these files, it would be greatly appreciated.

  • You can do a bios recovery but it requires a usb boot floppy.

    I tried various ways but was only successful with a usb floppy.

     CONFIRMED: Recovery from failed Windoze flash method!

    I recommend you Buy good diskettes and format the diskette using the usb drive BEFORE trying to make a recovery floppy.

    To download the file will require you to register on the mydell mini site but its free so not a big deal.

    NOTE: Requires USB Floppy drive for recovery: ... y%20Drives
    To Use: Remove battery and power adapter. Confirm USB floppy drive is plugged in. While pressing and holding Fn & B keys, attach power adapter plug. The power lights will momentarily blink and your Mini will beep once. Continue to hold Fn & B and press the power button. Release the keys once floppy drive begins reading. Your Mini will beep continually until the flash is completed and reboots. Note: The display is not available during this process.
    Download and extract attached file below:

    Attached Files
    File Type: zip 910_A04 BIOS (600.0 KB, 1647 views)

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

  • Hey guys,

    I just did everything you've told us to do. I created a bootable floopy with an external usb floppy driver, plugged that in and held FN + B etc....

    I've been waiting for about 2 hours now but the screen just stays black after my Mini beeped a couple times. The power LED is lightning tho.

    What to do?


  • I followed the instructions. I turn it on, it beeps, then it accesses the floppy drive. The mini then made a weird buzzing noise through the speakers, beeped twice and that was it. No activity at all after that. What could I be doing wrong?

  • Try using a different USB port to see if that makes a difference.

    You also have to be sure you have the correct software on the floppy drive to recover the BIOS...

  • I do have the correct software (at least according to the other posts). I've tried a lot of different bios versions, all of which have failed. I'm confused as to what I could be doing wrong or if this laptop is seriously just a paperweight now.