:^/ My Dell XPS M1210 is not recognizing its power adaptor. - General Hardware - Laptop - Dell Community

:^/ My Dell XPS M1210 is not recognizing its power adaptor.


Laptop computer Forums (Audio, General Hardware, Video)

:^/ My Dell XPS M1210 is not recognizing its power adaptor.

This question has suggested answer(s)

:^( My Dell XPS M1210 will not recognize the power adaptor.  Upon pressing the start button, the M1210 goes through its Power On Self Test, or POST.  One of the tests is to check that any power adapter connected was built and sold by Dell.  To determine that, the hardware's charging controller circuit asks the charger to identify itself, and compares the reply to an on-board list of known acceptable replies.  If a match is found, the laptop runs the processor at full power and charges the batteries.  Otherwise, the processor is run only at partial power, and the batteries are not charged.

My M1210 has had this problem previously, and I've been able to remedy it by removing all power including the Real Time clock battery, and then holding the power button for a while to drain any residual charge from the on-board volatile memory that holds certain settings, including the list of responses to accept from power adaptors.

Well, that remedy has had to be occasionally repeated, and now no longer works.

:^/ First I'll run through the possibilities that aren't the problem.

• It's not the power adaptor.  That part works fine, but the laptop hardware isn't properly recognizing it as genuine Dell, and so chooses not to support it.

• It's not the operating system, Windows or otherwise.  The trouble occurs during the Power On Self Test, well before the hard drive is even mounted, let alone any attempt is made to boot from it.  So, reformatting, reinstalling the OS, etc., are not the solution.

• It's not a loose connector on the motherboard.  No one has ever been rough with my laptop in the two years I've owned it, and there isn't the slightest looseness to it.

• It's not a different motherboard hardware problem, either. 

The trouble is with the laptop's firmware.  Somehow, the laptop's expectation of what a good charger looks like has become corrupted so that it no longer recognizes a good charger.

:^/ What is needed here is a utility that will re-write the charging controller's firmware so that it recognize good chargers again.  Dell's support pages for my M1210 list nothing remotely resembling that except for the BIOS upgrade to version A08.  However, I already have that installed, and re-flashing it has done nothing.

Where could I find a utility that will allow me to repair the laptop's charger controller firmware?

All Replies
  • It could be a dead battery. Remove it and use just the adapter to test. If you still have problems, the system board might be faulty.

  • :^/ Thanks for responding, Mary.  However, it seems that I could have made the situation more clear.

    The battery currently has a full charge.  The BIOS settings environment concedes that clearly.  The laptop boots and runs fine with the battery out and the adapter as the sole power supply.  However, on powering up, the BIOS reports that it cannot recognize the charger, and that the laptop will run at half the processor speed and not charge the batteries.  I'm then presented with the choice to continue booting, to access the BIOS settings, or to run Dell's diagnostiics.  BIOS reports the adapter as an unknown device, (meaning that the identy code from the adapter doesn't match the laptop's list of approved adapters.) -instead of the 65W that it normally shows.

    When this same trouble occurred a week ago, the situation was readily  remedied by removing all power to the system, including the clock battery.  This allowed the corrupted charger controller data to fade from memory.  However, that trick seems not to restore the proper settings anymore.

    You're correct that there is trouble with the system board.  In particular, the trouble is that when the charger controller compares the correct identiy data from the charger to the corrupted data on the controler, there is a mismatch.  The data on the controller needs to be corrected.  It is not the battery, it is not the charger, it is not the controller hardware, it is the controller firmware's data.

    How do we remedy that?


  • You're being very definitive - presumably that's from having tried another adapter (if you've not done that, you should).  If another adapter (Dell, NOT third party) produces the same error, then the next most common cause is a power jack not making good contact with the mainboard.  This isn't a stored error - it's caused by faulty contact somewhere.  Restore the contact and the error will disappear.

    It IS possible there is trouble elsewhere on the mainboard - but check the adapter and power jack first.  One of those two cause this error in most cases.


  • :^/ It's not the connection.  When running without batteries, a faulty mains connection would produce a flickering screen, staticy audio, faulty calculations, poor hard drive access, USB peripherals performing poorly, and so on.  Charging the batteries would not be the only problem.

    Also, these symptoms would occur no matter who built the power brick.  The laws of physics work the same for everyone, after all.  No, the only place the Dell/non-Dell consideration could matter is when the onboard charger controller negotiates its connection with the power brick on power-up.  One of the tests is to determine the authenticity, or "Dell-ness" of the adapter, and to choose what to do next based upon that factor.  If the adapter is not recognized, the controller chooses to run the processor at half speed, and to not charge the batteries.  And that's the trouble I've been having.  That negotiation is going badly sometimes.

    Now let's consider how that decision is made.  When negotiating their connection, the controller asks the power brick to identify itself, and the brick replies: "I'm a Dell 65W power brick," or similar.  If the response is on a pre-existing, onboard list of acceptable responses, the brick is approved and everything runs well.  If it's not, we get half speed, and no recharging is allowed.

    It's like the clichéd Hollywood party; if your name isn't on the doorman/bouncer's list, you don't get in.  Well, what happens when that list gets corrupted?  Invited guests (or good adapters) get rejected, just as I'm experiencing.

    :^/ For what it's worth, this has been an on-again, off-again trouble, and it's currently off again.  My BIOS recognizes the same adapter again, just as if there had never been any problem.  The only thing I've done differently is to leave it alone for a day after clearing the BIOS data, and using Dell's Quick Set to configure my M1210 to not automatically hibernate nor stand by when the lid is closed.

  • I am currently on my 6th battery charger. They are dell chargers. They work for awhile and then quit as in they no longer charge my computer, and the green light on the charger is not on. However, this last charger I purchased is still working accept it no longer charges the battery. I have a brand new battery in the laptop so that is not the problem. I know we are not the only two out there with this issue. This laptop is for work and I have massive amounts of client information on here that I can't afford to lose. Anything work for you yet?

  • Hi 

    I am having the same problem with my Dell XPS. I am using only the Dell adapter sent with the computer. The computer states that I am using a non Dell adapter. I called Dell to ask about  this. After they confirmed that I was using the correct adapter, they asked me to throw out  the software for it and let it reboot. When I restarted the computer the software was put in again and it was correct. That was about 30 days ago. Since then my whole hard drive broke, I got a new one and now I am back to the adapter problem. My computer can not work at full speed due to it's error in reading which adapter it is using. 

  • I'm having the same problem with a Dell Inspiron 1525 and my daughter has a 1545 with the same problem. I spoke with dell tech support and they don't seem to understand that both work and it's just the laptop not recognizing the adapter. Then they start this "You're out of warranty" and will cost $120 for tech support. This seems to be a major problem that alot of people are having, but dell doesn't want to address that. I bought a new adapter and a new battery for mine. It worked for a few days and it'sno longer working. Also I had upgraded to windows 7, so the dell analyzer doesn't work on my os. Dell should update their firmware so any adapter would be recogized and will charge any battery.

  • Dell was no help-- did not trouble shoot with me over the phone, just said I needed to send the computer to them to run diagnostic best case scenario was 179.00 worst case upwards $400.00 would be without my laptop for 2 weeks. I run my business through my laptop I was having anxiety just talking about it. I decided before I did that I would give Costco a call next since that's where I purchased the laptop from 3 years ago. Turns out they have a concierge service- i called them. I'm completely out of warranty but the tech said lets see if we can trouble shoot via phone. First thing we tried VIOLA-- it worked. Turns out computers can build up a static charge that blocks the charger from being recognized and charged. It's simple steps-- anyone else having issues With chargers shoukd try this first.

    1. Power down lap top, unplug, and take battery out

    2. Hold down power button for 60 seconds

    3. Insert battery (do not plug power cord in)

    4. Turn computer on

    5. After it's done booting up check battery life ( mine has said 0% for months and computer would never boot up without being plugged into out let)

    6. Plug charger in to computer in and verify its charging

    It worked for me, I hope this helps others. This was a very frustrating problem. And I don't understand why Dell had not shared this easy fix for other consumers. I know this is not an isolated problem.


  • nope didnt work

  • Looks like this has been a long known problem! Mine is an Inspirion 1545 and just started having this problem.

    Ran the Power-on Diagnostics to see what it found. After 4 hours of varying Memory testing, it asked if I wanted to continue with more "strenuous" testing or something else. I chose Something Else. Found something related to Battery/Charger (sorry, don't remember specifics) which reported No Problems Found ! (? really?) Found no "restart / reboot" command, pressed <ESC> which rebooted (with the charger connected). Sure enough, the charger was recognized!. Powered off then back on - NO PROBLEMS!  YEA! ... Until I hibernated: No longer recognizes the charger! Hmmm!

    Now running the onboard testing (from Start Menu) Nothing to check Battery or Charger :[

    Will try the Power-on Diag again and report the result. IF ok, then problem lies with Hibernation.

  • FINALLY getting back to this post.

    Went to Best Buy (R) because Google said "they have Dell chargers." Salesman suggested "upgrading" to a 90 W (have a 65 which came with the laptop) Insigna (R) (store brand) charger - $49 vs $150+ charger board, 15 day return policy.  The new charger works consistantly so it WAS the charger which failed ... sort of.

    The Insigna user's manual says to "plug in the charger then plug into the laptop - the opposite for other switching regulators.  So, tried that with the Orig charger: if I wait to plug into the laptop a minumum of 15 seconds, it WORKS every time. Hmmm?

    SO, I have 2 'working' chargers, one of which will work with "any" laptop.  $ well spent, I'd say.

    Hope this fixes all your Dells exhibiting simular problems.