Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

remove message - Your battery is able to charge normally...

This question is answered

 Your battery is able to charge normally. However it is reaching the end of its usable life.... how to remove this message? Uninstall DCP is not solution. Why confuse customer with such message letting him think that me, as reseller have sold him BAD LAPTOP with BAD battery????

Verified Answer
  • Dell included administrative templates with the Feature Enhancement Pack which deals with all these massages. To utilize them do the folowing:

    1. Copy all *.admx files in C:\Program Files\Dell\Feature Enhancement Pack\policydefinitions to C:\Windows\PolicyDefinitions;

    2. Copy all *.adml files in C:\Program Files\Dell\Feature Enhancement Pack\policydefinitions\en_US to C:\Windows\PolicyDefinitions\en-US;

    3. Run Group Policy Editor - Click Start button and in the Search box type gpedit.msc and click the result;

    4. Browse to Computer Configuration -> Administrative Templates -> System -> Dell -> Feature Enhancement Pack -> System Events and double click Battery in the right pane;

    5. Select Enable radio button and checkmark Battery helth degraded for this particular massage;

    6. You can get rid of any other massages there as well;

    7. Click OK;

    Done.

All Replies
  • The message means what it says - the battery needs to be replaced (or will, soon).

     

  • and how to remove this message?

  • There are two registry keys for that:

    HKEY_CURRENT_USER\Software\Dell\DellControlPoint\PWR\DisableBattPopUp_Primary_Caution
    HKEY_CURRENT_USER\Software\Dell\DellControlPoint\PWR\DisableBattPopUp_Primary_Replace

    The default is 0. Change this values to 1. This was working on my system.

  • I had to search for "EnableEBLNotif". I found two instances. One was 0, the other 1.

    After changing the value from 1 to 0 the notification disappeared.

    (Added note: but on the next day the notification showed up again....Sad  )

     

  • Business class computers: Click the start button, type the word "regedit" and click on it, then under the edit tab choose "find" and type in the word "Primary_Caution" change the default value from 0 to 1, then do the same for the next entry below "Primary_Replace". Then go to file, and exit. Shut down/restart, and you are good to go.

    Non business consumer product: Follow above instructions, yet it may be easier to find "DisableBattPopUp". There you will also notice 2 entries that end in the same as above "Primary_Replace" and "Primary_Caution"

    Unfortunately Dell's quality has gone down dramatically over the past 2-3 years, purchasing cheaper grade equipment even for the high-end business models. Don't expect a Dell branded battery to last much longer than the warranty. DO NOT purchase a Dell branded replacement battery... there are cheaper batteries available with twice the warranty!

  • I tried searching for Primary_Caution and Primary_Replace but regedit could not find the entries.  I am using a Precision M4400 on Win 7 64 bit and have also Installed Dell Feature Enhancement Pack.  Any ideas?

  • Unfortunately all fixes via the registry are not permanent. I have received many messages that the same notification reappears the next day. Others have deleted entries in the registry, without success. I have contacted Dell several times on the issue, and their "knowledge base" offers a fix through the Dell ControlPoint System Manager settings. I tested the fix with Dell, unfortunately this does not solve the notification issue either.

    I can only suggest living with it for now, as it does not harm your computer in any way. If it really bothers you, buy a new battery which will stop the notification. Please remember, do not buy another low quality battery from Dell. A Google search will help you find bettery batteries at half the cost, with a 2 year warranty.

  • Uninstalling QuickSet from your Programs will also remove the annoying message..

  • Dell included administrative templates with the Feature Enhancement Pack which deals with all these massages. To utilize them do the folowing:

    1. Copy all *.admx files in C:\Program Files\Dell\Feature Enhancement Pack\policydefinitions to C:\Windows\PolicyDefinitions;

    2. Copy all *.adml files in C:\Program Files\Dell\Feature Enhancement Pack\policydefinitions\en_US to C:\Windows\PolicyDefinitions\en-US;

    3. Run Group Policy Editor - Click Start button and in the Search box type gpedit.msc and click the result;

    4. Browse to Computer Configuration -> Administrative Templates -> System -> Dell -> Feature Enhancement Pack -> System Events and double click Battery in the right pane;

    5. Select Enable radio button and checkmark Battery helth degraded for this particular massage;

    6. You can get rid of any other massages there as well;

    7. Click OK;

    Done.

  • This is how I stopped the message from showing: I have a Dell E6520 and it is about 2 years old.

    1. Click on the "Start" menu.

    2. Right click on "Computer" and select "Manage".

    3. Expand "Services and Applications" and click on "Services".

    4. Double click on "Dell System Manager Service" to open the properties page.

    5. Change the "Startup type" to "Disable" and then click on "Stop".

    6. Click on "OK" and close the "Computer Management" window.

    After rebooting the system the message will stop showing up.

  • This worked perfectly for me  - thank  you nijels - I would rather not disable all the warning messages by disabling the service so this was a much better choice for me.

  •  

    I also get this message and my battery is new, and the health is excellent so there could be a software fault too, then I do not know what to suggest, except disable in the start up the dell feature. I expect the battery to start decreasing its life after one or more years depending on use.

  • The answer posted by nijel8 [on 06-07-2012 7:57 AM] works perfectly unter win7 and latitude E6520. It allows to configure different messages.

    I recommend nijel8's answer instead of disabling the whole "Dell System Manger Service" as suggested by Jallmitch [on 11-28-2012 9:00 AM]
    .

  • Thanks NIJEL8 for this solution! Very easy and nice to handle each of possible Messages individually! I work on a DELL E6520, i72620M, Win 8.1 PRO (64bit).
    DELL E6520, i72620M, Win 8.1 PRO (64bit)
  • Hit Fn + F3.  Click on the 'more information' link then check the box below to not be notified of this again.