Laptop computer Forums (Audio, General Hardware, Video)

Windows 7, Studio 1737 notebook STILL has ACPI bios issues

This question is not answered


I have just upgraded my Studio 1737 notebook to the bios version A07. This version promised solved DPC latency issues but no change really.

There are som DPC spikes above 1000microseconds (far from good) and there are som 2000-5000 spikes a few times in a minute. Dell has fixed the video brightness feature in Windows 7 in this release, but using it causes terrible DPC lag at above 8000 microseconds.

Improvements in A07 bios on the Dell Studio 1737,

Windows 7 brightness adjust: Works

DPC latency: No change


Still error messages in the event log,

: The embedded controller (EC) did not respond within the specified timeout period. This may indicate that there is an error in the EC hardware or firmware or that the BIOS is accessing the EC incorrectly. You should check with your computer manufacturer for an upgraded BIOS. In some situations, this error may cause the computer to function incorrectly.


Espen Blikstad

All Replies
  • I just noticed, CPU throttle limitation bug has been fixed. When plugging AC power the CPU returns to full speed.



    Hello eeblikstad

    I have a similar error to you, look here


    Did you ever solve your problem, if so how?

    Thank you.


  • I had the same error message on my event viewer and the message came up around every 10 minutes. I recently updated BIOS to A08 and the error message started showing up. I found the following solution which fixed my issue perfectly.

    Good luck for everyone




    Lots of people already had to RMA their laptop because of a badflash or wrong flash.
    Be warned, do NOT flash because you want to....only if you really NEED to flash to fix something.

    If do you flash a notebook BIOS, you must do the following AFTER the flash:

    1. Turn notebook OFF with button, hold 4 seconds.
    2. Remove recharge plug
    3. Remove battery
    4. Leave it like this for about 5 minutes.
    5. Put everything back and power the laptop again.

    The new BIOS should work properly now.
    This procedure resets the Embedded Controller (EC), so best been done as described.
    (MSI Europe informed me about the need for this procedure)

  • I was fast to say the issue was fixed. Recently the error came up again and I got the error about every 5 minutes. After I tried everything I could think of I found a workaround to get rid of the error from event viewer. I monitored event viewer for a few hours now and I did not see a single ACPI error in my event viewer.

    Basically I shutdown the machine and took out the battery. I use AC power only to start the machine and so far there is no ACPI error. So I think it is the issue in the power management driver.

    Can you try it and post your result here?


  • I also have this issue. I updated to A09 BIOS but it still is an issue.

    I did as suggested, powered down, removed  the battery and reconnected power. The ACPI errors are gone.


  • Hi Harry,

    I have the same problem, I have upgarded to A09 but still I get

     The embedded controller (EC) did not respond within the specified timeout period. This may indicate that there is an error in the EC hardware or firmware or that the BIOS is accessing the EC incorrectly. You should check with your computer manufacturer for an upgraded BIOS. In some situations, this error may cause the computer to function incorrectly.

    Can you please verify how did you fix this issue? Or is it still going? From your last post I can not understand what the situation is because first you say : ... still an issue ... but next you say : ... errors are gone.

    Thanks very much! Smile


  • Hi Shaya,

    Yes the problem did go away, but I believe that this was only briefly.

    I am using BIOS A09 and do still have lots of entries in the log as you describe above.

    I just gave up - I'm guessing Dell is not interested in looking into this.


  • Hello Everyone,

    Yes, if reading this thread it would have been nice if Dell Support replied to this thread.

    I have a Dell Studio 1555 with bios version A13 (the latest) and have had this error since I purchased the machine.

    If this is not Dell's area of responsibility it would have at least been nice if they could tell us.


  • hmmm. Im at A09 on my studio and this is happening....any special release?

  • same problems here!

  • I've had this problem since 2009 (with bios update A07).  I've talked to support in the past and was instructed to upgrade my bios.  I did to A08, still happened.  I upgraded to A09 and the problem showed up even more.  So I re-installed A08 and it's still occuring, just less frequently.  I run Windows 7 Ult.

  • I've been told that there is an connection between ACPI and ATAPI so I installed the latest SATA AHCI drivers from Intel from a package called "RST and AHCI Driver and GUI" and I have not had any ATAPI errors since, which is a kind of utopia for me after all this time. I've had one ACPI error only, but are planning to install the latest chipset inf package also. The inf package version is and was released November 6th 2012. Go to and just enter "RST and AHCI Driver and GUI" for the SATA ACHI drivers, and "" for the chipset, in the search box down to the left. With you will get three hits. It's the bottom one with date 11/6/2012.

    I'll post my experiences after some days.


  • Regarding my post Dec. 12th 2012. Unfortunately it did not solve the ACPI errors. Maybe less than previously, but difficult to say. I have not done exact statistics. But I have not had any ATAPI errors since the updating with the suggested drivers. So that's a good thing. My computer seems to be running smoother than ever after applying the "RST and AHCI Driver and GUI" driver.

    I've had the ACPI errors since I purchased my computer. First with Vista, then with Windows 7. My computer is a Studio 1555 where I have done all the BIOS updates up til the latest version A13.

    A bit odd that you have not given us any feedback at all on this issue Dell...... Not a good thing.


  • OK, I'll chime in again.

    I powered off my Studio 1737, removed the power cord, and removed the battery.

    I attached the power cord and ran without the battery installed. I have been running for 30 minutes (I know - it was just a quick test but these errors are a lot more frequent than every 30 minutes more like 1 or 2) and have no log entries regarding this ACPI error since the start-up.

    I only have one error message and that is "The following boot-start or system-start driver(s) failed to load: luafv" - don't know what this is, but that is a different story.

    Since I live in an area where power outages are fairly frequent and not predictable, I cannot run without the battery installed, so I put up with the error messages filling up the log. Surely Dell or someone can fix this??



  • Thanks Harry,

    I'll give it a try. My errors are not that frequent, but I'll see how it goes within a few days.

    For those of you that also have ATAPI errors, try the solution that I have posted in my two previous posts. Since I installed the new drivers I have not had a single ATAPI error. My computer is also running smoother than ever.

    For the ATAPI Errors search for the SATA AHCI driver by using the words "RST and AHCI Driver and GUI" at . Drivers for both x86 and x64 are in the folder called Drivers. Use Device Manager to update.