Latitude E6400 XP wireless/network driver issues.

Laptop

Laptop
Laptop computer Hardware and Software discussion

Latitude E6400 XP wireless/network driver issues.

This question is not answered

Hello,

 

We have a E6400 laptop that was shipped to us as a replacement for a previous laptop that went bad-we requested XP, but were told Vista was the only option, so as soon as I got the machine I installed XP, and installed all the XP drivers possible from Dell/Intell support. For some reason the network drivers are not working on this machine, and some of them from the dell site will not even install.

What can I do to get the XP network and wireless drivers installed if the ones provided by Dell and Intel do not work?

 

Things I have tried already:

 

-Made sure wireless and network settings were turned ON in BIOS.

-Installed all provided drivers and Dell Sofware from Dell support drivers page and Intel.

-Did windows update, installed SP 3, etc updates.

Tried manually updating drivers.

 

....anyone have any ideas?

 

Thanks.

All Replies
  • Did you install the drivers in the correct order?

    1. Service Pack 2 and 3 (may already have them included on the xp disc)

    2. Dell System Software under utilities

    3. The Chipset Drivers

    3.5 The Video Drivers

    4. Conexant Modem Drivers

    5. Network Drivers

    6. Wireless Drivers

    7. Audio IDT Driver only

    8. Input Device Drivers

    9.  Webcam Application

    Try installing the above without anything else after a clean install of xp and in this order.

     

    Philip Yip

     

    Windows Reinstallation Guide and Related Wikies See here for other wikies such as Customising and Using Windows 8.1, Dell Wireless Cards and Unofficial Drivers.

  • Okay I did that-installed them exactly in the order you described, starting from scratch I reinstalled XP and installed the drivers in exactly that order, but i'm still getting errors while trying to install the wireless drivers. Everything else seems to work...


    I've noticed this on multiple machines that came with Vista, it's like the wireless/network drivers supplied by Dell for XP aren't correct, or something, I don't know.

    Anyone know?

     

     

    When I try to install the wireless driver it gives me a Error :Setup.rul 380" has occured and cannot continue'

  • Okay FINALLY found the correct wireless driver, it is the XP wireless driver needed for the e6400 :

     

    http://ftp.us.dell.com/network/R202485.exe

     

    I highly recommend someone at Dell realize and correct the fact that on many of the machines they have the wrong XP drivers listed.

  • Actually R219313 works.  You have to do is load the .net framework 2.0 before you launch the application. This can be achieved by doing a Windows Update and selecting the optional items to install.  You'll see a checkbox for XP.  However, If you don't want the entire Dell WLAN application you can still just load the wifi driver.  By doing this, you'll use the windows version to connect to wifi sites.  All you have to do is right click my computer, click the hardware tab and select device manager.  Go down the list until you find the network device for the wifi device. Right click and update driver. When the R219313 was clicked you saved the files to a certain location.  On the update driver location, choose the location you had the files saved to.  Click down until you find the Driver_US folder. Go ahead and install and you should have the Dell Wifi Driver installed. 

    Also, the R219313 will install properly if prior versions have already been installed.

    NOTE: This only applies if you have the Dell Wifi Card. If you have the Intel card, use the appropriate driver.

  • WOW!! Wouldn't that be helpful if they put it in the error message(ie.. needing .net framework 2.0)?

     

    I was getting it when trying to install the driver on a Latitude D420 and luckily I ran across this post or I would still be searching for a solution.

  • .net framework 2.0 didn't help

  • Not sure what fixed this for me but I installed all service packs and Windows updates... installed flash, java, avg, ie7 and then ie8.. tried the install again and it worked.

  • This issue was a challenge, but here is the answer.

    I found a posting for the correct driver and this is it.

    Description
    Dell Wireless WLAN 1397 Half MiniCard (4312bg)
    R251447

    Installer package containing driver version 5.60.188.1 and application version 5.60.18.8 supporting Dell Wireless 1397/1510 WLAN on 32-bit and 64-bit Windows Vista operating systems.

    Search on Dell support site for this driver. You could also google it by the R251447 name.

    Best of luck!