Cursor jumps around when typing

Laptop

Laptop
Laptop computer Hardware and Software discussion

Cursor jumps around when typing

  • It is an easy fix by disabling the touch pad "touch to click" option, like I have posted before.   I am surprised however that Dell has not issued a Tech service bulletin or Recall on this issue.

    John B

  • If only it were that easy, John.

    That is what I tried at first based on posts in this forum as well as using a mouse - don' like touch pads much anyway.. Didn't work for me and my XPS laptop bought last September. Went through all the hoops suggested by Dell techies but still had the problem. 

    Then quite by accident I came across the N-Trig Duo Sense Digitiser Settings [It is in Control Panel if you have in view by large icons it is listed there] I had noticed one of the problems was a thing called Tablet Input Panel - not sure if everyone has them -but it is a gizmo that allows you to write in the panel on the screen or type. I never use it but everytime my mouse or cursor leapt off on its merry dance this thing would pop out from the side of the screen. I couldn't get rid of it but it stayed still long enough for me to be able to see that NTrig had something to do with it. So I opened N-Trig from the Control Panel and in the Digitizer Options Mode I unticked 'Enable Touch'. Lo and Behold a still pointer/cursor when I type. This was last December and so far so good.

    Not saying it will work for everyone - but it worked form me.

    I too have had a long line of Dell machines both desktop and laptop and this is the first I have ever had a problem with. Dents your confidence in the brand a bit.

    Rob

  • Ah ha...yes, well I found when I upgraded to Win8 (a big mistake) that the problem returned, as when I first got the new laptop last July. So I had tried updating drivers, and was installing the wrong one.  Was not a synoptics like Windows installed but a ALPS touch pad driver that worked and allowed to untick or unclick  the "touch to click" option. The synoptics driver had no such option.   Yes, I called Dell Support too, they really had a hard time understanding the problem, or me them, maybe the India accent had something to do with it.  It certainly leaves a bad taste in a persons techy recommendations and have not recommended a dell laptop to a close relative because I did not want them to go thru the same frustrations.

  • Jim, how can you be so sure about something when you can't witness how the person is using their laptop.

    With the extent of the issues from lots of different people and on different laptops, surely they can't all be touching the touchpad while typing. Also how come no one else complains about this with other PC manufactures to this extent.

    Do a little Googling and you will see this is wide spread on Dell laptops.

    I have a E6400 and I have this issue too. And before you start going on about lazy wrist syndrome I use an external Mouse and external Keyboard so I do not type anywhere new the touchpad. And just for the record I also disabled the tap to click on the touchpad but didn't make any difference.

    On a side note I also have issues with my Audio. It drops in and out or doesn't sound at all. However it works fine if I disable the Wifi using the physical switch on the side.

    These seem to be a specific DELL ISSUE, maybe relating to the hardware control or bios. I also read something about CPU thrashing issues.

     

    So please pause and research a little before offering simple advice regarding floppy wrists as it just adds to the myth that this is a user problem and may delay Dell actually trying to investigate the issue.

     

    Cheers,

    Anthony. 

  • Jim, how can you be so sure about something when you can't witness how the person is using their laptop.

    With the extent of the issues from lots of different people and on different laptops, surely they can't all be touching the touchpad while typing. Also how come no one else complains about this with other PC manufactures to this extent.

    Do a little Googling and you will see this is wide spread on Dell laptops.

    I have a E6400 and I have this issue too. And before you start going on about lazy wrist syndrome I use an external Mouse and external Keyboard so I do not type anywhere new the touchpad. And just for the record I also disabled the tap to click on the touchpad but didn't make any difference.

    On a side note I also have issues with my Audio. It drops in and out or doesn't sound at all. However it works fine if I disable the Wifi using the physical switch on the side.

    These seem to be a specific DELL ISSUE, maybe relating to the hardware control or bios. I also read something about CPU thrashing issues.

    So please pause and research a little before offering simple advice regarding floppy wrists as it just adds to the myth that this is a user problem and may delay Dell actually trying to investigate the issue.

    Cheers,

    Anthony.

  • I found the tap to click solution only worked with the Alps driver, and not the Synoptics driver that Win7/Win8 initially installed.  Dell tech support did not have a clue.  Boy, maybe its time for a class action suit...good luck with that huh?

    BYW, The tap to type on my Apple Ipad touch screen also sucks, picks the wrong letters all the time, but no bouncing.

  • I disabled Dell quick set I lost some function of some keys like the eject button for the DVD, however it still works using the software eject. but since I disabled NO MORE JUMPING CURSOR! I have fixed mine this way and now 3 other friends and families Dells that had this same issue
  • Jumping Cursor on Dell Precision M4500.

    Disabling Touchpad impossible! Windows 7 keeps enabling the Touchpad.

    Tried the latest drivers, disable when mouse present, disable with Dell Touchpad control centre. Nothing works!

    Some solutions works for a few days until Windows 7 finds it time to make me go crazy again.

    And stop replying with Touchfreeze...  doesn't work on Windows 7.

    DELL... Please FIX THIS!

  • It DOES work on Win 7 and 8 and Vista. Been using for years for all three OSs.

    When you disable it through the TouchPad control panel, does the pad stop responding completely? If it still responds at all, then it isn't disabled. If it doesn't respond and you have cursor jumping, then the problem isn't the software, but a problem with the Pad itself, such as bad connection inside. If so, call Dell for warranty service. If it still responds, go to the Toshiba web site and download the latest driver(s). They have ALPS and Synaptics drivers available. I have used both of them for years with no problems.

    XPS M1530, Windows 8.1 Pro 32-bit
    Inspiron E1705, Windows 8.1 Pro 32-bit
    Dimension 9100, Windows 8.1 Pro 32 bit
    Inspiron 660, Windows 8.1 Home - 64 bit
    Compaq DX 4370G, Windows 8.1 Home - 64 bit
    Asus T100 Tablet, Windows 8.1 Home - 32 bit

  • KirkD thanks,

    I now use Synaptics driver and that works but somehow Wndows 7 still seems to re-install it's own driver now and then.

    The trouble always is that I find a solution that works and then I forget about the situation until after a few weeks Wndows has it's moment again and I see my cursor doing it's little dance again.

    Offcourse this whole discussion on Touchfreeze and what drivers work would not be necessary if the touchpad would work in the first place.

    If you scout Google on the "jumping cursor" problem there are many, many posts on the subject so I'm a bit puzzled why there are so little solutions to this problem. May because this is indeed a hardware problem (dirt under the touchpad etc...)

  • Here it is 3013 and Dell is still delivering laptops with the same problem of the cursor jumping around. i just purchased the Inspiron 15R and in my opinion, this laptop is unsuitable for business or home use.

    I believe the problem is with the touchpad. The 'Palm Rejection' and 'Touch Pressure' controls don't work. You can disable the touchpad when an external mouse is connected, but that's a hack. And, when you disconnect the mouse, the touchpad buttons remain disabled (you have to go to the control panel using the mouse to re-enable).

    Again, this laptop is unsuitable for business or home use. I'm returning it for a refund.

  • Thanks for this information!  I tried enabling the TouchGuard and it seemed worse than before - should it be in the middle of the bar or closer to "+" or "-"?  How do I check to see if the driver is installed?  Really appreciate your post.  I just got my laptop and merely typing this message has been a challenge!

  • Basically there are two options. You can try Toughguard or the Synaptics driver ( www.synaptics.com/.../drivers ). In my case the Synaptic driver works fine.

    You can of course also rip out the toughpad all together which I was pretty close to doing at the end...

  • Thank you for the suggestion and link. . .and for the humor!  I am about at that point myself - unbelievable. I was so excited to finally be upgrading to a new machine and now I'm typing this message on my "old faithful" which is 8 years old.

  • My 10 year old Dell Inspiron works fine also. The touchpad is smaller and doesn't exhibit the behavior. Go figure....