Cursor jumps around when typing - General Hardware - Laptop - Dell Community

Cursor jumps around when typing


Laptop computer Forums (Audio, General Hardware, Video)

Cursor jumps around when typing

  • Paul

    Look for a touchpad icon n the taskbar.  When you rest the cursor over it, it should read "Dell Touchpad".  Double-click it.  Click "Device Select" and check "Disable Touchpad / Pointing Stick when external USB mouse is present and see if it helps.

    While you are there you can click on Touchpad settings and adjust touchpad speed and sensitivity, play around with the settings and see if you can increase control on the cursor.

    If there are no Touchpad icon on the taskbar click on start, control panel and then mouse.  Click on Touchpad and you should be able to bring up the same menu.

    If there are no Dell Touchpad options under Mouse in Control panel, I suggest downloading and installing the touchpad drivers from the following link.

    <ADMIN NOTE: Broken link has been removed from this post by Dell>

    For a great article about general touchpad troubleshooting please check out the following link.

    I hope that this helps.


    Specialize in Laptops, Mobile Devices

  • It's nice to know you're not alone - though it would be nicer still if none of us had this problem.   Does it seem to be a Dell problem or do other laptop makes have the same defect?  I wasn't sure.

    Anyway, thanks for all the replies.


  • Guys, seriously, your lazy wrists have to start getting unlazy! This isn't a hardware issue, this is a user issue. One of those ID-10-T errors if you get my drift. What is happening is you are ever so lightly touching the touchpad with your palm while typing. This is not a driver issue. Make sure and download the latest drivers so you get the Touchpad icon in the tray so you can go into the properties and disable the touchpad while you use an external mouse.

    Jim V.

    PC Support Specialist


  • Some touch pads are so sensitive that you don't need to actually touch the pad accidentally, just come close. I could get better results with my M1530 by downloading a newer pad driver from the Toshiba site. The best results came from using a free-by called TouchFreeze. Eliminates about 99% of the problem.

    XPS M1530, Win 10 CU Pro 32-bit
    Inspiron E1705, Win 10 CU Pro 32-bit
    Dimension 9100, Win 10 AU Pro 32 bit
    Inspiron 660, Win 10 CU 64 bit
    Inspiron 3668, Win 10 CU 64 bit
    Asus T100 Tablet, Windows 10 CU 32 bit

  • Well Jim your mileage must be different from the rest of us because it is more than just lazy wrist syndrome. I'd love for it to be that. I even hold my wrists up off the system for testing and when I type about 3 sentences the cursor will move up 2 lines and insert in the 1st sentence.

    I have staff that are upgrading from the D series Latitudes to these E series latitudes and that has to be the biggest complaints we get about them is text jumping around. Is it just strange that this wasn't a problem with Dell Latitude D series and now it is a problem with Dell Latitude E series?

    Then to tell staff that they should disable tracpad buttons (namely the keyboard pointer stick)  that they paid for they ask why did they get a feature that we have to turn off??  one person commented saying if you buy a car with a rearview mirror but our IS dept takes it off because you have a blind spot instead of fixing it is'nt very cost efficient. I showed them that we have only 1 internal keyboard choice... other than back light or no back light are my only choices.

    I will say that Touch Freeze does work on our XP systems. I just worry when our business does make the Win 7 plunge next summer that we aren't dealing with this issue still.

  • We now have E6410, E6420, E6520, M4600, and M6600 laptops and they all have this similiar issue. Out of all those models though, I only have complaints from about three teammates from three different models. Only one complaint from the E6420. You are right that this was not a complaint with the D-series laptops. Since I setup all the new laptops, I always set the properties for the touchpad as follows:

    Check the box next to "Disable Touchpad / Pointing Stick when external USB mouse is present"

    I then up the "Touch Sensitivity" to about two to three notches from the right.

    Using these settings, I have not had anymore complaints about this new ultrasensitive touchpad. You do not have to totally disable the touchpad, that isn't necessary. Simply use those settings, I guarantee happiness. Again, this isn't a "problem" but simply a learning curve for your users to migrate over to a more technologically advanced machine. I used to have this problem when I just started getting E-series laptops, haha glad I finally figured out how to properly use my hardware. Like a new car, you will eventually get more comfortable with everything, but sometimes you can't teach and old dog new tricks.

  • FYI-This will happen with both XP and 7 users.

  • Wow. Condescending answers ("ID-10T error"? Really, Jim?) are not helpful. The issue is that the drivers that allow advanced control of the touchpad ARE NOT INCLUDED - you have to go download them. Then, you can adjust the sensitivity, mess w/buttons or whatever. So I suppose we idiots that expected BUILT IN HARDWARE to have the necessary drivers out of the box have to adapt to Dell not caring if their systems seem like demon-possessed machines when you shell out thousands of dollars for them. C'mon.

  •  I don't really have anything of value to add...just wanted to put it on record that I'm also having this same issue with a brand new 2 month old Dell M5030.  Since the first 1-2 weeks I've had intermittent issues with the cursor going crazy & would basically go in the opposite direction of where I'm touching on the touchpad.  During these episodes it doesn't matter where I touch or what direction, it will go the opposite or in it's own direction completely.  Extremely frustrating!  The only thing more frustrating is the jumping cursor while typing!  It's exactly the same as what everyone else describes, I'll be typing (it's already happened 5 times this post alone) & next thing I know the text is smack in the middle of 5 sentences ago.

    I agree, I find it extremely frustrating that I keep seeing the same answers over & over (tried them all, haven't helped), then on top of that the condescending comments that it's the user's fault for having "lazy wrists!"  Come on now!  This is absolutely rediculous!   The only thing more rediculous is that I thought this would work itself out & am now outside of the return period or this would be going straight back to the store where I bought it.  I have owned several brands of laptops including Toshiba Satellite, HP/Compaq, Sony Vaio, Lenovo, Panasonic & now Dell & I've never had a problem with any of them doing this, not even when it came time to upgrade&replace.  The last sentence I typed the curser jumped 6 times & NO my hands are not touching the pad or even resting on the base board next to the pad.  These wrists are definitely not lazy! 

    Thank you to anyone who figures out this issue & posts the answer.  Although I think it's pretty insane to purchase a brand new computer & have to spend hours online researching ways to to tweak & disable settings just to make it function properly.  Guess my next step is contacting Dell, but from what I've been reading that doesn't sound too promising.  I'll update everyone if I figure this out or get any help from dell.

  • I would like to state that I am having this problem as well with a brand new XPS 15z using windows 7.  It is very frustrating.  I have tried disabling the track pad when using the USB mouse and still have the issue.

    It is not a lazy wrist issue at all.  I have the problem when I'm testing with the external mouse only.  I will click into the subject field of an email, and after a few seconds, I will no longer be live in the field.  This goes for actively viewing a web page and being able to use the mouse scroll.  Suddenly it jumps and I can no longer scroll within the page until I click back in.

    Tech support had me restore my system to factory default, and that didn't help either.  I'm very frustrated by the whole thing!!!

  • I finally solved the issue!  Well, I guess I didn't solve it, but i figured out a way to get around it.

    1. I right click anywhere on the desktop & choose "personalize"

    2.  Click on "change mouse pointers"

    3.  Click on Dell Touchpad

    4.  On Touchpad settings under "Taps"  the "tap to click" button had a check mark, I unchecked it & haven't had the problem since!

    Hope this helps someone, I know it's frustrating!!!

  • Same problem with 3 Dell 1440s.  Two are older (12 months old); 1 was purchased in last 4 months.  All 3 have the jumping cursor issue.  We simply ignored the issue for the last year.  And it's not a lazy wrist issue either.  Cursor jumps even though wrists are 3 inches away from touchpad.  Dell has a probelm.



  • Great post Claymonster. I agree completely. I just bought a new E6420. No Dell Touchpad driver installed even though there is an active touchpad input device. The driver should be installed on these laptops by default. I had never had a problem with the touchpad moving the curser while I typed until getting this E6420. Apparently the touchpad area is greater than with my previous D620 laptop. Simply having my thumbs hover above the touchpad sometimes moved the curser while typing. With the new Dell Touchpad driver I simply turned on "TouchGuard" under the "sensitivity" setting and the problem went away. I hope that this helps all new E series laptop owners. Check to make sure that the Dell Touchpad driver is installed.

  • have the jumping cursor issue on a E4320, we have had all the hardware replaced (I do mean all of it), OS clean reinstall. Issue remains. we have installed "the latest" driver and still the cursor jumps randomly, random c&p occurs as well.

    Viruses have been ruled out, scaned with 4 different Av products, malware has also been checked for, and from a clean OS install on a new HD would not explain it either.

    Either this is an inherently flawed HW issue or it is an Inherently flawed driver.

  • typo E4310