Laptop computer Forums (Audio, General Hardware, Video)

Dell Latitude C840 Laptop Sees a PA-9 90W AC Adapter as a 70W AC Adapter and Line in LCD

This question is not answered

When I use a PA-9 4.5 90 watt AC Adapter, it says that it is a 70 watt AC Adapter and that it will not work correctly.  Also, there is a thin line running down it toward the middle, red in parts blue in parts close to a white spot where it looks like the eraser track ball has left it's mark (round, white circle).

All Replies
  • For your AC adapter issue go to and download the latest BIOS. try to use other known good 90 watt ac adapter, if still having issues motherboard needs a replacement.


    For your LCD, try to use an external monitor. if the thin line is not present, LCD needs to be replaced. try to run the diagnostics also.

  • <!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } -->

    I put an external monitor on and then booted up and both showed until the desktop but then the external went out so how do you get the external to show at the desktop then go back to the LCD?  Also, how do you run the diagnostics.  I know IBM has this kind of resource but I do not know anything about Dells having it. Thank you.


  • <!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } -->

    I tried another Dell PA-9 AC Adapter and it is still recognized upon boot up as a 70 Watt AC Adapter with this “Using a 70-W AC adapter will cause the computer to run in reduced-performance mode and may display an AC adapter” WARNING message. Before I purchase another Motherboard, I want to confirm this means the Motherboard is bad.

  • For LCD issue:

    Once it enters Windows just press and hold the Fn key and press the F2 key then release both keys.

    For the AC Adapter issue:

    Did you already flash the BIOS? If so, motherboard is defective.

    **to flash the BIOS just go to, then click Drivers and downloads. Xhoose by service tag then download and install BIOS.

    **to run the diagnostics, turn the computer off. Press and hold the Fn key and press the power button. Once you see something on the screen you can now release the Fn key.

  • Hello, Did you ever get an answer that worked to resolve the power adapter problem? I also have a C840 with exactly the same problem! Thanks, Selby