plugged in not charging ? bios flash without battery ? - General Hardware - Laptop - Dell Community

plugged in not charging ? bios flash without battery ?


Laptop computer Forums (Audio, General Hardware, Video)

plugged in not charging ? bios flash without battery ?

This question has suggested answer(s)

laptop : Dell XPS M1530

had it only for a year or less.

battery was fine until two days ago, plugged in, not charging , stuck at 4%.

did a LOT of research online, tried all the methods & combination of removing / reinstalling ,...etc. none worked.

read that if i flash bios then it should work. problem is that i can not flash bios since battery is (perceived by the system) less than 10% .

how to fix this ???

would system restore / restore to factory settings resolve this ?

please help . i'm quite sure the battery it self is fine and this is rather a software thingy.......
can't be the power adapter, when I ran the diagnostics it is clear for the adapter, and the system is working fine if the adapter alone is plugged in, tried different wall outlets, no difference.
- the messages i get:
If only adapter plugged in : "The AC adapter and battery MUST be plugged in before the system bios can be flashed"

If adapter and battery plugged in : "Make sure the battery is more than 10% charged to flash bios"

..............please help !
All Replies
  • Thanks rlamontagne.


    As an alternative, for those interested in downgrading to the A09 BIOS, you can download this Win98 bootable ISO image with the A09 BIOS executable.  The idea is the same as rlamontagne's.  The only difference is you don't have to go to the trouble of building up your own bootable USB stick / CD.  The ISO image was built from a bootable .IMA file provided by these guys.  The only modification was the addition of the 1530_A09 executable.



    1. Burn this image to a CD.
    2. Reboot, and boot off of the CDROM.  You may need to press F12 or whatever it is to get the "Boot Menu" to show up. 
    3. When the Windows 98 menu is displayed select the option that gives you CDROM support
    4. If you get a message saying your hard drive isn't recognized because of  the format; just ignore it, its not important.
    5. At the prompt type:  d:  <ENTER>
    6. At the prompt type:  dir <ENTER>
    7. You should see a file called 1530_A09.EXE
    8. At the prompt type: 1530_A09  /forceit <ENTER>
    9. Follow the Dell BIOS install screen


    This worked for me, but as always, use at your own risk.

  • I had the same problem with my xps 1530 which is only 14 months old.  Dell scheduled a tech to install a new motherboard and adapter.  However, two days before the tech was scheduled to arrive, after uninstalling a program, I received a message could not boot windows.  A Dell tech over the telephone assisted in rebooting windows with the cd that came with my computer.  I have vista business.  The tech was able to reboot the computer and the battery started charging.  The battery is now at 100% and I am working on battery only to be sure it continues to operate before cancelling the tech scheduled for Monday.  This worked for me, so far.  BE SURE IF YOU DECIDE TO REINSERT THE VISTA  CD  CHECK THE BOX THAT STATES "REPAIR COMPUTER AND RESTART".  IF YOU REINSTALL VISTA INSTEAD OF REPAIR, YOU WILL LOSE ALL YOUR DATA AND YOUR LAPTOP WILL REVERT BACK TO THE DAY IT WAS PURCHASED.  YOU WILL THEN HAVE TO REINSTALL ALL THE PROGRAMS AND THE DATA.  IF YOU HAVE NOT ALREADY BACKED UP YOUR FILES - DO IT BEFORE YOU TRY THIS.  HOPE THIS IS OF HELP.

  • Hi,

    I am having the same issue with my Inspiron 9300.

    Unable to flash BIOS....

    Battery indicates it's charged 100% in the BIOS screen, when I boot up latop (XP sp3) the battery never charges and isn't displayed in the power meter tab.

    when I remove AC cord laptop powers off completely straight away.

    Any suggestions?


  • Hi

    found this site when I worked on an old laptop (Latitude d500) the first link answers the q. about flashing the BIOS when low on battery, the second and third link is about flashing without a floppy (flashing with a bootable-cd or a USB memory key)

    1 -

    2 -

    3 -

    I hope it's helpful to someone!


    Cheers // encor3

  • I had the same problem with the XPS M1530 and the "Plugged in, Not charging" message.      I struggled with this for about 6 months and finally got irritated enough to try to fix it.     I didn't consider the BIOS as being the issue until I came across this post.      To make a long story short,  I downloaded the A09 BIOS .exe file(M1530_A09) from the Dell Drivers Download site, saved it to my desktop, ran it, the computer restarted, flashed the BIOS(from A12 to A09), and when the laptop booted back up for the first time in 6 months my battery is charging and I can unplug my laptop without it shutting down!!      I don't know if that same process will work for anyone else having this problem, but for me it ended up being a pretty simple fix for a very maddening issue.     Now I'm just hoping it lasts!

  • Hello everyone:


    I have en issue of my own, i have en old laptop a dell 1150, which was given to me, it had an xp recovery disc and i have my own copy of xp pro, i tried installing the xp recovery, it goes through the formatting process, then it starts to create the files, after then it gets to the last phase, it gets to 35% then it freezes, it does this every time, so i tried windows 7, it goes in without any problems. So now that win 7 was in, i was able to find compattable drivers for the laptop, but heres where im having the prob, for some reason i can plugg in the adaptor to charge the laptop when the laptop is turned off, but when i want to install updates like service pack one, i cant do it off the battery alone it wants the adaptor as well, but everytime i plugg it in, the laptop freezes my desktop stops working, i can run the laptop off the battery and it works fine, i even removed the battery from the laptop then plugg it in it still freezes, so i googled the issue, its telling me that i might beable to fix it by updating the bios, but again i cant do that either, because it wants the adaptor along with the battery. Is there a way to get around without having to use the adaptor.

  • I had the identical symptom you describe:  "no charging in BIOS A12, but charges in A09"

    I replaced my power board and this solved my problem.

    Power board is only $30 if you can install yourself or $99 if you pay the supplier to install it for you.

  • I know this may not be what you want to hear. I finally got fed up and switched to LINUX MINT.

    Now I get everything for free. When I installed it on my XPS M1530 it corrected all my problems!     And without a reboot.

    I have Firefox and Chrome,  Thunderbird and Skype, Office and music and games and graphics etc......

    No more Hacking and Keygens. Everything is free and open source.

    It breathed new life into an old laptop. Much faster now, while using less resources.

    When I installed Linux Mint 12 "Lisa" the Software Manager had over 53,000 software applications I could download for FREE.

    They just upgraded to Linux Mint 13 "Maya"

    If you are unsure, during install it will allow for a dual boot setup and you can switch between them.

    If you are really not trusting, you can boot off the DVD and play for a while.

    Now I just use Windows for work "Lamers" at the same time I am able to do most of my work in Linux too.

    It took a while for people to start using the Internet, then the PDA, then the Cell Phones, then Google, then the Touch Pads.

    Now the new thing is LINUX. This environment is already on the top 500 most powerful machines in the world and is the fastest growing platform. Part of the reason is that it is so versatile and can run on almost any platform, MAC - INTEL - Supercomputers - You name it.

    Now all the money I would have spent on software and the OS, I can spend on Hardware and Upgrades!

  • Easiest  thing to do is just go to computer management and in Device Manager disable Microsoft ACPI-Compliant Control Method Battery. Then update the BIOS

  • For others like myself, who were looking for a solution you can accomplish the same thing without a bootdisk by doing 1530_A09.exe /forceit from the command prompt inside of Windows.  I just renamed the file a.exe and moved it to the root of the C drive.

  •  was trying to follow your instructions , but when i ran "1564a13.exe /forceit". i get :"this program cannot be run on dos mode.".

    can anyone help?

    also i had to change the  file name from 1564a13_win. exe to 1564a13.exe  otherwise dos do not recognize more the 8 character names.

    ran "1530_A09.exe /forceit"

  • same problem on my  xps l502 i called cu care they came my house this Tuesday let's see what happen.

  • I have a dell insprion 1525. The battery says 0%. I put a full charged battery from another dell in it still read 0%. It's my board or my bios. I can't update bios without 10% battery to find out. I tried to run the update in safe mode command prompt it still wouldn't run. How can I update bios to see if that fixes my battery problem?

  • i am waiting for answer for this question for many months now. dell support is making everything to avoid answering. it seems that dell customers support will not give a sh... about there customers. it's the last time i bought dell

  • When in doubt go to LINUX.