Dell (e6400,e6500,m4300,m4400) Alps Touchpad Driver Issues - General Hardware - Laptop - Dell Community

Dell (e6400,e6500,m4300,m4400) Alps Touchpad Driver Issues


Laptop computer Forums (Audio, General Hardware, Video)

Dell (e6400,e6500,m4300,m4400) Alps Touchpad Driver Issues

This question is not answered

I believe all of these laptops use the same Alps touchpad and drivers.  I have several M4400's running XP SP3 downgrade.  The A06_R191111 driver was installed and working.  In trying to get a fix for the issue of motion speed settings not being saved after rebooting (this is apparently due to KHALMNPR.EXE in KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run - haven't tried this fix  yet).

Basically, the A06 and A09 drivers will not install or update.

I tried to upgrade to A09_R212017 which failed installation and left me with no touchpad drivers - just a "PS/2 Compatible Mouse".  With another laptop, I removed the Dell Touchpad driver A06, and A06 would not install again.  Using A06 or A09 setup.exe fails with "Alps Pointing-device driver Installer" "Cannot Complete the Device Driver Installation Wizard" "Alps Dell Touchpad (06/27/2008" or ((12/21/2008  "Install failed".

Some installation instructions said to set the mouse to a "PS/2 Compatible Mouse when uninstalling the touchpad drivers or before re-installing them.  If I use device manager and update the driver for the "PS/2 Compatible Mouse", by selecting "install from a list or specific location" and "Don't search.  I will choose the driver to install".  Have disk and browse to the A06 or A09 install folders and pick "Apfiltr.inf" to install the "Dell Touchpad". This installs drivers and finishes with "Cannot Install This Hardware"  "There Was a problem installing this hardware: Dell Touchpad".  "An Error occurred during the installation of this device" "Fatal error during installation".  Not much help in troubleshooting this problem.

One forum suggested Toshiba Alps Touchpad 7.2.303.104.1 was a little better than the Dell version.  Attempting installation gives the same errors. Using device manager" "There Was a problem installing this hardware: Alps Pointing Device".  Using Setup.exe, "Cannot Complete the Device Driver Installation Wizard".  "Alps Touch Pad Driver (07/31/2008 7.2.303.104" "Install failed".

One more mouse note related to this machine.  The bluetooth mouse driver worked, but after every boot came up with the message that it was not working properly and the driver did not install.  Manually updating the driver and picking "LMouHidK.INF" fixed this.  This is a Logitech driver dated 12/20/2005 Version 2.50.

My guess is there is some driver fragment remaining from the previous install on disk or in the registry that cannot be overwritten with a fresh install.  Any help would be appreciated.

All Replies
  • Did you ever resolve this?  I have the same problem now on an E3400.


  • You can try to install this driver: v5.4.104.4 - The latest DELL Alps GlidePoint/StickPointer driver

    This driver uses for INSPRION but It still works well with my VOSTRO 1400.

    Hope this work with you ! :D

  • Actually, I had to reinstall in the end.

  • I had the same problem on E4300 and E6400 when I was trying to update the A06/A07 version to the A09 version.

    After 2 days of testing I found the solution:

    Rename c:\windows\system32\drivers\wdf01000.sys to wdf01000.old.

    Start the installer and now it installs fine!

  • My Dell Precision M2400 has Windows 7 RC1, and when I install the "Dell_Touchpad Pointing-St_A9_R212017" I get an error that states the "Alps Dell Touchpad..... Install failed". Now one of the replies said that the wdf1000.sys needs to be renamed to wdf1000.old. How do you do this from Windows 7 (in use and no permission) or do you need to boot up with an UBCD outside Windows and rename? Isn't there an easy way to resolve the issue? How can I uninstall and reinstall this driver?
  • Many Thanks. This worked for me on my E6500 after suffering for 2 months with the problem and no help from Dell.

  • Bless Ya 8ERT,  I have to setup 15 E4200 solid state HD laptops and my image had the problem with the same thing, Fatal error on install of the touchpad.

    Your remedy of renaming the wdf01000.sys file worked perfect.



  • 8ERT,

    Worked for me on a E6400, thanks for the post!

  • Thanks, 8ERT.  Worked like a charm.

  • This worked, thanks very much you've saved me a lot of diagnostics!

  • Thank you for advise!

  • Thank You 8ert! This fixed worked great for me. You would think that when they say "look in the status colum for more details" the message would be a little more than "Driver install failed".

    Thank You!

  • There is now an A15 driver posted for the E6400 that solved all my driver issues. Check it out. The touchpad finally works like it should...

  • Trusted installer (Windows 7) will not allow me to change the name to old

  • dont change any .sys file name or you will can not logon to windows once you restart the computer anymore, he try to trick you guys,  I did it once and then I cannot logon to my windows.