Laptop won't power off when shut down - General Hardware - Laptop - Dell Community

Laptop won't power off when shut down


Laptop computer Forums (Audio, General Hardware, Video)

Laptop won't power off when shut down

This question is not answered

Hi!  I have a Dell Inspiron 1525 and two days ago it started doing this.  When I shut it down from the Start menu, it will turn everything off except it won't power off.  I have to hold down the power key to shut it off completely.  I have had to do this both days and I am not sure what the problem is.  Can someone help?!

All Replies
  • An easy way to tell if it's hardware or software would be to download and burn an Ubuntu Live Linux cd.  Your computer would boot off of the cd and run off of the cd without ever touching your harddrive and your OS on the drive.  Once the cd is loaded completely, go to the shut down area and tell it to shut down and turn off the computer.

    If you're able to turn off the computer from the linux cd, then it's most likely a Windows issue.  If it still won't shut down, then there is probably some hardware issue.

    This will at least get you started in the right direction of where to look and we can go from there.


    Information on the Ubuntu Live CD and download links can be found at:


  • I've got a very similar problem with a Latitude E6400. 

    Tried it with Ubuntu as suggfested and it shuts down properly so I'm guessing it must be something to do with the Windows power management. Any idea how to sort it?

  • So I got that problem figured out after visiting a few online forums to see what people have done to fix it.  Then a couple days ago it started again and this time what I had done earlier did not work.  Someone said to update BIOS and I did that and now all I have is a black screen with "time of day clock stopped" written on the upper left hand corner.  Anyone know what I can do to get back to my comp?  I find that lots of people have had the same problem with 1525.  I can't believe I am having so many issues on a computer that's just a year and half old!!

  • Same problem with my Latitude E6510.

    It went away after it asked if I wanted to restore a previous point. However it's come back.

    When I ran the BIOS (?) diag, it failed at the video colour test. (won't read any input).  Also the fingerprint read also isn't working.

    I'm going to hunt down another answer online.