Laptop Fn Key Problems - General Hardware - Laptop - Dell Community

Laptop Fn Key Problems


Laptop computer Forums (Audio, General Hardware, Video)

Laptop Fn Key Problems

This question is not answered

On a new Inspiron 1545, I have noted the following apparent keyboard problems:

1) The F1 key (shows a computer & screen icon):  Not discussed in the User Manual. What is it supposed to do?

2) The F2 key (Wireless Key): Discussed in the User Manual, toggles the wireless on/off state.  After the first week, the on screen state confirmation icon (an antenna) stopped being visible.  However the key still seems to work based on the information shown in the Windows Mobility Center.

3) The F3 key (Battery Status?):  Not mentioned in the user manual, and does not do anything.

4) Lastly the CD eject key (to the right of F12).  It sometime initiates a disc eject, but often does nothing.

I've checked the BIOS settings, ran the Dell diagnostics, verified no driver conflicts via the Device Manager, and searched the net & this forum for similar issues.  So far no real answers...

Before I take the laptop back  (and most likely loose hours of personalization settings) I'd like to see if anyone in this forum might have any suggestions.  Thanks...


Inspiron 1545; Dimensions: XPS Gen2 & 4550

All Replies
  • I just found the solution!  There is a Dell program called Quickset that seems to control these function keys.   I stumbled upon it ran it and the keys worked.  The Best Buy Geek Squad tech disabled that program using msconfig when I brought the laptop back for a startup problem generated by a Dell driver update - he did a lot so fast I could not keep track.  Yet, did see hime disable several startup programs via msconfig.   I ought to go back and thank him for the hours I lost trying to figure out why these keys stopped working...

    Also I found out what the F1 key was used for - connecting to an external monitor.  Now all four of the problem keys work

    Problem solved!


    Inspiron 1545; Dimensions: XPS Gen2 & 4550

  • and what abut  the CD eject key (to the right of F12).   did you find the sulotion to this problem as well ?

    because most of the time when i use this key the o's (vista 64) freezes

    did any one find the sulotion to this ?


  • Actually, I did not specifically check that key - I assumed it would be ok seeing that the other Fn keys were functional.  However, I will check it now...

    Inspiron 1545; Dimensions: XPS Gen2 & 4550

  • Is this a pre-installed version of Vista x64 or an aftermarket install? It does make a difference. In other words did Dell install the x64 or did you? 

    Dell Precision 7400 2x L5420 Xenon @2.5Ghz 8gb Ram 500gb FX1700

    Dell Precision 670 Workstation 3.6GHz Dual Xeon Cpu's, 6gb Ram, Nvidia Quadro FX1700, 1.5tb of hard drive space,

    Dell PowerEdge 400s P4 3.0 1gb ram 2tb

    Dell Optiplex 260 P4 2.4, 2gb of ram, 1.5tb hard drive space, ATI 256mb

    2x Latitude E7400, 4gb 640gb

  • In my case, the Vista x64 OS was pre-installed - pressumably by Dell.

    Inspiron 1545; Dimensions: XPS Gen2 & 4550

  • my  case to it was pre-installed by dell ...

  • It's been more than a year since you posted this message, and it's still helping people!  I had the same problem (after having a local computer repair company work on my comupter, my Fn keys did not work). I tried dozens of "solutions" posted throughout the 'net but nothing worked until I came across your message. I located the Dell Quickset program, launched it, and got my Fn keys back!  Thanks so much ....