Dell Inspiron Mini 9 - battery not working - General Hardware - Laptop - Dell Community

Dell Inspiron Mini 9 - battery not working


Laptop computer Forums (Audio, General Hardware, Video)

Dell Inspiron Mini 9 - battery not working

This question is not answered

My Mini 9 has been working great for the two months I've had it so far.  Yesterday, it stopped running off the battery.  When it's plugged in, it will start up.  It will also work if I have the battery out but the AC power in.  If I try to turn it on with just the battery and no AC power, I get nothing.  No BIOS screen, no boot, no lights, nothing.  When I plug in the AC power, the white light turns on to show that it's charging, but it never goes off.  I have reseated the battery many many many times, and I have not made any system changes in Ubuntu.  Has anyone else experienced something similar or have a solution? 

All Replies
  • i have exactly the same issue. dell support  told me to contact ubuntu and "check all the settings" and also to contact dell ubuntu support to update my bios...

    it seems from all symptoms as if the battery is not recognized, but if i do: dmesg | grep -i batt, i get "ACPI: Battery Slot [BAT1] (battery present)" - so i would suspect the battery just isn't getting charged properly. if i hit the power button when on battery only, i get a quick flicker on the screen then just nothing, i.e. no power.

    probably will try to get the battery replaced.



  • Two things for customers who are experiencing battery and charge-related issues with the Mini 9:


    1. Make sure to flash your BIOS to the A04 version
    2. The first time you charge it, please leave it plugged in for 12 hours.


    More information coming in a Direct2Dell blog post happening tomorrow.



  • I have been working on this issue with my friends Mini 9 for a couple of weeks now.  The only answer on the forums is to update the BIOS to A04.  I did the update, but it did not fix the issue.  It has been very frustrating, as no one seemed to have a solution.  Last night I stumbled across another blog that gave me the answer.

    THE REASON:  The reason that the battery is not charging, is because the OS (Ubuntu) thinks that it is in Airplane Mode.  When in Airplane Mode, the battery will not charge.

    THE FIX:  Make sure that Airplane Mode is NOT enabled.  Go to System -> Preferences -> Airplane Mode.

    NOTE:  When I first checked my friends Mini 9, it said that Airplane Mode was not enabled.  I wanted to make sure though, so I enabled it, and then disabled it.  The OS immediately saw the changes and began charging the battery.  The Mini 9 now has no problem charging at all.

  • I just got mine Friday and on Saturday I started having the same issue, the battery stopped charging. I looked everywhere for a solution and then yesterday realised that I had put it in Airplane mode when the problem started. I took it off that mode and the battery was charged 2 hours later. Check to make sure that its not in Airplane mode.

  • Make sure its not in Airplane mode. Doesnt seem to charge in that mode.

  • Except for one problem...

    Install instruction:
    Step1:Make sure AC installed and battery capacity over 10%.
    Step2:copy those file into bootable usb key.
    Step3:Boot to Dos, type 910A04.bat
    That kind of puts a damper on the whole charging thing - if you have to charge the laptop to 10% before flashing the BIOS, which supposedly then allows it to charge (implied by Lionel_Menchaca's post), it becomes a Catch-22.  What I'd like to know is how a BIOS update can be the difference between a hardware charger working and not working?  That doesn't make a single bit of sense.  There shouldn't be ANY software involved (which is what the BIOS is).
    I've got the same problem.  I've tried all the "Airplane Mode" fixes, removing the battery and putting it back in, but it still won't charge just keeps blinking and blinking and blinking...
  • Ah.  Interesting.  Here is the blog entry Lionel_Menchaca was talking about:

    I now understand what is going on (sort of).  I left the laptop unplugged for about three months and the battery completely drained.  So, the battery is apparently in "pre-charge" mode and needs to just be left alone for 12 hours to get charged up properly.  So I have to wait for it to charge to 10% and then I can choose to flash the BIOS.  The only relevant change to the BIOS is improved battery performance (probably for when it is already powered on).  That means the BIOS really has nothing to do with charging the laptop battery, just how fast it drains when on battery mode.


  • Well, it has been 12 hours.  No change.  What now?  I guess call Dell.  I've owned this laptop for 5 months and "used" it maybe 5 or 6 times.  I'm not really alone - people are slowly discovering the same problems with the battery that I have where it just randomly keels over and dies.


    Well, battery have a life cycle, you can charge and discharge for about 500 times.  And then it is capacity may get small or can' t work. 

    And then you need to buy a new battery. Smile I have learn  some tips to take care of our battery on this site

    The battery should be re-installed every 3-4 weeks and allowed to fully discharge. Leaving a battery in storage for longer than this without using could cause the battery to fully discharge as the circuitry of the battery itself consumes power.

    Leaving a battery in a laptop while using an electrical outlet for long periods of time will keep the battery in a constant state of charging up and that will reduce the life cycle of the laptop battery.

  • Tina He
    Well, battery have a life cycle, you can charge and discharge for about 500 times.  And then it is capacity may get small or can' t work. 

    I already know that.  My point is that I turned the thing on maybe 5 or 6 times during my entire ownership of five months.  Compare this to my 10 year old Dell laptop which, while the battery never was the greatest, still works.  I use both laptops at about the same rate.  Given that knowledge, this battery should still be fine.  It isn't.  The Mini 9's battery died after only a few uses and 95% of that time it was in use, it was plugged into the wall.  This means the batteries Dell is shipping with the Mini's are poorly constructed and die after a few months.

    Running a few searches on the Internet has shown me that I'm not alone.  People are slowing discovering this same problem with the batteries.

  • You are right, So many people have to buy replace battery for their laptops.

  • Best customer service experience I've experienced in a REALLY long time.  I worked through the standard hoops technical support makes you jump through.  Took only 10 minutes for them to determine that I had basically diagnosed the problem myself.  Dell is shipping out a brand new battery to me along with what sounds like a RMA (hard to tell at times what the support person was saying).

  • The battery arrived today!  Yikes that was fast (Standard Overnight shipping)!  I wasn't available, so the dead one isn't on its way back yet (I'll stop off at a Kinko's later today).  It is a standard RMA as expected.

  • The dead battery is on its way back to Dell.  The new one charged up nice and quick and is fully charged.  Everything seems like it is back to normal.  This is one of the best customer experiences I've had with Dell in a long time.  The overnight shipping was a nice touch but overkill.

  •  I have only owned this computer for about a month. I'm having the same battery problem. when I try to go and change the airplane mode it says I need an administrative password. I don't remember ever setting a password on this machine. Not sure what I need to do. Any suggestions? I'm used to windows, this operating system is all new to me.