plugged in, not charging - General Hardware - Laptop - Dell Community

plugged in, not charging


Laptop computer Forums (Audio, General Hardware, Video)

plugged in, not charging

This question has been answered by Gseif

I purchased a Dell Inspiron 1525 in April 2008.

About 1 month ago I noticed that my computer would automaticaly shut down when the power cord was removed, I hovered over the battery icon in the bottom right corner and it said 0% available plugged in, not charging.

I googled the phrase plugged in, not charging and realised lots of people were having the same problem.

I have tried

  • restarting and shutting down my computer (with and without battery and with and without power cord)
  • removing and replacing my battery (while laptop is on and off)
  • a replacement battery from Dell
  • my sister's battery and power cord (she also has a 1525)in my laptop and get the message plugged in, not charging. My battery in her laptop will charge but my power cord in her laptop says plugged in, not charging
  • removing the battery with the laptop on then restarting the laptop and replacing the battery
  • uninstalling and reinstalling the Power Management Software
  • switching between power plans
  • flashing with current bios

All 3 batteries (hers, my original and my replacement) have adequate charge (50% or higher)

I run with Windows Vista Home edition

Can anyone help me or suggest anything else?

I have been to the local Dell distributer and they tell me to call Dell.  I have tried calling Dell but I keep getting put on hold for 30+ minutes.


All Replies
  • Glad it worked! :)

  • This doesn't just work for Vista. This problem has been frustrating me to no end. This is the second time my computer stopped recognizing my battery  (I've got a Studio 1558 running Window 7 Home Premium) and this solution fixed my problem! Just the diversion I needed (in the middle of a hurricane right now).

  • Good news!

  • All,

    We just had this problem today.  After running bios tests I pulled the cord from the adapter and just replugged it in.  It worked and the bios recognized the 65w adapter. It was supplying power just fine, but now it is recognized.  Dell does have a design flaw with the power adapter. The cord coming out of the brick to the computer is not straight, it has a 180 degree bend.  This means that if the cord has any stress in it, then the bend has stress too.  What I did is put a couple of zip ties on the adapter to make sure that the joint coming out of the adapter is never under stress again.  Let's see if that will help long term.


  • You are not alone. Don't waste your time on replacing the adapter. Dell laptops have a problem with their motherboards. The chip which recognizes the adapter dies and the adapter will be refused to be recognized by the unit, causing charging to stop. Once in a blue moon, it will allow a charge, but what good is that? Dell refuses to acknowledge this problem so I am not buying any more Dell products until they offer a recall and replace the defective motherboards for free, whether under warranty or not.

  • SBiff, I just followed ishakooner's suggestion on my Studio 1545 and it worked! Now the question is: will it continue to recharge the next time the laptop battery is discharged? I'm a little afraid to try.

  • Well SBiff, IshaKoonar's suggestion to boot on battery, then reattach the charger worked only once. No more. After one complete charge/discharge cycle, the motherboard again refuses to recognize the AC adapter for more than 20 seconds. It shows charging for 25-20 seconds, then "plugged in, not charging" reappears.

  • tried loads of these suggestions but finally "hard tapping" solution by kjr_23 worked for me - pasted below. It must often be just a dodgy motherboard connection.

    "SOLUTION!!  I have a Inspiron 1526 purchased from Best Buy and a Inspiron 1525 purchased directly from Dell.  I also have a work Dell Latitude, so I was fortunate enough to be able to try alot of different combinations.  I had the problem with the 1526 only.  IT IS NOT - the battery, the charger, the bios.  I tried all of the solutions, updating the BIOS, installing the updated Dell power management driver, even the "magic" ones like taking the battery out and holding down the power button for 10 seconds etc.  THE PROBLEM is a loose connection somewhere between where you plug in the AC adapter and the motherboard.  What actually worked for me was LIGHTLY punching/tapping the surface next to the plug, right where it says "Inspiron".  It must've jarred the loose connection and now it it making the connection.  This kinda makes sense that some of the other solutions worked.  Depending on how aggressively you press the power button or put the battery back in may also make the loose connection "reconnect".  The actual solution is probably to take the cover off and check those connections, but most of us aren;t technical enough to know what to do, and would probably do some damage.  So I recommend tapping on the surface, just above the esc key above where the plug sticks in and continuing to tap across till the first button.  I did this while the computer was on and "plugged in, not charging" and it switched to plugged in charging within about 5 seconds.  I don't remember if I saw anything flash on the screen or if something in the tray changed, but I think it did.  I am not joking, this really did work.  Obviously, when you tap/pound on your own computer, you are taking a risk.  This is your own computer, so if you use this technique, use it at your own risk.  I am merely posting what worked for me, just understand that if you punch your computer you can damage it also, so be careful.  Good luck, I'm glad mine is finally working again."

  • For me it is a connection thing too.  What I do is to plug, and unplug in the cord at the adapter.  If I do it a few times, that usually does the trick for me.  So in my case, a new adapter will probably work.

  • That helped! 


    Immediately after I pressed the fn and F2 keys, the battery immediately started charging!  Thank you for that.


    Though, I cannot imagine why, FOR ANY REASON, anyone would want to stop charging their drained laptop battery.

    Maybe this odd feature will be removed in future Dell laptops..


  • I unplugged and then plugged my battery back in and now it's charging (I hope that it's a permanent solution and that I don't have to keep doing this!!)

  • Jayca1
    THIS IS A PURE VISTA (software) problem.

    Absolutely wrong.  The Original Poster has walked you through the fact that the Dell's BIOS (that is Basic Input Output System) which is *PRE* Operating System in hte boot order, has reported that the AC ADapter is not being detected properly.

    In a Plug and Play system, the PNP Compliant BIOS is responsible for hardware enumeration, and for passing the info about hardware up the the operating system at system boot.



  • If the computer was under a year old the warranty would of covered the motherboard replacement!

  • all that is rubbish...this worked for me and alot of other people also and follow exactly.same problem came back abt a month later...but worked again and battery is now charging see this link

  • Hi,

    This is very common problem with dell's inspiron's especially with 1520. Problem lays with chip MAX 8731 (in other laptops can be found also MAX 8734), and it's surroundings. The chip is quite cheap - about 8 $ but it's impossible to change it without hot air soldering station (it's BGA chip). But it isn't necessarily the chip only, it can be something of it's surroundings like burnt resistor so there you should look.