plugged in, not charging - General Hardware - Laptop - Dell Community

plugged in, not charging


Laptop computer Forums (Audio, General Hardware, Video)

plugged in, not charging

This question has been answered by Gseif

I purchased a Dell Inspiron 1525 in April 2008.

About 1 month ago I noticed that my computer would automaticaly shut down when the power cord was removed, I hovered over the battery icon in the bottom right corner and it said 0% available plugged in, not charging.

I googled the phrase plugged in, not charging and realised lots of people were having the same problem.

I have tried

  • restarting and shutting down my computer (with and without battery and with and without power cord)
  • removing and replacing my battery (while laptop is on and off)
  • a replacement battery from Dell
  • my sister's battery and power cord (she also has a 1525)in my laptop and get the message plugged in, not charging. My battery in her laptop will charge but my power cord in her laptop says plugged in, not charging
  • removing the battery with the laptop on then restarting the laptop and replacing the battery
  • uninstalling and reinstalling the Power Management Software
  • switching between power plans
  • flashing with current bios

All 3 batteries (hers, my original and my replacement) have adequate charge (50% or higher)

I run with Windows Vista Home edition

Can anyone help me or suggest anything else?

I have been to the local Dell distributer and they tell me to call Dell.  I have tried calling Dell but I keep getting put on hold for 30+ minutes.


All Replies
  • I have a Dell Latitude E6410 that I encountered this problem with. I did figure out that I accidenly when using the FN Key and F1 (Sleep mode) that I hit the F2 key which also has a icon for battery. This toggles the charging of the battery when plugged into AC power. You can test this to see and watch the message on the battery icon change.

  • Hi,

    Windows 7, Dell latitude E6510.

    I had similar symptoms but in my case it was easily resolved by clicking right on the battery on the taskbar. Went to Dell Battery meter (contextual menu) and in the pane Battery status, i have unset the Disable battery charging (not sure how it got set in the first place)

    Like you i believe that the issue is a software one as it looks like it is an option to not charge the battery (maybe for sedentary use of the laptop)

    Hope this will help someone!


  • So awesome!  I was skeptical but it totally worked for me (at least for now!)

  • Dell E6510 - Same issue as above,  an even easier solution.

    i noticed the Battery with the lightning bolt on the F2 Key on the top row.   I dont know why they have this on there,

    but Pushing the FN key + the F2 Key enables or disables Battery Charging.


    Fixed the problem on mine instantly.  I think I had been used to my old D Series and was trying to disable the wireless, and hit that combination and disabled battery charging.


    hope this helps.


  • I had the same problem, plugged in not charging.  I unplugged the adaptor, logged off the computer, took my battery out for a minute, replaced the battery, logged back on and it started charging again.  I just hope it lasts

  • Allowing the adapter to discharge for a minute or so, as described by Lynnia above, worked to end "Plugged in-not charging" message on my Latitude E6500 running Vista. While it was unplugged, I also blew air into the end of the adapter cable and the receptacle on the laptop before reinserting as someone else suggested.

    Thank you forum members.

  • Chunks_ please stop posting links to that site. You have done that in all your posts under your various usernames. My security will not allow me to access it. I don't know why except that it has a "Poor Reputation" according to its WOT rating. If we are going to refer members to other sites, let's check the reputation of those sites first. Thanks.

    Windows Insider MVP 2016 -

    Microsoft MVP - Consumer Security 2006-2016

    Social Media and Community Professional

    I am not a Microsoft or a Dell employee. I am a volunteer.


  • I found the same problem last week on Mums Dell Inspiron 1525. I tried Google for the solution, and came across this site in the process. After much research it seems that this is a very common problem at present, with no solution offered other than hit the computer above the Esc key!

    So here is how I solved the problem.....

    Click on Start, My Computer, then right click  on Local Disk C. Click on Properties, then Tools, then Error Checking, Check now. Shut down the computer and restart, which will put the error checking into process. When I did this it identified and repaired a number of disk errors and following the operation the problem was solved and the computer works perfectly - plugged in or on the battery.

    No guarantee folks, but it worked for me.

    It´s relly working on my Dell Inspiron 1520 Laptop! It´s sounds not logical but it´s work! Smile  However I will not buy a Dell again. The Power Jack sucks, the Hinges sucks, the Microphone sucks, the Plastic sucks. I heared that Fujitsu Siemens, HP, Samsung and Toshiba laptops are very reliable! I have questioned my friends, so that will be my next Buy List! :P


  • Jayca1


    Yes I tried all the previous steps including flashing BIOS with latest update but no luck. Replacing teh MB seems to have resolved the issue.


    On another note if you google "Plugged in not charging" you get 100's of hits and it seems like a widespread problem related to Vista and not a computer manufacturer. Seems like all makes of PC's are having this problem for one reason or another. A lot of people have reported success in resolving this issue by following the below steps that I copied and pasted from another forum. No Guarantee it will work but who knows..

    In many cases it has been a Vista software problem.

    Good luck !



    Click Start and type device in the search field, then select Device Manager .


    Expand the Batteries category.


    Under the Batteries category, right-click the Microsoft ACPI Compliant Control Method Battery listing, and select Uninstall .

    WARNING: Do not remove the Microsoft AC Adapter driver or any other ACPI compliant driver.


    On the Device Manager taskbar, click Scan for hardware changes .

    Alternately, select Action > Scan for hardware changes .

    Windows will scan your computer for hardware that doesn't have drivers installed, and will install the drivers needed to manage your battery's power. The notebook should now indicate that the battery is charging."

    It's working again.
    THIS IS A PURE VISTA (software) problem.


    This worked for me and I'm on Windows 7 with a Dell Studio 1558. My batter indicator was saying 91%; plugged in, not charging.

  • I had the same problem with my Studio 1457, plugged in not charging.  I have been using this laptop for 1 year and four months. My first power adapter failed before one year and now my second adapter is having this problem just after the 90 days warranty period. I am using Windows 7 Pro and I have tried the above methods but to no avail. Dell battery and adapter seems to have a lot of problems.This is really disgusting!

  • Thanks so much for offering a simple solution which worked :)  fingers crossed the error doesn't happen again.

  • I was having similar trouble and found a really basic solution. 

    If you hit Function F2, you shut the charger off.  Easy to do if you are trying to set the Sleep mode (Function F1)

    The clue is that the battery light goes off (right next to the WiFi light) by the Escape key.

    Had tried several of the other steps and then had a A Ha or is DUH moment. 

  • I faced the same problem with Inspiron 1525. Rebooting the computer on battery power and then plugging in the charger solved the problem for me.

  • This worked for my 1501 running Vista. Started with blowing and kept on going till something worked and this was it.

  • Thank you, IshaKoonar!  I tried all of the above suggestions (except those that required spending any money) with no luck.  Your simple suggestion is the one that worked for my Inspiron 1525.  It seemed to me that the computer was just confused (this plugged in-not charging thing started after installing some of those regular Microsoft updates that required rebooting).  So, folks, if you have a 1525, don't run out and buy things or replace things before you try IshaKoonar's suggestion.  Just unplug the adaptor, reboot it while on battery power, then plug the adapter back in.  Poof!  It works!  Battery is now fully charged again.