plugged in, not charging - General Hardware - Laptop - Dell Community

plugged in, not charging


Laptop computer Forums (Audio, General Hardware, Video)

plugged in, not charging

This question has suggested answer(s)

I purchased a Dell Inspiron 1525 in April 2008.

About 1 month ago I noticed that my computer would automaticaly shut down when the power cord was removed, I hovered over the battery icon in the bottom right corner and it said 0% available plugged in, not charging.

I googled the phrase plugged in, not charging and realised lots of people were having the same problem.

I have tried

  • restarting and shutting down my computer (with and without battery and with and without power cord)
  • removing and replacing my battery (while laptop is on and off)
  • a replacement battery from Dell
  • my sister's battery and power cord (she also has a 1525)in my laptop and get the message plugged in, not charging. My battery in her laptop will charge but my power cord in her laptop says plugged in, not charging
  • removing the battery with the laptop on then restarting the laptop and replacing the battery
  • uninstalling and reinstalling the Power Management Software
  • switching between power plans
  • flashing with current bios

All 3 batteries (hers, my original and my replacement) have adequate charge (50% or higher)

I run with Windows Vista Home edition

Can anyone help me or suggest anything else?

I have been to the local Dell distributer and they tell me to call Dell.  I have tried calling Dell but I keep getting put on hold for 30+ minutes.


Verified Answer
  • it is work !! thankyou very much

  • I dug out my Dell User Name and Password just to say Thanks!.  This actually worked.  At first I thought it was a prank, since it is such a strange and bizarre a solution.  

    NOW the question is WHY?

  • This worked for me also...that is nuts...i was about to be upset with my husband thinking he broke it and didn't tell me. lol...weird. thanks 

  • OMG thank you so much ! it worked !
    lool i tapped a little under my laptop and the battery started charging! funniest thing ! XD

    this does really work, dont hit too hard though, it'll damage it

All Replies
  • I just had a phone call from the Dell Online Techician.  He said to;

    Shut Down the laptop.

    Press the power button then tap the F2 key until a blue screen appears.

    On the left sided menu arrow down to Battery Info.

    On the right side of the screen my computer showed

    • Battery Status = idol
    • Battery % Charged = 99%
    • AC Adaptor = Unknown Device Installed

    He then told me that he's have to post me a new ac adaptor, so fingers crossed that this will solve my problem!

  • I had the same problem with my M1530..  Twice now.

    The first time a couple of months ago I had the "Plugged in not charging" problem. Called Dell and they sent out a new AC adapter. Did not solve the problem so they sent out a new battery. Still did not solve the problem. Then one tech told me to upgrade my BIOS. That worked ! battery now charging and teh "plugged in not charging" message was gone. :-)


    Untill three weeks ago.. The dreaded "Plugged in not charging" message came on again. Well this time I had to ship out the laptop to have the motherboard replaced. Working fine now... so far :). Now it also reads my battery in the BIOS and does not say Unknown device Installed like it did before.

    Hope all is good now.

    To the original poster... If still under warranty call tech support and have them fix it.


  • Jayca1, regarding when it failed again only three weeks ago: did you try the same things again, i.e. different battery, different ac adaptor? If so, I gather they made no difference. In which case, did you try flashing the BIOS again and did that also fail to solve the problem? I have an Inspiron 1501 and I'm determined to find out exactly what goes wrong with these pathetic machines, since the type of problem is extremely widespread. If it's not 'ac adaptor not recognized', it's 'battery cannot be determined'. I'm not spending hundreds replacing parts that should last longer than 13 months. One way or another, I'm going to find out exactly what is happening with the laptop.


    If people stopped buying from Dell, they'd be taught a lesson. Unfortunately people get annoyed, think how wrong it is and how badly designed the products are, pay through the nose to buy overpriced shoddy replacement parts, are then happy because it's al working again and subsequently forget about the issues and next time they buy from Dell again! What utterly foolish behaviour, and then people wonder why they treat us like ignorant little money machines!

  • doesn't look promising.

    i just did the F2 thing on my sisters computer, hers said

    • Battery Status = idol
    • Battery % Charged = 99%
    • AC Adaptor = 60 w


    then i did it again on mine with her power cord and mine said

    • Battery Status = idol
    • Battery % Charged = 99%
    • AC Adaptor = Unknown Device Installed


    Does this mean that it is my computer, not the battery or power cord?

  • @Gimpoid,,,

    Yes I tried all the previous steps including flashing BIOS with latest update but no luck. Replacing teh MB seems to have resolved the issue.


    On another note if you google "Plugged in not charging" you get 100's of hits and it seems like a widespread problem related to Vista and not a computer manufacturer. Seems like all makes of PC's are having this problem for one reason or another. A lot of people have reported success in resolving this issue by following the below steps that I copied and pasted from another forum. No Guarantee it will work but who knows..

    In many cases it has been a Vista software problem.

    Good luck !



    Click Start and type device in the search field, then select Device Manager .


    Expand the Batteries category.


    Under the Batteries category, right-click the Microsoft ACPI Compliant Control Method Battery listing, and select Uninstall .

    WARNING: Do not remove the Microsoft AC Adapter driver or any other ACPI compliant driver.


    On the Device Manager taskbar, click Scan for hardware changes .

    Alternately, select Action > Scan for hardware changes .

    Windows will scan your computer for hardware that doesn't have drivers installed, and will install the drivers needed to manage your battery's power. The notebook should now indicate that the battery is charging."

    It's working again.
    THIS IS A PURE VISTA (software) problem.
  • Argh its happening to me now .. My inspiron 1525 adaptor was playing up so i have ordered a new one which should arrive in the next two weeks. But in the mean time by adaptor is working  but i have only 1% of battery available ( plugged in not charging ). Do you think its the adaptor ?? Did the above advice work ??  Would love some advice cheers xWink

  • Hate to have to tell you this - but I have been through the same thing with my Inspiron 1520. After trying 3 different chargers, going through all the"diagnostics" from tech support, still no luck. I bought it January 10, 2008, so it is not even a year old. I also bought an almost $400 warranty. They are telling me now that the problem is the motherboard needs to be replaced and that my warranty doesn't cover it. I am livid. No one stands by their products anymore.

    I cannot even get to a person there to complain. Phone tree and options and recordings. The online chat is timeconsuming and ridiculous.

    So many people told me to buy a dell - never again. Next time I'm getting a mac.

  • Just had a Dell Technician visit me and replace my motherboard under warranty.  :-)

    Everything works perfectly now.

  • Ive had laptop for 6 months i dont think its under warranty i'm not sure ..Hmm Just checked yes it is :)

  • Does the Dell chat link work as Ive been trying all day . I rang the support line obiviously a call center in India, but gave up after hanging on for 30 minutes Angry


  • Hi cait68 I had the same problems.  I could never get connected to online chat and always got put on hold for EVER!.

    I managed to get thru on this number 1800 812 393. (Not sure what number u've been calling, but I hope this helps and hopefully ur still covered under warranty!)


  • Hello All, i had a similar problem in Nov-dec 2008 after 9months of owning a M1530, as i wasnt in the country where i bought the laptop i sent an email instead of calling Dell (30mins waiting on a international call would have been a killer), i got a response 3 days later, i replied & got another response 2 days later with the solution to my problem - a new ac adapter & a new battery. I had it posted to the address i got when i bought the laptop & subsequently had them sent to me in the country i am.

    point sending email may not get immediate responds but its works 

  • Hi,

    Another "me too" to add to the hundreds of others that I've seen on forums on various sites Sad

    I bought a new Dell 65Watt AC adapter and have also replaced the power cord but it made no difference. Machine is out of warranty. As this appears to be such a common problem it looks to be a design fault which is unacceptable and is going to steer me away from buying Dell again in the future.

    Dell Inspiron 6400, BIOS ver A17.

  • I'm not going to blame Dell on this one until I try out a few things. 1) Dell is sending me a new battery (I bought it, as my computer's out of warranty). 2) My various power supplies have no impact upon this (I own two). I can run on AC power, not battery. 3). I bought an extended warranty from BEST BUY, so I may run up there. If they have to replace the motherboard, so be it - I back up regularly. 4) I did try a suggestion on checking the drivers for batteries, but I'm up to date. 5) While laptops should be able to take some abuse, I had mine fall off the desk the other day, so this may be MY FAULT.

  • I had this issue on my dell Inspiron 6400 with vista.

    I saw that a number of people had linked it to a bios issue, not hardware. However, you can only flash the Bios if you have 10% of battery remaining and i didn't have that. About to give up i installed Presto, the instant on OS so that I could at least use the laptop in some way. But in Presto the battery charged and I was able to start windows again and flash the Bios


    Flashing the Bios to the latest version (A17) worked. In this case it was a Vista issue not a hardware one