D830 shuts down without warning

Laptop

Laptop
Laptop computer Hardware and Software discussion

D830 shuts down without warning

This question is not answered

I have Latitude D830 running Windows XP SP2. I actually have a batch of 20 of these, all from the same order, but one is behaving badly. For a few weeks it worked fine. Suddenly one day, it just powered off. Not nicely either, it just lost power. I suspect a battery, or power power supply, so I swapped out the power supply and removed the battery and powered it back up.. it stayed on for a short time and then went off again. I let this one sit for a several weeks (I have 19 others remember), then came back to it, having forgotten all about the issue. I was able to reinstall XP, install updates, and use it for about a few hours before it "lost power" again.

Any ideas? It is running BIOS Rev A11.

Thanks,

Jeff

All Replies
  • Have you tried going back to BIOS version 09? Let us know  ... I believe it's a BIOS / Chipset update problem with the Motherboard. Revert to the exact firmware configuration and RAM that came with the 830. Let us know.

  • Ughh! I hate the idea of backflashing a BIOS and especially if there is not a related, known issue like I'm having.

    If there is a known issue, then I will certainly do that, but I hesitate otherwise because I could be creating other problems based on the fact that A09 is much older than A16 and my drivers are setup to work with A16.

    Don't you rather think it's something more practical/mundane?

    What I did after my last post was take the laptop apart most of the way (keyboard, HDD and DVD drive, inserts for the smart card and PCMCIA cards, battery, memory door on the bottom). Then I took compressed air from my air compressor and thoroughly blew out all the dust and if there were any tin whiskers they certainly are gone.

  • The other thing is that this was happening with the original RAM which I have since upgraded both chips to max it out at 4GB, so that's out.

  • When I first noticed this happening, it seemed to be because of the NVidia graphics card, and was happening mostly while I was playing a couple particular games (I wasn't playing any other games, but games being a little more graphics intensive, that's where I got the idea that was the cause). But then it started happening occasionally even though I wasn't playing any games so I thought it was temperature related, so that seemed to fall through. We'll see if it happens again too soon and then I can consider doing what you said, but I recently just redid my system from scratch (for the first time since I bought this used laptop almost a year ago) and really want to avoid anything radical that could make it worse or I may end up having to set it up again which is a lot of work. It crashes like this about once or twice a week at most. It seems like I've had it running for several weeks one time without this happening. If it was that kind of BIOS issue, I would expect to be fighting this issue a lot more offen, like several times a day or more.

  • I found it quite simple to return to an earlier BIOS, just override the window stating that "This BIOS is older than the one currently installed". I am not sure you are correct in stating current programs are set up for the latest BIOS upgrade. My 830 improved markedly and the problem appeared to be corrected when I returned to the earlier BIOS release. Must point out that my 830 only shut down while on battery. As soon as the power plug was removed the system crashed until I set an earlier BIOS verson and installed a smaller HDD. 750GB down to 500. Only complication is if there are several causes for a problem and any one of them is intermittent. Suggest you purchase another 2Ghz D830, can be picked up at Government auctions in great condition for about $100 then transfer - install your hard drive and RAM and keep your current machine for possible spares. Good Luck.

  • I have the same problem, I have dell d830 80gb hdd and 2gb ram only, it shuts off without warning even while not playing games, but 1 thing is confirmed, it shuts off when plugged in (while not on battery)  and it is not overheating issue(temperatures were under normal values). I am using latest bios A16 with Windows 7 sp1.

  • I haven't replied on this in a month, but my D830 is entering its longest period of stability in quite a while that I can remember.

    No more sudden shutdowns since April 15th (almost 3 weeks ago).

    What happened is that I was having an increasing number of these suden shutdowns right after I installed some programs. Many in the same day.

    Uninstalling those programs however, was not enough to stop them.

    What stopped the sudden shutdowns was simply backing up my data, deleting my Windows XP profile, rebooting and recreating the profile.

    (I also used some registry cleaners mentioned on techsupportalert.com and have gotten in the habit of installing all my programs with Revo Pro.)

    I reinstalled the programs that seemed to cause these to happen a lot more than before, yet no more sudden shutdowns.

    Ever since April 15th, rock solid stable, even surprisingly so after I started to put great strain on the machine's resources which before that time used to cause predictable shutdowns. I haven't been able to do anything yet that has caused the sudden shutdown since recreating my Windows XP profile.

    Has not turned out to be a BIOS issue or a heat issue, and probably isn't even a driver issue although nearly all my drivers are WHQL-approved anyway.

    My BIOS is still A16.

    This time around, I will wait a good long time before I can suggest this as being an answer. Say the end of May, which would put this over 6 weeks out.

  • Thank you ssybesma. I have sold my D830 and gone back to an D630 ATG 2.6Ghz model. Good Luck.

  • D630s are pretty reliable laptops. In some ways better than the D830s. Used to use those when I worked at the EPA.

  • So, have anyone or dell itself confirmed the real cause of these shutdowns. I will also try the windows profile deletion and recreation, but it seems more like a hardware issue to me rather than software.

    Waiting for more replies

  • I think the closest we've had to a solution is backflashing the BIOS.

    I just had this happen again this past Sunday after it not happening for three weeks straight.

    So, my solution is at best a partial solution. Forestalling the inevitable.

    I am now deciding what version of the BIOS to backflash to.

    If that solves the issue, we should all request that Dell put out a new version of the BIOS that isn't broken.

    I really don't like backflashing the BIOS, because when you install the OS and drivers, they actually detect
    and work with the version of the BIOS you have on your machine. If you backflash it, you could be 'breaking'
    how something else works. I don't want to chase my tail.

    But, if it really fixes this occasional but very annoying problem, it's certainly worth a try.

    It would take me the better part of a couple months before I know this is the solution, because I've never
    went out that far without this happening.

  • 1 thing I also have noticed with this issue of mine.

    It only happens when skype is running and my desktop resolution is high these shutdown issues are very high

    at lower resolution it rarely happens

    It never happened without skype

  • When it happened a week ago Sunday, I was playing a YouTube video. The cause has been impossible to pinpoint because no errors are ever left in the Event Viewer when it happens. I have to believe the BIOS is the last hope other than a motherboard replacement, but I hate backflashing, like I said before. The OS doesn't trap the error so it seems to be something on a lower level than the OS can detect. Things that occur in the OS only seem to exacerbate it or make it happen less often.That's why for a while I thought it was the Windows profile, and for a while before that something temperature-related. I have ruled both of those causes out.