No Boot Device Found - General Hardware - Laptop - Dell Community

No Boot Device Found


Laptop computer Forums (Audio, General Hardware, Video)

No Boot Device Found

  • I've had this kind of thing before on anothe machine.  In this case it isn't so dire as much as it is a nuissance.


    When booting, it beeps and displays the typical "No Boot Device Found - F1 to restart, F2 to configure ..."

    If I press F1, it will boot up.  If I press F2 and just exit without making any changes or saving, it will also boot up, and if I have the Windows CD in the drive, it will boot up on its own.  I just don't know why it won't boot normally on its own.


    I have two disks making one logical volume.  The LUN is defined as the boot device.  All appears to be right in the boot up sequence.  Thoughts?  Thanks!

  • (Bump.)
  • I have the exact same issue with my 2 month old XPS and it has been an issue for as long as I have owned itIt occurs approximately once per week, sometimes more and sometimes less. The problem will persist until I repair the BCD. (I use Easy BCD from NeoSmart Technologies to do the repair.) Once I repair the BCD the problem goes away, only to return after a period of days. I have tried restoring the master boot record and BCD from the Vista CD as well. The repair is always successful no matter which method I use to do the repair.


    It happened again this morning. :smileymad:


    I have tried a system restore within Windows, an OS recovery, a format and reinstall of Vista Ultimate x86 once, and then did a format and new installation of Ultimate x64. Yet, the problem continues to occur intermittently. I have scanned for viruses, rootkits and other malware using more than one brand of security software. No malware exists.


    The do recall recall that on two occassions this boot issue happened, I noticed a system lockup immediately upon plugging in the AC power supply. I had to force shutdown using the power button both times. When it occurred this morning, it was a cold boot from a powered off state on battery power, so there appears to be no correlation to plugging in the AC adapter. (That appears to be a different bug.)


    I have run basic memory tests (not the extended memory tests), hard disk tests and no problems are detected. There are no SMART errors reported. I am not getting any error messages about the power supply during POST. I have tried changing some of the bios settings and reloading bios default settings. I am running the most current bios version, and the same version my XPS shipped with.


    I also have somewhat frequent hard OS/software lockups using Internet Explorer, FireFox, WMP, Windows Movie Maker and my Nero apps. The mouse cursor will move until I try Ctrl-Alt-Del and that locks up everything solid and I have to use the power button. If I launch a new instance of the offending program with the hung up instance is "not responding", the new instance works fine. If I wait until Windows prompts me to do something, I can kill the app. If I try to kill the app using Task Manager my system locks up completely. Opening Task Manager using Ctrl-Alt-Del under this circumstance also causes a hard lock upLaunching Task Manager by right clicking the task bar does not, but trying to kill the unresponsive app usually does


    Two days ago, I upgraded to IE 8 Beta 2 and the newest FireFox release. Nothing has changed, for better or worse. The system sometimes hangs on shutdown, especially after a program stops responding.


    Having spent $4,000 for Dell's finest, I would expect more stability and less frustration. This is a maddening problem. I find myself wondering if the issue is a problem with the bios loading the raid controller, but find nothing on the web suggesting that to be the case. The fact that it only happens about 1 out of every 8 to 10 days is strange.


    I have searched the web extensively and Dell's support pages and don't find anything relevant to my problem. (The only information I find relates to power problems and hard disk failures.) The Dell KB is basically worthless, as it pulls up irrelevant information even though I specifically identify my laptop.


    Machine Specs:

    XPS M1730

    Core2 Duo T-9500 2.60 GHz

    4 GB System RAM

    Nvidia 8700M GT in SLi

    Dual 320 GB HDD in Raid 0

    Message Edited by BJFox on 10-12-2008 06:54 AM

    7700K @ 5.2GHz ● GTX 1080 SLI ● 17.3" QHD 120Hz G-Sync ● 64GB DDR4-3200 ● 780W AC Adapter

    7700K @ 5.0GHz ● GTX 1080 ● 15.6" FHD 120Hz ● 32GB DDR4-3000 ● 330W AC Adapter

  • Gosh, I don't know what to say other than I empathize and salute your effort to solve the mystery.  When I was running 32-bit Ultimate, I didn't have this problem.  When I ran 64-bit Ultimate, I did not have that problem with my first build, but I had a lingering issue and Dell suggested I (gulp) rebuild the machine.  This "no boot device" problem has surfaced in my attempt to rebuilt my 64-bit installation.  I'm not that far along in my rebuild so I may just start it over again.  (My other issue was an inability to burn Blu-ray disks, but I may live with that rather than return to 32-bit Ultimate.)  I vaguely remember swooping through the BIOS settings on one of my restarts, and I wonder if I stepped on something, but it all looks ok.


    The only thing I have doubts about is the RAID setup.  The array is listed as 0 but so is one of the two disks.  It makes me wonder whether it looks at the disk and not the array.  The part I find frustrating is not being able to get a print screen or print out of the settings for further research.  I've resorted to taking pictures with my iPhone, and that's just not optimal.


    While I would now not dare contact Dell support without creating a  restore point (another story), I don't think using a restore point will be useful here if it is a BIOS issue.  I too have run and endured the comprehensive diagnostics and don't believe this problem is related to any hardware failure as much as a configuration issue.


    Just to commiserate, somehow I managed to spend even more on this than you did.  (It is an embarrassing amount of money which I will not share with anyone.)  MacBook Pro owners in the house find this all very amusing, but I was going for high powered graphics, and in this area, the XPS M1730 currently trumps the MacBook Pro.  I have found 64-bit Ultimate very stable.  I can simultaneously run a lot of apps, including high bandwidth, graphic intensive apps.  It delivers in that area. 


    It is mind blowing that I'm still tinkering with this so much after having it for two months.  I feel like Dell and Microsoft should be sending me weekly paychecks for all of the time I put in.  Aside from my Blu-ray issue, my real jaw dropping, head banging, frustration is with Office 2007.  I'm hoping I can downgrade to 2003, but I've now strayed pretty far from the thread. 


    As I initially noted, this is a nuisance.  I just want the lazy freedom of turning it on and coming back and having it ready for me.  I don't want to wait to press F1 before having it boot.  I know that if I don't resolve this now, my frustration will only increase in the months ahead.


    Anyway, I'm hoping you can isolate the issue that causes things to revert.

  • I'm sorry you spent so much more on your XPS. I could have spent an extra $1000 on a BlueRay burner and Intel Extreme CPU, but did not see the extra expense as being a good value. (I have a BlueRay reader/DVD burner and don't plan on playing or burning any BlueRay discs any time in the near future.)


    Macs are not really any better. I have family and friends that use Macs and they have problems quite often. Every time I take my kids to the Mac store (frequent problems with the iPod Touch), the 'Genius Bar' is full of angry people that are returning Macs or complaining about problems with their other Apple products. I also hate Macs because they are so extremely proprietary, have fewer apps, etc. If I wanted OS X, I would simply run it on my Dell and save my money on overpriced Mac hardware. I also hate the snobby attitude that some (not all) Mac users have. 


    It is a frustrating problem we are having. I did have the same issue with Vista Ultimate x86 (32-bit), which was also configured as Raid 0. x64 is more stable and it recognizes and used the full 4 GB of RAM, whereas x86 will only see and use like 3.5 GB of RAM. I ran Vista Business x64 for more than a year on the laptop this one replaced and never had any stability problems. It also performed better (faster) than the x86 version, saw the full 4 GB of RAM, etc. 


    Raid 0 is the raid configuration that causes two or more drives to function as one large drive. Data is written to both discs simultaneously to provide high performance. There is no mirroring, and if one drive fails all data is lost (as bits of data are written to both drives, it takes the data from both drives to make one complete file).


    Because of my system hangs and application lock-ups, I am suspicious that something is wrong with one of the SO-DIMM modules. But, I did not get any problem reports from memory testing. And, I still think it could be a problem with the raid controller, too.


    I have considered creating an image of my installation on an external hard drive and then reconfiguring the bios to run in non-raid, then reinstalling from the image to see if the problems go away. But, I need to buy a 750 GB or 1 TB drive to do that. I also am not thrilled about the performance loss that will occur with low (5400?) RPM drives running in non-raid mode, so I have not been all that enthusiastic about running out to buy an external drive.


    I did have a hidden partition that Dell used for restoration utilities. In an effort to try to resolve this problem, I purchased Acronis Disk Director Suite, deleted that hidden partition, then expanded the existing partitions to take up the free space. Doing so had no effect on the problem.


    I cringe at the thought of contact Dell directly for support because I end up with reps from India that are very difficult to understand and not very helpful. When I did my first clean reinstall of the OS, I could not get the Creative Audigy software to install. It would quit with an error message that it could not find the correct drivers, even though I was using the drivers provided by Dell. I had a similar issue with the Dell Dock and the rep from India sent me a link to the StarDock web page and I downloaded it there. But, it has been a month since I spoke to them about the Creative Audigy problem. They were going to research it and get back to me. They haven't.


    All of the reviews I found on the XPS M1730 were highly favorable and I made this purchase thinking I was getting the best gaming machine. I now wish I had gone with an Alienware or Sager. I am satisfied with the very high quality of the case, display and lighting. Not satisfied with the bugs, or the foreign support reps. 


    A great example of what occurs all the time happened when I got the email telling me someone replied to this post. If I launch the link to view the message from Outlook, IE stops responding. This occurs even if I open IE first. The link tries to open in a new tab and IE just locks up. So, I used FireFox and did not have that problem. As I was using FireFox and typing my response (this post), my system locked up and I had to hold down the power button and force a reboot. My hard drive light flickers almost continuously unless my laptop is idle and not in use.


    Message Edited by BJFox on 10-12-2008 09:51 PM

    7700K @ 5.2GHz ● GTX 1080 SLI ● 17.3" QHD 120Hz G-Sync ● 64GB DDR4-3200 ● 780W AC Adapter

    7700K @ 5.0GHz ● GTX 1080 ● 15.6" FHD 120Hz ● 32GB DDR4-3000 ● 330W AC Adapter

  • I've been rebuilding my 64-bit installation.  (I had 32-bit Ultimate and have gone to 64-bit; but to activate 64-bit from a fresh install, I need to install it twice: once without the license, and again from within Vista as an upgrade.)  The re-upgrade doesn't disturb applications, drivers, or data. but it did fix the no boot device issue.  Admittedly, this is not a quick or surgical fix, but the upgrade requires minimal intervention and can just be left running.


  • By going through the installation routine you have outlined, you are essentially replicating what I have already done far more numerous times to correct the problem.


    Having done so many reinstallations and BCD repairs already, I am skeptical this problem is permanently fixed for you. Give it a week or two and if the problem does not resurface let me know. Mine stays fixed anywhere from 2 days to a week, then the problem returns. (My problem has been fixed twice in the last 5 days.)


    I am surprised neither of us has received a response from Dell. Either they do not read this forum, don't care or don't have a clue what the problem is.



    Message Edited by BJFox on 10-14-2008 08:37 PM

    7700K @ 5.2GHz ● GTX 1080 SLI ● 17.3" QHD 120Hz G-Sync ● 64GB DDR4-3200 ● 780W AC Adapter

    7700K @ 5.0GHz ● GTX 1080 ● 15.6" FHD 120Hz ● 32GB DDR4-3000 ● 330W AC Adapter

  • The solution worked, but I've now done a complete rebuild including a format for Media Direct.  I've taken backups as I've gone along, but ... today it returned.  Sadly, you are correct. 


    What puzzles me is that I had nearly a month without this problem.


    Now that I've exhausted my possibilities (having the problem temporarily go away was just a happy coincidence) I'm going to have a chat session with Dell about this.  If they tell me to rebuild, I'll just ask to escalate to Devcon 4.

  • In my troubleshooting, I eliminated Media Direct and the special partitions complete from my system and that had no effect on the problem.


    I have another issue that I may not have mentioned that I am wondering if you have experienced, too. If I am running on battery power and plug in the AC adapter, that sometimes causes my system to freeze and the only solution is to shut down by holding down the power buttion. 


    If Dell has a solution for our boot problem, please share it with me and others on this forum. After they fix it for you, please ask them to contact me about fixing this problem. Hopefully, they can put something on their Knowledge Base, or send out a technical bulletin to all registered XPS M1730 owners that may have been affected by this issue.

    7700K @ 5.2GHz ● GTX 1080 SLI ● 17.3" QHD 120Hz G-Sync ● 64GB DDR4-3200 ● 780W AC Adapter

    7700K @ 5.0GHz ● GTX 1080 ● 15.6" FHD 120Hz ● 32GB DDR4-3000 ● 330W AC Adapter

  • In my chat session, the Dell support technician made a lot of inquiries and then told me that Microsoft would be issuing patches/updates to remedy the situation in the weeks ahead (four to eight weeks?). 


    I don't beleive he was just blameshifting or trying to skirt the issue.  The issues does not pertain to specific drives. Because Vista's drivers have not been fully updated, it may have problems finding the hard drive when the drive is configured for RAID0.


    I can live with this for a few months.  I don't think the nuisance is substantial enough to make it worthwhile to go back to 32-bit Ultimate.  In the meantime, all I want for Christmas is updated drivers.  ;^)

  • I am not optimistic that new drivers from Microsoft will fix this problem. I guess we will have to wait and see. With SP1 already released, Vista is really not a fledgling operating system. I seriously doubt Vista drivers will fix the problem because it appears to occur before Vista loads. It appears to be a BIOS firmware problem to me.


    I also had a chat session. After hearing all I had done on my own, the rep agreed I had already tried everything he could recommend. The chat support rep ended up doing more research and calling me about 20 minutes later.


    Go into the BIOS and reset to default settings. Switch the SATA boot parameters from Autodetect SATA / AHCI to RAID only. (You will find that option in the middle.) You will have to first disable the flash cache module in the option tree below the SATA operations parameters if it has been enabled. Save the settings upon exit and reboot.


    You should be able to ignore the ominous warning about being unable to start your operating system if your system was already configured for RAID 0. (From you previous posting, it appears that is how yours is configured.) I had no issues and believe the warning would only apply if you were changing from a parallel drive configuration to striped array.


    I do not know if this tweak has accomplished anything yet. Only time will tell if the problem will return. It should not take more than a few days to find out. (I had already repaired the BCD and was not having the problem when I called.) If the BIOS autodetection feature is buggy and not consistently working correctly, this may be a valid solution.


    If you have not already done so, I recommend that you download and install EasyBCD from NeoSmart Techonologies. This will allow you to repair the BCD (master boot record) within Windows. This will fix the issue on a temporary basis if the BIOS setting change outlined above does not resolve the problem for both of us.


    I'm crossing my fingers. I was told the next step to try to solve the problem would be a "restore" operation, and I am 100% confident that will not solve anything because I have already tried that.


    Hope this solution ends up working for both of us.


    7700K @ 5.2GHz ● GTX 1080 SLI ● 17.3" QHD 120Hz G-Sync ● 64GB DDR4-3200 ● 780W AC Adapter

    7700K @ 5.0GHz ● GTX 1080 ● 15.6" FHD 120Hz ● 32GB DDR4-3000 ● 330W AC Adapter

  • I hear what you're saying.  It seems like it would be BIOS related too except that reinstalling it doesn't seem to make any difference.  I saw the other RAID autodetection option but was too chicken to try it.  Thanks for the info and please let me know if your remedy lasts more than a week.  :^)

  • I got a call from Dell this morning clarifying what the tech support person told me yesterday.  The update will come from Dell and not Microsoft.  It will be posted on the drivers page for our machines, and it will need to be copied onto a CD or memorty stick so that it can be flashed.


    I think there is a way you can set yourself up to be notified when new drivers are available for your system.

  • Ah! That sounds much more accurate... that Dell, not Microsoft, would be posting some updates. Hopefully, an update to the BIOS or whatever might be causing this problem will be provided. It would be nice if they would open up some frequency and voltage settings to allow modest overclocking. The XPS is supposed to be Dell's gaming flagship, but nothing is open to modification.


    So far, so good on the problem in question. But, only time will tell if the BIOS setting changes they had me make are truly the ticket. I'll know soon enough and will post the results.


    I am already set up to receive email notifications on updates. So far, all of the update notices I have received have absolutely nothing to do with my XPS, even though I signed up to receive only XPS 1730 update notices. 

    7700K @ 5.2GHz ● GTX 1080 SLI ● 17.3" QHD 120Hz G-Sync ● 64GB DDR4-3200 ● 780W AC Adapter

    7700K @ 5.0GHz ● GTX 1080 ● 15.6" FHD 120Hz ● 32GB DDR4-3000 ● 330W AC Adapter

  • I understand and I told the first agent that I thought it was a low level issue; but he seemed pretty adament.  I still find it puzzling that it would be so long before this problem arose on my system.  It makes me wonder whether there is some other conflict, perhaps due to some stealth Vista update installation.


    After painstakingly checking the drivers on Dell's support page and the CD provided with my machine, driver detective suggests I still am not using the latesst drivers and suggests 13 updates.  (It's curious to me that neither the the site or the CD are inclusive.)  I'm now pretty content with my most recent rebuild and feel a little more comfortable with a series of disk images and restore points.  I still can't help wonder whether or not these other drivers might not be more optimal.  I'm going to trust that Dell is testing the interoperability of various drivers before pushing them out to their support site.