XPS M1530 BIOS Upgrade A08 -> A09 Issue - General Hardware - Laptop - Dell Community

XPS M1530 BIOS Upgrade A08 -> A09 Issue


Laptop computer Forums (Audio, General Hardware, Video)

XPS M1530 BIOS Upgrade A08 -> A09 Issue

  • All -


    I've downloaded the 1530_A09.exe upgrade file, but whenever I attempt to run it, I just see a Command Prompt window flash briefly, then disappear.


    Not sure if it is blocked by installed Firewall or Anti-Virus/Anti-Spyware software, but same issue when these are disabled.


    Nothing of interest in the Event Log.


    Instructions seem very straightforward: Download -> Save -> Double-click -> Follow Prompts -> Auto Reboot


    Nothing doing!


    TIA for any insights.


    - Ray



    System Info:


    Dell XPS M1530

    Intel Core 2 Duo Processor T9300 (2.5GHz/800Mhz FSB, 6MB Cache)

    4GB Shared Dual Channel DDR2 SDRAM at 667MHz (2 Dimms)

    256MB NVIDIA GeForce 8600M GT

    Genuine Windows® Vista Ultimate Edition SP1

    120GB 7200rpm SATA Hard Drive

    BIOS Version: A08

  • I have exactly the same problem. Anyone able to help?
  • Consider yourself lucky!

    I ran the BIOS update at 10:30 last night right before bed. All seemed to be going smoothly, white Dell screen with "BIOS update" utility running; then a nasty shut down, followed by the inability to restart. The BIOS seems to be installed (says version A09 when booting), but I get a blue screen of death with a "critical process/thread terminated" message. Dell states we might be able to fix once I get my OS disc, but likely will need to do a factory reset. ICK!

    This is with Windows Vista, incidentally. I'm peeved.

    Beware! This is a new laptop with nothing screwy installed on it-- mostly just windows apps, etc. Used to run great.

  • ARKed and responders - glad I found your posts.  I had the same problem with installing the file.  After what I have been reading, I'm glad I haven't tried to install it again.  I've posted my problem to this page, but no one is answering.  I also posted it on the Virus page since my TREND tried to block it.  No one answered that post either.  I've had excellent help from the DELL liason people in the past with a variety of problems.  I'm wondering if this isn't a new issue.  I'm not sure if this problem is one that Dell Tech support will help with without charging.  I'll post anything I learn regarding the issue.



    Laptop 1530 XPS - Vista Home Premium

    Laptop Inspiron 8600 - XP Pro

    Desktop Gateway XP Home (and a new Dell 420 that should be here by Wednesday)



  • Hi, All.


    I came to the party late, but I am working this issue. I will update when I know something.



  • Mine seems to be same thing as with Obenjammin.  Did you get yours fixed?  This really stinks worked perfect before the "upgrade"!!!!!


    XPS1530 Vista Home Premium SP1 upgraded from A08 to A09.  Updated seemed to go ok, but on later boot, fails.  Gets by the Dell screen and just past the windows green bars, but then immediately fails and does memory dump.  Windows Startup Repair launches automatically.  No luck with fixing (only thing I saw is try is a system restore).  Still won't boot.  No hardware or software changes other than BIOS. 


    *** STOP: 0x000000F4 (0x0000003, 0x0904d3320, 0x904d346C, 0x81e84400)

  • Hi pempey,

    Nope. Had to do a factory image restore. I'm not sure if this is ultimately a Windows Vista issue or a Dell issue (or both), but it stinks.


  • Thanks for responding.  I gave up on mine too.  Dell didn't think it was directly related to bios as could get beyond Dell screen and windows green bars before doing a memory dump reporting a 0x000000f4 error.  Couldn't even boot to safe mode.  System restore failed.  chkdsk /f reported no errors, but sfc /scannow reported a bunch of corrupt files that it could not repair.  Did a full Dell diagnostic on hard drive and found not errors at all. Who knows.


    Gave up.  Just pulled my data off drive with an external enclosure and going to do a CLEAN install of vista.  What a waist of several hours.