Novatel EU870D - General Hardware - Laptop - Dell Community

Novatel EU870D


Laptop computer Forums (Audio, General Hardware, Video)

Novatel EU870D

  • Hey guys, I need some serious help here.


    I have DELL XPS M1330, 4GB RAM, VISTA x64 ULTIMATE, A09 Rev. Bios


    I recently bought a Novatel EU870D mobile broadband modem (unlocked), and I am trying to install the drivers on the laptop.


    I haven't yet bought a HSDPA subscription nor I have a data SIM, because i wanted to be sure that this thing really works.

    I've already physically installed it in the machine, and enabled it the bios.

    The drivers that i have tried are from novatel and the Dell generic drivers for 5520 but still no go, which both claim vista x64 support, but the description on my device manager remains Data Interface (4 times). Any ideas?

    Plz help


    P.S. Is it possible that i have to install also the SIM card so that the modem operates normally and have it's drivers installed? 

  • You mentioned unlocked,did you by chance buy this from some place other than dell or the manufacturer?...



    The reason i asked is,a friend of mine bought a so called unlocked card and the minute they started to use it,it shut down.

    E1705 T7400 2.16Ghz / Vista Home Premium SP2 / 17" LG WUXGA 1920 X 1200 / 4GB 667Mhz Geil Ram w/Heatspreaders / Western Digital Scorpio Black 500GB 7200RPM / 500GB 7200RPM My Book / Nvidia Geforce Go 7900GS 256MB / Toshiba DVD/CD+/-RW DL / Intel 4965 A/B/G/N / 355 Bluetooth 2.0+EDR / Pinnacle Pro HDTV USB Tuner / Pinnacle Ultimate HDTV USB Tuner / Sound Blaster Audigy Advanced MB / Sound Blaster X-Fi Extreme Audio Notebook / Logitech G51 Surround Sound Speakers / 2-NB-MA01 Notebook Coolers / 3D Mark06 5446 / Driver v.174.31 /

    XPS M1730 Saphire Blue X9000 @ 3.2 / Vista Home Premium SP2 / 17" WUXGA 1920 x 1200 / Matshita BD\DVD Combo / 8GB 800Mhz Geil RAM / 500GB>200GB 7200RPM / 9800M GTX SLI / AGEIA PhysX Accelerator / Intel 4965 / 355 Bluetooth / 5700 Mobile Broadband / 3D Mark06 16250 /Driver 275.50 beta

    XPS Gen 4 Desktop>being rebuilt

  • I bought it from an E-bay. The card itself appears impecable.


    I haven't really used it yet, because the drivers haven't installed so I don't think that it shut down. But the BIOS informs me that there is a cellular device installed.


    It all comes down if a cellular device needs a SIM card so that it can be detected by the OS and have it's drivers installed.


    Any ideas? 

  • There is EU870D GENERIC version 7.2M upgraded selling on Ebay by Bear99bear.  100% working perfect!


    **Remember to install the mobilink s/w (for GENERIC) instead of the DELL s/w.