Error Message (!) Says that the model number for the primary battery can not be determined - General Hardware - Laptop - Dell Community

Error Message (!) Says that the model number for the primary battery can not be determined


Laptop computer Forums (Audio, General Hardware, Video)

Error Message (!) Says that the model number for the primary battery can not be determined

  • cont.,


    This will prevent the battery from charging. Please insert a Dell battery for best system operation.


    What does this mean? I figure I need a new battery but why isn't this battery being recognized as a Dell?

    It's the orginial battery that came inside the laptop....(Inspiron 1501).


    Any help would be great!



  • My original battery on my Dell Insp 1501 just started giving me the same error today, although it has been a great battery up to this point - usually lasts a good 4hr on full charge.

    I get an error on boot that says I have to hit F2 twice to goto setup, or f12 to  choose boot manager...only problem is there is nothing in the  bios set that would help this, and  hitting F12 doesn't do anything.


     If I leave the battery out on boot, the laptop boots normally with no errors.


    I'm thinking this is a battery manufacture problem since my battery is just over a year old (just out of warrantee that is).


    Maybe if enough of us complain they will replace for free? 

  • Mine has been doing the same thing, with the same result, and, not coincidently, out of warranty.   It's called "planned obsolesence" and is done on purpose.  Mine never did last as long as yours on a full charge though.  I've been lucky to get 1.5 hours in before having to plug in

  • Hello

    I am having the same problem with my dell vostro 1000.

    The Battery Won't Charge. It the battery supplied with the laptop.

    Does any one knows how solve this problem???

    This official Forum should have some technician's form dell To answer such questions.

    Users can't answer each other.

    User can share problems , so you won't  feel lonely with your problem Big Smile.

    I hope Some Specialist Answers us.

    Thank You

  • Great! I'm having the same problem with my Inspiron 1501 (recently out of warranty).  Obviously, no technicians have posted and solutions, and no effort has been made to fix the problem before the computer leaves the factory.

  • Hi, here a Dell Latitude D630 with very similar problems. It seems it is a general glitch in many Dell models. In my case in the BIOS the adapter and battery are recognised and battery is displayed as charging. However this is not the case. Green light indicating battery charging is not on when the adapter is connected. I swapped different power adapters and batteries, because in the office we have 4 Dell Latitude, to no avail. I get with different batteries the whole range of messages, from the classic : "Your battery is charging but is at the end of its life" to :"battery not installed" and amber light flashing. All batteries and laptop were bought less than two years ago and I am inclined to think this is a general mainboard problem. Good Luck!

  • Hello everyone,

    same issues.  I got a dell inspiron 1545 and 3 months out of warranty. I didn't do anything with they battery, it's still the original one from Dell and or course it started displaying the message  that the maine battery number can not be determined, which will prevent it from charging.  I am so disappointed w/ Dell lately, I regret the purchases that I made with them in the last year.  What a waste of money having to buy a new laptor/pc every year and 3 months.   

  • Has anyone found an answer to this?  I'm having the same trouble with my Vostro 1000 and would love a workaround to get battery usage above 30 seconds.  Though the battery did only last 30 minutes when it was brand new anyway! :(

  • has anyone figured this out? Wth my battery is only 15 months old and it started doing this today....