Latitude D830 - WiFi unusable - General Hardware - Laptop - Dell Community

Latitude D830 - WiFi unusable


Laptop computer Forums (Audio, General Hardware, Video)

Latitude D830 - WiFi unusable

  • Hello, My Wifi connection keeps dropping, is anyone else experiencing the same problem? There is no real pattern, sometimes it drops straight away and other times it can take 5 or 10 mins. This is specific to the laptop and is not an issue for 2 other PCs or my Axim connecting to the same router. In fact the Wifi light goes off on the latitude indicating the problem rests with the laptop itself. This can only be resolved with a reboot and then it just happens again. Thanks, Gegerty.
  • In Control Panel>System>HArdware Manager right click on your wireless network card and click properties.Got to the Power Management tab and check to see if the little box "allow windows to turn this device off to save power" is checked or not.It should not be as this will allow windows to automatically turn of your wireless card.Keep me posted
  • Hi, Thanks for the reply. I had tried absoultely every setting including this. Actually when the problem occurs you cannot get into any properties, either via control panel or the system tray. However, Dell support have solved this problem for me. I had to open up the laptop, remove the wifi card and slot it back in. It seems it was simply not held in place properly.
  • Glad I found this thread. I've been wrestling with the D830 wifi radio dropping for a while - as a matter of fact, it just happened again, but I'm plugged into the wired network. Also - does this fix the hardware switch on the left side of the machine? I can use that to turn Bluetooth on/off, but it doesn't seem to control wifi(?)

    Jim Gross | Solutions Advisor, Telligent
     | Facebook | LinkedIn | FriendFeed

  • I found some documentation that suggested taking out the internal wifi card and re-inserting it, but after trying that, the radio still drops occasionally and restarting the machine seems to be the only way to fix it. The process for removing and reseating the wifi card is pretty tricky, btw, and since it hasn't improved performance in this case it's probably not worth the risk and I won't post the instructions here.

    The hardwire switch on the side appears to be working correctly. When the wifi radio is on and functioning, I can turn it off and back on with the switch and after the wifi radio drops unexpectedly, the hardwire switch will still turn Bluetooth on/off.

    Anyone else had any luck with this issue?

    Jim Gross | Solutions Advisor, Telligent
     | Facebook | LinkedIn | FriendFeed

  • I have some questions on this issue.  If anyone has this problem with the D830 Wifi this would help to troubleshoot the problem.

    What Operating System (XP, Vista, etc)?

    What BIOS are you running on the D830?

    Which wireless card is inside the laptop, is it an Intel or Dell brand? Are you using the current drivers for whichever card you are using?  If it's an Intel card have you tried drivers directly from Intel's website?

    What brand/speed of wireless router are you connecting to?

  • Hello,

    I have the same problem (many Wi-Fi disconnections, low-performances Wi-Fi) for many months.

    Here are my details (latest version from DELL's website):

    • BIOS: A14,
    • OS: Microsoft Windows Vista Professional SP1,
    • Wireless card: Intel Wireless Wi-Fi Link 4965AGN (date: 28/08/2008; version:

    I found a quite similar problem described there : <>.

    It is very frustating to have a wireless laptop which works well only when wired...


  • Do you have a Linksys router?  I found this in the release notes of the latest Intel driver version 12.4.

    After the association flow completes, the adapter stays awake (as in CAM mode) for 10 seconds, and then acts according to the PowerIndex (PI) regkey. PI should not be change during this period. The association timeout is 10 seconds. Using the Linksys access point, association occurs every 60 seconds, resulting in deauthentication and disconnection from the Linksys access point.

  • Thanks for the answer, but I have this problem with the NETGEAR WNR2000 router (802.11 N), the D-Link DSL-G684T modem-router (802.11 G), and other (modem/)routers.

    The problem does not seem to appear with the (Vodafone / SFR / N9uf Tel9com) N9uf Box 4 (802.11 G, Broadcom BCM94318 chip).

    Any other idea?


  • I have exatly the same problem. Seems if i use this two command the wireless start again work for 5/10 min. After that I have to do the same...

    ipconfig /renew

    ipconfig /release

    Any other idea???