Inspiron 640m Problem - General Hardware - Laptop - Dell Community

Inspiron 640m Problem


Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 640m Problem

  • Ok, so I get my laptop last week, and decided to format it and install Windows XP Professional on it. I finished installing all the components I wanted, then thought I might as well install the Dell Media Direct software.
    I looked on the Resource and Drivers disk, and found "Dell MediaDirect Repair Utility". I looked at the .pdf in it and it said how to reinstall it. So I followed it's instructions.
    1. Boot from CD
    2. Press "Q" and type "cd \MD2"
    3. Type "Repair".
    After doing that, I wait a while, and it says "Done", and so I reboot the laptop.

    Now the laptop keeps rebooting after the black Windows XP screen *I can't get on Windows XP*. I can't get into Windows itself using Safemode, last point it was working, or continue it normally.

    I've looked online, and it says that it is a STOP error or something. But all the diagnostic tools on the actual laptop (from holding Fn + Power key, Hardware diagnostic) all pass.

    Trying to re-format it again doesn't work, as it says that there is a software error and that windows has to stop. So... I reckon it's a BIOS error, but seriously have no clue what to do.

    Message Edited by Rkhl on 10-28-2006 02:56 PM

  • Rkhl,
    Some details are missing from your post, but one of my first questions would be what partition modifications may you have made during the XP reinstall?  Did you reinstall over/into the same partition as the original???
    Sounds like the answer is no, but....
  • Well, as usual, I quick-formatted C: (Where windows was installed) then installed Windows XP Prof onto the same drive.

    Everything was fine until I tried to install the Dell Direct Media.

    I have been suggested this:
    "How to recover from a corrupted registry that prevents Windows XP from starting" found at:;en-us;307545 , but I don't know whether to try it or not. Might go wrong :-S

    Message Edited by Rkhl on 10-29-2006 06:27 AM

    Dell has also contacted me and told me to try a Dell System Restore by holding "ctrl + F11" at startup to begin the process. It doesn't work, but it keeps going to it everytime I boot up the computer now... Is that normal?

    Message Edited by Rkhl on 10-29-2006 06:28 AM

  • Sounds like your boot code is not quite right rather than your BIOS....
    You may want to consider writing the Microsoft boot code to your hard drive and see what that may do for you in terms of at least getting you back to where you can get to Windows.
    This would entail using the Windows Install disk and accessing the Recovery Console.  Command would be fixmbr...
  • so as to install the dell media direct you first need to leave 2 gb size as unused space and then install win xp professional as dell media direct would require that space and hope it should work perfectly well as it needs a different space other that your c drive in which windows is installed
  • Well at the moment, the problem has been narrowed down to a STOP error.

    This is because I keep getting this message when I do different things:
    "A Problem has been detected and Windows has been shut down to prevent damage to your computer.
    Plug and Play detected an error most likely caused by a faulty driver.
    If this is the first time you've seen this Stop error screen restart this computer. If this screen appears again, follow these steps:
    Check to make sure any new hardware or software is properly installed. If this is a new installation, ask your hardware or software manufacturer for any Windows Update you might need.
    If problem continue, disable or remove any newly installed hardware or software. Disable BIOS memory options such as caching or shadowing. If you need to use Safe Mode to remove or disable components, restart your computer, press F8 to select Advanced Startup Options, and then select Safe Mode.
    Technical Information:
    *** STOP: 0x000000CA (0x00000001, 0x85E879B0, 0x85f10498, 0x00000000)"

    And what I have found out about the 0x000000CA error message is that it's "Inserting the Same SmartMedia Adapters Causes a "Stop 0x000000CA" Error Message" found at
    However, I have nothing in my Smart Card reader, nor do I have 2 of them on the laptop.

    Also, I can't get onto the Windows Recovery as it requires me to get to the setup screen. Where I get the STOP message right before the window is supposed to appear. This is the same as Dell Recovery Environment, which won't stop cycling now, so I can't get onto the safemode option screen anymore...

    Well, the Direct Media had plenty of space on C: (60gb of free space left) but I had no clue about it needing another drive... I only had C: and those partitioned spaces which are used by Dell Recovery.

    Message Edited by Rkhl on 10-30-2006 01:42 AM

  • Can you confirm that this 'STOP' error also happens when you try to boot using the XP reinstall DVD/CD???
  • Yes, I get the same message when:
    1. Windows XP disk is in the drive, and then booted of it. (It begins to load the files, and then before the Welcome to Setup screen, I get the stop message).
    2. Dell Recovery Environment. When it reaches 100% and says Loading, the screen turns blue, and the identical stop message appears.

    And I'm not sure, but when it went to the Loading Windows XP black screen, it crashed halfway to a blue screen (for about .5 seconds) before it reboots and the cycle repeats. However, I can't get to that part again as Dell Recovery Environment keeps loading.
  • Sounds like your Dell Recovery partition has been set as your 'active' partition and is 'stuck' there for some reason [boot code hosed???].
    As to your STOP during boot with DVD has me stumped.  Don't know if you have access to a DOS-boot CD of some kind, or can/want to make one...  If you did, you could put something like ptedit on it to look at your partition table to see what's going on.
    If you got a 'hang' with a DOS-boot CD, then I'd say it's time to get your laptop back to Dell and see what they can do....
  • Dell Hardware Support says that they can't help me, but to contact Dell Software Support which will cost me. However, for Dell Software Support to help me, there's a snag:
    "This service helps customers resolve one-off standard error message occurrences arising from the use of a single, standalone Dell computer system with standard Dell factory-installed operating system and/or application software."
    From my knowledge, as I formatted the computer, and tried to install Dell software on it, it's no longer a "standard Dell factory-installed operating system and/or application software."

    Seems like I buggered my computer.

    The thing is, as I cannot unplug any hardware (reason being I have no expertise with laptops). I cannot try and unplug the SmartMedia adapter on the side of the laptop, which apparently is causing this problem.
    The STOP error is overriding everything I do, so when something reaches 100% (whether Windows loading, Dell Recovery Environment, Welcome to setup), the STOP error stops everything and says the computer has to shut down.

    Message Edited by Rkhl on 10-30-2006 12:21 PM

  • You're not alone as I was able to find a post in one of the Notebook forums describing same issue.  STOP error after repairing MediaDirect...
    Unfortunately, there were no solutions.
    I still think a DOS boot disk may be in order.  Here is one site for you to look over....
    One of the files I'd put on it is ptedit from Symantec
    That DOS application will let you look at your partition table.
    Just a follow-up question.... Have you done anything wrt your BIOS in terms of changes/modifications/updates?
  • Well the only BIOS settings that I change is changing the boot-up sequence (moving CD-ROM above IDE/SATA). I never ever flash my BIOS settings, nor update them since I would probably break the computer doing that.

    At most I do is format a hard-drive to reinstall windows on it, but that is relatively safe compared to flashing/updating BIOS settings.

    EDIT: Thought I might add in.
    When I was formatting C:, there were 4 partitioned spaces on the HDD. 2 are like 100mb big and 1 was much better, over 1GB. I just formatted the C: was about 68GB big (although it's a 80GB HDD). I completely ignored the rest, since they weren't drives.

    Message Edited by Rkhl on 10-31-2006 08:26 AM

    EDIT2: Would replacing the HDD work? Cause if it does, I could probably buy a new HDD and replace it. (Presuming you just you unscrew the Strike Zone panel, unplug the HDD and plop the new one in) Can't find an Inspiron 640m HDD on dell though... -- this guy got a replacement HDD from dell. No clue if it works though.

    Message Edited by Rkhl on 10-31-2006 08:34 AM

  • Rkhl wrote:

    EDIT: Thought I might add in.
    When I was formatting C:, there were 4 partitioned spaces on the HDD. 2 are like 100mb big and 1 was much better, over 1GB. I just formatted the C: was about 68GB big (although it's a 80GB HDD). I completely ignored the rest, since they weren't drives.


    I can only assume the 'formatting' was done as one of the steps during the Windows Reinstall and using a Windows DVD/CD....
    btw When C was reporting ~68GB that would be correct since C resides on just a portion [partition] of the hard drive with the rest of the hard drive space being used by other partitions or 'reserved space' for MediaDirect.
    AFAIK just about any 'notebook' hard drive will fit/function in Dell computers.  Would be a 2.5" SATA drive.  Question beyond size/cache would be speed 5400/7200.  But I have my doubts that you have a hardware problem, esp since someone else has also reported same issue.
  • Yeah, it looks like a hardware problem to me as well.

    Thing is, Hardware support sent me to software support (which requires a fee). However, I've sent an email back, with the links to the other people that had the identical problem as me (where he got a replacement HDD).

    Well, if I get my own HDD, I will no longer had the dell stuff on the partitioned space. So I presume that i'll lose the startup dell screen, and other stuff, unless I get one from dell.

    Also, I don't really want to buy a ~£100 HDD if this won't work. The only thing i've found so far is that the person who had the identical problem as me got a replacement HDD and hasn't reported back yet, suggesting it might work.

    Message Edited by Rkhl on 10-31-2006 11:40 AM

  • my problem is i have pationed and formated my harddisk as well as i have updated my from a04 to a05. I don't have the reinstallation cd of mediadirect ???? is there any link to download the media direct for the a05 bios ??? i have tried the repair utility of a05 but it didn't work.
    please reply as soon as possible.