HELP!! BLACK SCREEN -- DELL LOGO FLASHES, THEN BLACK

Laptop

Laptop
Laptop computer Hardware and Software discussion

HELP!! BLACK SCREEN -- DELL LOGO FLASHES, THEN BLACK

  • INSPIRION 8600 ON ALL THE TIME. SUDDENLY BLACK SCREEN. UNDO EVERYTHING THEN TURN ON AGAIN.  DELL LOGO FLASHES WITH PINK HUE, THEN BLACK SCREEN, WINDOWS XP LOGO FLASHES WITH PINK HUE, THEN BLACK SCREEN PERMANENTLY.  ALL SOUNDS NORMAL AS USUAL.  BEST BUY GEEKS HELPLESS.  DO I HAVE TO DUMP LAPTOP FOR LACK OF SCREEN?
  • Sounds to me like your motherboard may be giving up the ghost. Could also be the video card. Reguardless of what color the Dell Logo screen is as soon as it comes up try pushing the F10 key ,I think it's the same for all,if the computer boots into a screen that gives you several options to boot into. Use your arrow keys to highlight "last known good that worked" or words that affect. Then depress enter and see if that will boot into display as normal. Hope this helps,good luck.
  • How did you get this fixed? I have the same problem!
    Thanks D
  • OneDesertDog,
    It's been awhile but as I remember I was online with the tech on "chat" . After I tried several of the things she wanted me to do she determined that that the motherboard was bad. Because I was still under warrenty she ordered a board to be sent out and installed by a tech. The young man was ok but he had never replaced a board before. I have on several older laptop computers. Once he saw I knew more than he did about laptops he let me direct him on what to do. The directions that Dell sent with the board were for desktops,didn't help very much. But its a fairly easy thing to find directions on the web for this. After installation the system works fine and seems to be a little better than before. If your not very good with taking something like this completely apart,take it to someone you know knows what they are doing. Laptops are very very easy to kill when taking them apart. Hope this helps.
  • OneDesertDog:
     
    I haven't solved problem yet but 2 responses seem to feel it's the mother board.  Will take for repair and let you all know if that was the problem.  Thanks for help and suggestions.