Cannot Enter BIOS, F2 key does not work? - General Hardware - Laptop - Dell Community

Cannot Enter BIOS, F2 key does not work?


Laptop computer Forums (Audio, General Hardware, Video)

Cannot Enter BIOS, F2 key does not work?

  • I try to enter bios at the Boot up screen where it says press F2 for system utilities.  I press F2 so many times and have tried constantly but I cannot enter the BIOS.  I need to change the boot up device order to reformat computer.  Is there any other way to do this without entering the BIOS and does this mean my F2 key doesn't work?  Any help would be greatly appreciated.
  • try F12 for the one-off boot menu.
    btw what model laptop is it?
  • it is an inspiron 5100, and i have already tried the f12 key to no avail. It seems like any button i press on the boot up screen does not work. even pressing esc to get the dell screen to go away doesn't even work. i have also tried pressing Fn+F1 as i have read in another thread that on some older bios versions needed this key stroke to enter them but this didn't even work. seems like that i am messed up.
  • I suspect that you have an old Phoenix bios version installed.
    if so suggest you update your bios to A22 initially & the problem should magically disappear.
  • Remove the Harddrive and CDROM and see if it will boot just from a Floppy Disk in a floppy drive . If it will not, disconnect the CMOS battery overnight  and see if it will boot from the floppy then.  Youwill have to check with someone who has worked on the 5100 and get them to tell you how. Some models have a small white plug on the motherboard with a 2 wire connectoer, but others connect through the Touchpad connector. That should reset your BIOS to default with the floppy drive first

    This following was not on a 5100, but rather on 2  Inspiron 8000 M'boards. The BIOS would boot to the setup screens and those showed the CDROM, Floppy and Harddrive as present and recognized, BUT it would also report no Bootable Devices Detected and that is as far as it would go. A good BIOS chip was substituted for each of them in the socket and everything became normal. The bum chips both had A02 version(early) on them. I then installed the good chip in the socket just far enough to boot up the floppy drive and a I8000A23 Flash Diskette to an A: prompt, typed in the Flash command and entered it, and got to the screen that requires a "Y" to continue. I popped out the good chip with a pair of wooden toothpicks(no metal) put in a bad chip, and hit Y. A normal flash to A23 resulted using that procedure with both chips., and all the devices became bootable.

    I think you can see the problem is how to get the Floppy to boot up in order to flash the BIOS. Right now you have a Catch 22 situation. You need to use it to flash the BIOS to correct the problem thatis preventing it from booting so you can flash the BIOS!! BROTHER!!

  • thanks everyone, i found the answer with more searching of the dell community forum. as i said before, the computer was not able to boot up from cd-rom and i do not have a floppy disk drive. so what i had to do was take out the hdd and restart the computer with it out, thus forcing the computer to boot from the cd-rom. i was able to update bios with the bootable cd-rom containing the bios update that i made prior to doing all this. viola! makes you feel good to learn something new.
  • Same principal as the floppy, but using a Bootable CDROM. It is good you worked it out. 
  • I have the exact same problem, but am not quite as confidant as you.   I have downloaded the BIOS upgrade but what I wanted to know is what else you put on the bootable disc.  Be as specific as you can, please as, I'm afraid I'll be stuck with this unusable computer.  Thanks in advance.