Enabling Mic Monitoring

Laptop

Laptop
Laptop computer Hardware and Software discussion

Enabling Mic Monitoring

  • A number of members have reported on their attempts to find the registry entry 'DisableMicFromPlayback'. Their purpose in seeking this line is to change its value to allow them to monitor the microphone's input thru headphones.


    Users of Inspiron 1100, 5150, 5160, 8500, 8600, 9100 and 500m found the entry. (8600 users might try setting 'EnablePOpBypass' to 0.)
    Users of Inspiron 600m, 4150 and 8100 did not find the line.
    Please post any additional or different findings. I'd like for us to compile a complete list.


    These instructions were originally posted in a different form first by dilleyo and then jk79:


    1. Go to Start menu and click on Run. Type in the word regedit and click OK to open the Registry.


    2. At the top of the list, highlight My Computer.


    3. Under the Edit menu, select Find.


    4. Type in DisableMicFromPlayback and click find next.


    5. Highlight DisableMicFromPlayback. Right click on it and select Modify.


    6. Highlight 01 and change to 00. Click OK.


    7. Exit the Registry and restart the computer.


    Next, configure the system mixer:


    1. Open Volume Control by right clicking on the speaker icon on the taskbar, or go to Start/Control Panel/ Sound & Audio Devices/Advanced (button).


    2. Under the Options menu, select Properties.


    3. Under show the following volume controls check the box next to Microphone. Click OK.


    4. A mic control appears in the Volume Control. Make sure the mute box is unchecked and you will hear the mic input thru headphones. If you connect speakers check the mute box or feedback will occur when a live mic is connected.


    Jim


    Message Edited by jimco on 07-16-2004 04:46 PM


    Message Edited by jimco on 07-17-2004 12:30 PM

    Message Edited by jimco on 08-03-2004 09:31 AM

    Message Edited by jimco on 03-03-2005 11:42 PM

    Jim Coates -- senior forum member


  • I have an i8500 and the key is found and everything works as described in your post
  • Well, it's weeks later and I still have no solution. Is there someone I can call, say, at Dell?

     

    Thanks for your efforts.

     

    Mike

  • Jim,

    Thanks for the thorough solution summary.  I have a 9100 and your solution works well except that the mic input seems extremely sensitive.  That is, the volume for the mic when used as a line-in must be set to the lowest possible setting otherwise the volume is overwhelming.  Do you (or anyone else) know a way to make the step-up of the mic volume slider more gradual?  The other problem is that the master volume seems to have no control over the mic input level, although muting the master volume does mute the mic as well.  Unfortunately, this means that any program that uses the mic for line-in and then attempts to contol the volume through the master volume cannot control its volume.

    Thanks for a any help!

    DJPOP

  • DJPOP,

    Try verifying that 'mic boost' is off.

    Open Audio Properties (right click on the volume icon on the taskbar, or go through the control panel, Sound & Audio Devices). Select the Audio tab. Click on 'Volume' under 'Sound recording'. Click on 'Advanced' under the microphone select box. Uncheck the mic boost box.

    Use the mic volume slider in the Recording control panel to adjust the input signal level. When I have used the mic input as a line in I primarily used the volume control on the external source device to determine the signal strength..

    Thanks for the feedback on the 9100.

    Jim

    Jim Coates -- senior forum member


  • Jim,

    Thanks for response.  Knew about the mic boost and had that off already.  Another thing I noticed is that the master mute only mutes the PC speakers and not the 9100 subwoofer.  Below are the registry settings, if you have any other ideas on trying to give the master volume control over the mic (it has no effect on the mic input) or desensitizing the mic volume.  THANKS!

    DJPOP

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0005\Settings]
    "DisableHeadphone"=hex:01
    "DisableLnlvl"=hex:01
    "DisableWaveIn2"=hex:01
    "DisableSubwooferAtMono"=hex:01
    "MasterMute"=hex:00
    "EnableExtAmpControl"=hex:00
    "ExtAmpPowerDownTimeInMCS"=dword:00001388
    "ExtAmpPowerUpTimeInMCS"=dword:00001388
    "CodecPowerUpDelayInMCS"=dword:000003e8
    "DisablePCBeep"=hex:01
    "DisablePhone"=hex:01
    "DisableLineIn"=hex:01
    "DisableCDIn"=hex:01
    "DisableVideo"=hex:01
    "DisableAux"=hex:01
    "Disable3DControl"=hex:01
    "DisableMonoVirtual"=hex:01
    "DisableMonoOut"=hex:01
    "DisablePeakmeters"=hex:01
    "DisableMICSelect"=hex:01
    "EnableMuteReg02InMasterAdvanced"=hex:01
    "MuteReg02InMasterAdvancedDefault"=hex:00
    "PCBeepMute"=hex:01
    "PhoneMute"=hex:01
    "LineInMute"=hex:01
    "CDMute"=hex:01
    "CDVolume"=hex:00,00,eb,ff
    "MasterVolume"=hex:00,80,ef,ff
    "MonoMixerAtMonoOutVolume"=hex:00,00,00,00
    "SubwooferAtMonoVolume"=hex:00,00,00,00
    "VideoMute"=hex:01
    "AuxMute"=hex:01
    "SurroundMute"=hex:01
    "CenterMute"=hex:01
    "LFEMute"=hex:01
    "3DDepthEnable"=hex:01
    "HeadphoneMute"=hex:01
    "TrueLevelMute"=hex:01
    "WaveInMux"=hex:05,00,00,00
    "EmulateAllMasters"=hex:01
    "DisableMicFromPlayback"=hex:00
    "MasterControlsAux"=hex:01
    "MasterControlsMono"=hex:00
    "MICAtRecMuxVolume"=hex:00,30,10,00
    "EnableNonPCMOnWin2K"=hex:01
    "MasterVolumeFixedLevel"=hex:02,02
    "AuxVolumeFixedLevel"=hex:01,01
    "PCMVolumeFixedLevel"=hex:08,08
    "CPL_SaveExtraPower"=hex:00
    "CPL_UserControlsOnlyOnOff"=hex:01
    "CPL_SecondsAfter"=dword:0000000f
    "CPL_MaySwitchExtAmpPowerState"=hex:00
    "MuteInactiveDAC"=hex:00
    "EnableSubwooferAtMono"=hex:01
    "CPL_SpdifTransmitterEnabledByUser"=hex:01
    "GPIOControl"=hex:01
    "GPIOSPDIFControl"=hex:01
    "GPIOActions"=hex:00,00,00,00,00,01,02,01
    "WaveIn2Mux"=hex:01,00,00,00
    "MultiChannelEnable"=hex:00

  • I just joined the forum to say thanks.  The registry edit worked perfectly for my 5160.

     

    Thanks

  • Thanks,

    I've updated the original post to include your info and some others'.

    Jim

    Jim Coates -- senior forum member


  • I got an Inspiron 600m yesterday for myself. I am amazed (and disgusted) to know that the in-built mic is NOT there by default. I had been using a Latitude D600 and I liked the in-built mic feature as I have to worry less about carrying it with my notebook. I wonder why would Dell have chosen to remove this?
     
    Well, I see that I have Braodcom 10/100 and BIOS Memory is running at 333 MHz. Does that mean that I dont have any in-built mic. I enabled the Microphone in Sound->Playback settings with Boost Mic set to ÓFF. However, I could not see any mic getting detected. What do you all suggest?
     
    Are there any hardware available in market which if I add to the laptop, will work as in-built mic or do I have to purchase the usual bulky microphone? Suggest me what should I buy?
     
    Thanks to all you guys,
    Rakesh Mittal.
     
     
  • Rakesh,

    Please start a new thread with your question about built-in mics. This thread is not about that. Thanks.

    Jim

    Jim Coates -- senior forum member