High pitch sound from speaker

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

High pitch sound from speaker

  • I have a Latitude CPx J650GT running win2k server.  The audio works fine until one day, it emit continuous very high frequency sound (sort of like smoke detector, but higher frequency) from speakers during the boot time and the sound persists till I shut it down.  The volume control works because it could lower the high pitch's volume.  No other audio could be heard when I tried to play some audio file.  I don't think this is a driver issue because I updated the driver and it used to work fine.  I rebooted it and it gave me the same high pitch sound.

    I switched to use a different Power adapter, and it works fine now.  Then I used the adapter (which caused the high pitch sound) on a different Latitude (running win 98SE), it works normal.  I don't know if the Power adaptor has anything to do with it.  The same adaptor used to work fine for this laptop (for all my dell laptops).  Can someone explain to me that happened?

    Thank you.

    Blue

  • I had a similar intermittent problem 2 years ago with a CPxJ, but in my case it was short duration during boot or resume from standby. It was  fixed by updating the BIOS.

    Download the latest files and flash the BIOS. If this doesn't fix the problem please post back.

  • I upgraded my BIOS to A22 (BIOS Date 11-7-02) in December and this upgrade DID NOT solve my problem which is similar to the one described.  I also updated the audio driver at the same time.  I have a Dell Lat C600 running Windows 2000 Professional.

    I continue to have an intermittent problem with a high pitched "firm alarm" sound being emitted from the speakers.  It happens occasionally when I resume from stand by.  It has happened once while I was actually using the computer.  The noise always goes away if I reboot and may or may not go away if I go to stand by and then resume.  When the noise is emitted, everything else with the computer operates normally--even volume control and mute.

    Additionally sometimes when I resume from stand by (having normal sound operations when I went to stand by--no alarm noise) I have NO sound and must reboot to get sound.  It I got to stand by and resume sometimes the sound will return, but usually not.  This "no sound" problem happens much more often than the alarm noise--maybe even daily.

    I'm guessing these issues are related.  Although they diligently tried, Dell Phone Support couldn't offer any help with the matter during a lengthy phone call.

    Any ideas?  Thanks!!

  • I am having the same problem with the high-pitched sound. I don't know if it is coming from the speaker, however. My sound card is busted, so normally my computer makes no noise.

    Mine's a Latitude CPx H. I tried updating the BIOS and the audio driver; Dell's site no download information for my system for the audio, and when I ran the BIOS wizard, I got a message saying that I already had that version.

    When it occurs is similar to what kudcom described. It has happened when booting, while I was using it, and also when I wasn't even in the room. The occurances are few and far apart, but rather alarming! When it happens, I have to unplug the computer and remove the battery pack to make it stop.

    Any suggestions greatly appreciated,
    Laura
  • Laura,

    Thank you for using the Dell Community Forum.

    This post has been locked because the initial post was made last year.  If you wish to continue this discussion, I encourage you to start a new thread.