Choppy/Skipping Audio

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Choppy/Skipping Audio

This question is answered

Choppy/Skipping Audio FAQ

Since February 2007 we have seen a tremendous increase in the number of posts from Dell laptop owners complaining of audio glitching. It started with Windows Vista and continued through 7. These are tips from owners concerning these issues. Roughly starts with the most recent tips and ends with the oldest ones.

Note: if you have a brand new laptop and are dissatisfied with the noise in the audio, there is usually a 21 day return policy that I suggest you take advantage of if the solutions below do not help. You will own the problem after the  return period has expired.

> Section 1 -- Models with Windows 7 Pre-installed

> Section 2 -- Models with Vista Pre-installed

> Section 3 -- Older Laptops That Started Having Audio Noise Over Time

> Section 4 -- Windows Media Player Skipping

  **************************************************************************

**************************************************************************

Section 1
Audio Stuttering & Glitching on  Models with Windows 7


Summary

(Edit on 9-22-13: it has been a long time since getting complaints of the problems in the summary, so they may have been fixed at least on newer models.)

> The most popular solution for most models is to disable McAfee Netguard, or to remove McAfee entirely.

> The most popular solution for the XPS 15z (L511z) model is to install a Quaalcom Atheros driver.

> The most popular solution for the Inspiron 1545 & 1750 models is to disable the Intel Matrix Storage Manager or download the latest version of the Intel Rapid Share Technlogy. This solution also helped on several other models.

Inspiron 14z (N411z)
Inspiron 17R SE (7720) & 17R (5720)
Inspiron 15R (5520)
Inspiron 15R (N5110) & 17R (N7110)

Inspiron 15 (3520)

Inspiron 15 (N5010)
Inspiron 1545 & 1750

XPS 17 (L701x & L702x)
XPS 15 (L501x & L502x)
XPS 15z (L511z)

XPS 14 (L401x)

Studio Models

Vostro Models



Inspiron 14z (N411z) owners wrote:

"Go to Control Panel > Hardware and sound > Manage Audio Devices > Playback
Highlight 'Speakers' > Properties > Advanced
Unselect 'Enable Audio Enhancements'
Click 'Apply'
No more un-listenable, crackly audio." -- posted by ericmei and confirmed by allatrop

"I've disabled McAfee NetGuard and the problem is gone." -- posted by dmanvzla

"Basically it is a McAfee Net Guard problem. You go to the antivirus menu for McAfee:
Click Web and Email protection, click Firewall, Click Net Guard, turn it off by unchecking box." -- posted by MBanach

"Turning off the McAfee Net Guard feature fixed it for me." -- posted by L1NDSAY


Inspiron 17R SE (7720) & 17R (5720) owners wrote:

"I turned off the accelerating of my ssd, and what happened? Sound working perfectly, no crackling anymore." -- posted by Vykoria


Many 7720 and 5720 owners have reported a loud random hissing noise that lasts for 5 seconds to 5 minutes. The noise is associated with the units' power system. The solution for this issue is to replace hardware components.

"A technician changed the motherboard & speakers on my kitchen table. The new motherboard was bad so he reinstalled the original one. So, to my knowledge only the speakers were changed and that has solved my problem." -- posted by gskayak

"I had this issue as well with my first 17R SE, after a system replacement everything is fine." -- posted by Diana C.

"They replaced the power transformer cable, the power jack on the laptop, the mother board and the sub - so I don't know which bit was the culprit but it hasn't happened since." -- posted by ClareJ

"...My motherboard has been replaced. It seems all ok now." -- posted by Boedir

"I logged a call with Dell. Tech came onsite and replaced all the speakers and the mother board. Haven't seen the problem since." -- posted by Aussan

"I changed the motherboard out and the problem was solved." -- posted by duntuatha

"It appears to be an issue with the motherboard." -- posted by Dell_Vikram M, referring to the 5720 model

"I never found out if this was a bad charger or a problem on the motherboard.  I just returned it for a compete replacement and the new unit works great. The sound/interference noise definitely comes from the charger when it is charging the battery." -- posted by dencolousa


Inspiron 15R (5520) owners wrote:

"I turned off McAfee Firewall ... and like magic I have been listening for an hour w hile connected to the internet using bit torrent web browser and winamp running DPC latentcy checker guess what NO RED BARS NO Distortion." -- posted by louismar

" It was recommended to me to uninstall the McAfee software that came preinstalled. I did uninstall it and installed something else (AVG). Haven't had the problem since. " -- posted by St. Pete


Inspiron 15R (N5110) & 17R (N7110) owners wrote:

"I found that the Intel Rapid Storage Technology driver for my laptop (N5110) was outdated. I downloaded and installed the correct version, Version: 10.8.0.1003 directly from Intel. The stutters and buzzes are completely gone." -- posted by aja8090

"I have solved problem (N5110) by disabling Net Guard in McAfee antivirus. My friend (Inspiron N7110) also has solved stuttering noise by disabling this option in McAfee antivirus." -- posted by pr3dr46

"Have a Dell Inspiron N7110 ,,,, problem is in the wireless adapter, and all you have to do is to disable it and  glitching and buzzing sound will disappear." -- posted by Branimir12  [but that is more like a description of the problem than a solution.]

"The only solution for me (N7110) was to uninstall the Windows 7 Home Edition SP1 and install another Windows 7 Home without SP1. I did not update the Windows (just security updates) and it's working. No sound and video problem." posted by valtinpaul

"Same problem with Inspiron 17R (N7110) ... I have solved the driver: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20110&lang=eng&OSVersion=Windows%207%20%20*&DownloadType=%0ADrivers%0A" -- posted by simi_n22

"Uninstalled the Western Digital "SmartWare" program and activated a backup setup through Windows 7.  Testing the audio and have had no glitches as of yet...." (N5110) -- posted by Taylis

" I no longer hear the annoying sound. Turning off Net Guard completes the process after installing the Intel Rapid Storage Technology." -- jinxed.utopia


Inspiron 15 (3520) owner wrote:

"I disabled Anti Malwarebytes on the start up and poof problem gone." -- posted by erik50000

Inspiron 15 (N5010) owners wrote:

"I updated INTEL HD GRAPHICS driver and looks like noise is gone." -- posted by  kabhi17

"...I updated the Rapid Storage Technology driver to the 10.8.0.1003 version and that did the trick!" -- posted by iamshardy2



Inspiron 1545 & 1750 -- Intel Rapid Storage Technology

For audio glitching in these 2 models, the main recommendation is to download and install the latest Intel Rapid Storage Technology driver directly from the Intel site. Dozens of owners have confirmed this. It also works for many but not all XPS 15 (L502x) and other Dell laptops. --  first posted by mao.tsetung

Go to http://www.intel.com/p/en_US/support/highlights/sftwr-prod/imsm

Go to that page and click on the link named "Intel Rapid Storage Technology (Intel RST) RAID driver". On  the next page, download the file named: "SetupRST.exe".  


Other solutions that worked for some Inspiron 1545 & 1750 owners:

> Go to Device Manager, find the Intel(R) ICH9M-E/M SATA AHCI Controller, right click, select Properties, driver tab, roll back driver. Roll back to an earlier version of the Intel Matrix Storage Manager, 8.9.0.1023

> or download the earlier version http://www.dell.com/support/drivers/us/en/04/DriverDetails?driverId=MHT9T&fileId=2731106471

> Go  to Windows Services and disable Intel Matrix Storage Event Monitor. Or just set it to "manual" start up.

> Or just uninstall the Intel Matrix Storage Manager. Most people who don't use RAID do not need it.

> "I physically removed the battery and ...problem solved. Latencies consistent ~250 and under, NO SPIKING." --  posted by jesuisneil (Inspiron 1750)


XPS 17 (L 701x and L702x) owners wrote:

"My L702x has the i7-2820QM 2.3 GHz processor. So therefore when I would check the box "number of processors" you can access a list of the processors the computer recognizes. Mine would be "8". This noise issue was occuring and I found that when it was my computer only recognized 2, losing 6 of the cores.

-Open Start Menu
-Within the search box type "msconfig"
-Select the Boot tab
-Select advanced options
-Uncheck "Number of Processors"
-Uncheck "Maximum Memory"
-Click OK
-Click Apply
-Restart your L702x.
-Once the computer comes back on right click on the taskbar and select "Start Task Manager"
-Select the Performance Tab. Look at the CPU Usage History date on the top graph. I have 8 graphs representing all 8 of my Cores on my processor. However many cores you have should be listed too." -- posted by AJ5K

"After reading these posts about the Intel Rapid Storage Technology Driver I uninstalled it. That was around Dec. 10, and so far I haven't had any "lag" issues since then." -- posted by AJ5K

"There was a post on updating the Intel Rapid Storage driver. After I have updated this my laptop is working fine." -- posted by jamy

"I un-installed McAfee and so far so good. I also explicitly told the computer I had 8 cores in MSCONFIG." -- posted by neil XPS 17 l702x

"Uninstall McAfee and your laptop will get rid of the sound and laptop freezing issue." -- posted by Waqaas

"All I did was completely remove McAfee and install Microsoft Security Essentials in its place and problem gone." -- posted by wildmanyeah

"Please disable McAfee Netguard and check if you still have stuttering issue." -- posted by DELL-Anish V
 
To disable Net Guard:
1) Open McAfee Security Center
2) Click on "Web and Email Protection"
3) Click on "Firewall"
4) Click "Net Guard"
5) Uncheck the box beside "Turn on Net Guard

"Uninstalled McAfee this morning and that cured the problem. No more latency spikes. Reinstalled all my programs I had dissabled to pinpoint the problem and the problem came back. I started disabling my programs again and found out that my passport external hardrive software was causing it. Although the drive was not connected and the Western Digital backup software was turned of, it was still running in the background causing problems. I dissabled the program in msconfig and my PC has been running like a champ." -- posted by kurtro

"I recently realized that this issue completely vanished. The one big change I did to my computer was to uninstall McAfee." -- posted by rommyusa

"If you have McAfee security remove it, that worked for me." -- posted by bobycat (L701x)

"...Malwarebytes has two checkboxes for protection, one is the 'filesystem protection' and the other one is the 'malicious website blocking'. If I disable the second one then the [DPC Latency] spikes are gone." -- posted by littlerocker


XPS 15 (L501x & L502x) owners wrote:

L501x

"The one thing I still haven't done before then is installing the newest BIOS version! And that was the problem... no cracks and noises anymore." -- posted by oerpflkaefer [CAUTION: a failed attempt to update the BIOS can ruin the motherboard.]

"I solved this problem disabling all the desktop gadgets that were checking elements of hardware (nvidia temps, cpu freq). If I enable this gadget the audio cracks appear." -- posted by Yauja

"Uninstall Realtek Audio Manager program, do not re-install, sound is crystal clear!" -- posted by crumptious

L502x

"...The problem was that the laptop had two cores off... Click on Start->type msconfig->Click on Boot->Advanced Options->Check on Number of Processors->Now select the Processor that you want to activate->Click on Apply->OK.
You need to active 8 cores, if you only have the option of 4 and you can't select 8, just uncheck the option, restart and go back and now you can see 8 cores." --  posted by edgard_cz and confirmed by Groskoko

"I reinstalled McAfee without the firewall, no stuttering anymore." -- posted by leftisthominid

"On the Nvidia thread (http://forums.nvidia.com/index.php?showtopic=157614&st=510) a user named T1mur pointed out that if you add a certain line to the registry it greatly remedies the situation." -- posted by leftisthominid

"I've updated the Nvidia driver from the Nvidia page itself, rather than the Dell page. I've uninstalled McAfee COMPLETELY. I've installed Intel Rapid Storage Technology. Uninstalling McAfee ...seemed to be what cause the final blow. I haven't had the spikes for at least a month now" -- posted by xShubert
 
"I called Dell and they send me the new laptop. Again I noticed the problem and the only solution that worked was to completely uninstall McAfee." -- posted by NoArq

"After another fresh install, removing McAfee firewall, and applying all the latest drivers from hardware manufacturers it seems to have rectified the issue." -- posted by midnightfox88

"I've updated all my drivers from the manufactures websites, deleted McAfee and most of the Dell software and now the audio stutters have pretty much gone. " -- posted by IanEvs79

"I did clean install of windows and installed all the drivers, for my surprise audio stutters were not present. Later I installed McAfee and stutters appeared again. So McAfee is the problem, just uninstall it." -- posted by multiks2000

"All I had to do was simply remove McAfee and I installed Microsoft Security Essentials in its place and the sound problem is gone." -- posted by wildmanyeah

"Go to the notification bar (right of the taskbar) - right click the "Speaker" icon and click "Playback Devices" - select the speakers / audio out and click "Properties" at the bottom.   ... Under the "Enhancements" tab check "Disable all sound effects". I also completely uninstalled nVidia (3D engine and suite) and restarted.  I then reinstalled nVidia (using the latest 302 build) and restarted. No choppiness for me." -- posted by Shundi

"...since I have installed the suggested Intel Rapid Storage driver from the Intel home page about two months ago I am not experiencing audio stuttering anymore." -- posted by gavmav

"The cause of the problem was out of date drivers on the Dell website, the main culprit being an out of date Intel Rapid Storage driver which was producing lag between the hard drive on the Southbridge and the CPU." -- posted by mike1787

"...found a Firmware update for the SeaGate HDD that my laptop, and as many of yours certainly too, have...
SEAGATE ST9500423AS
Release Date: 6/22/2012
Version: A04 0005DEM1
Now I've just used uTorrent and listening music and had no problem at all." -- posted by Fencore

"The main cause, for me and for many others on both Dells and other manufacturers, is ACPI.sys. Under Device Manager, it is listed as "Microsoft ACPI-Compliant Control Method Battery." Disabling this removes the battery icon in the notification tray (which means that you will no longer be able to check on the status/percentage of your battery or be warned when your battery hits a "critical" level), but it also seems to drastically reduce the DPC Latency issues." -- posted by austinay  [CAUTION: doing this could affect battery charging.]

"I recently unistalled my McAfee AntiVirus. I haven't had any problems with the stutter noise since." -- posted by atabernacki

"The last thing I noticed was my Dell Support Center.  It was running occasionally in the background using up my CPU for just a second slowing everything else down. First I tried to turn off the auto monitoring features but it was still running. I uninstalled it, and two days now, no stuttering!"  -- posted by dumyfou

"I went to Intel's support site for "Intel Rapid Share" and downloaded the newest driver. I installed it, restarted the XPS and voila - NO MORE STUTTERING AT ALL!" -- posted by egis_core_i7

"I removed some of the HDD control options in Intel Rapid Storage and the problem seems solved!" -- posted by Strie

"I uninstalled and reinstalled McAfee Security Centre without the Firewall. And boom. Problem solved." -- posted by LucasKoehn

"I've Dell XPS L502x and had same problem. You've to turn off McAfee Net Guard. This solution work with me." -- posted by mizomizo

"Intel Rapid Storage Technology driver update does solve the problem. It made quite some difference in my case at least. I still have full featured mcafee installed..." --posted by kromastorm





XPS 15z (L511z)  -- Atheros Ethernet driver

"This specific audio issue is regarding the Intel Centrino 6230 N Wireless Card in the XPS 15z. When a wireless connection is active and network traffic is generated, audio glitches will occur on the XPS 15z .... It was eventually discovered that the Atheros Ethernet Adapter could be attributed to the problem ....   Since this point, it has been a community recommendation to install the Qualcomm Atheros driver rather than using the outdated Dell OEM driver." -- posted by James2k

To learn more about this issue and how to fix it, go to James2k's thread and read his first post:
XPS 15z Audio Crackling/Stuttering with network traffic over wireless (Latency Issue)



XPS 15z (L511z) -- other owners wrote:

"1) Go to your Taskbar and right click on the sound icon --> select playback devices.
2) click on Speakers --> click properties
3) now you will see 4 tabs at the top of the new window (general, levels,enhancements, advanced). Click on Enhancements.
4) now tick/enable the box "Disable all sound effects". -- posted by Patronza

"The only way I could fix this issue was to rebuild my laptop from scratch using a Windows 7 disk, not the recovery partition. I just installed the drivers from the Dell website but none of the other unnecessary software that comes preinstalled on the machine when you buy it." -- posted by swhite78

"If I run the laptop on batteries I don't have the problem!!" -- posted by aqal

"Also, try turning off "Enable Dell Extended Battery Life" in the Battery Meter window." -- posted by cmespinoza

"McAfee was causing the latency /audio glitch error for me. Dell tech support transferred me to Dell McAfee support and they re-installed McAfee with all the current updates and that finally resolved the problem." --posted by Wolfeman07

"I notice under the Advanced tab of the Realtek HD Audio Manager that there is a power management setting which turns off system audio devices when there are no sound events ... it seems my problem is gone and I now have great sound again" -- posted by aras1


> Right click on the speaker icon in the lower right corner and choose Volume Control Options.
> Click on the arrowhead in the bottom right hand corner to show hidden icons and double click on the Realtek HD Audio Manager icon.

>  Under the Advanced tab of the Realtek HD Audio Manager that there is a power management setting. Turn off or disable that feature

 

XPS 14 (L401x) owner wrote:

"I played an mp3 music on vlc then I disabled & enabled the wireless card by (Fn + wifi) combination in the keyboard...many times...  Result is: freeze screen then blue screen (I did it 4 times again and again), then the crackling sound is gone." -- posted by Driss el Mernissi

Studio XPS 1645 owner wrote:

"I replaced the Intel Rapid Storage Technology (7-21-10) with the Matrix Storage Manager (9-23-09). That, plus a Turbo boost monitor seems to have done the job." -- posted by Fix this

"Right click on the ‘Speaker/Headphones' tab (located in your tray)
Select Sound. Click on the Playback tab. Right click on Speaker/Headphones.
Properties>Advanced>Default format. Change format to 24bit 192000hz" -- posted by sunny1985 on notebookreview.com


Studio 1745 owner wrote:

"I just rolled it back [Intel Matrix Storage Manager] as stated here and it worked, thank God! Go to Device Manager, find the Intel(R) ICH9M-E/M SATA AHCI Controller, right click, select Properties, driver tab, roll back driver. Roll back to an earlier version of the Intel Matrix Storage Manager, 8.9.0.1023." -- posted by Lindy52

Vostro 3450 & 3700 owners wrote:

"I seemed to have maybe fixed or at least greatly improved the problem by deleting and uninstalling the Realtek High Definition Audio software and driver on my laptop and allowing my computer to install its generic Microsoft High Definition Audio instead, and I also read on a forum that if you put your power savings option to high performance, the sound card uses more power obviously and thus improves sound quality." -- posted by S.P. and confirmed by 2 others

****************************************************************************

****************************************************************************

Section 2

Models with Vista Pre-Installed

 

 

> Wireless. The most common problem in Vista  is choppy/skipping audio when the wireless is turned on. This is easy to diagnose just by turning off the wireless. Press Fn+F2 on the keyboard, or turn off the wireless switch if your model has one. If the wireless is causing your audio problems then you will notice at least a partial improvement when the wireless is off. Sometimes switching to a different brand of wireless card can fix this.

(Forum member kakendle was the first to note a connection between the glitching and wireless on 2-26-07.)

 

> Disabling the 802.11a band. Some wireless card models still feature the "a" band. If turning off the wireless (Fn+F2) lessens the choppy/skipping on your computer then disabling the "a" band is often a permanent fix if your card has that band. I don't have a list of which models have the "a" band and which don't. The Dell Wireless WLAN 1510 Half MiniCard (4322) N card has it.

 Go to Control Panel > Device Manager > expand Network Adapters > right click Dell Wireless (your model) > right click Properties > Advanced Tab > click "Disable Bands". In the drop-down list on the right labeled "Value" choose "Disable 802.11a". Click "OK".

 On some models you select the "b/g" bands instead of disabling the "a" band. On some models updating to the latest driver fixes this problem.

 

> Update Drivers. Most of the problems seemed to be caused by a poorly written driver causing excessive DPC latecy. The worst offenders are wireless and  video drivers. If your laptop came with Vista pre-installed then there are no new driver updates coming out anymore, but at least be sure to have the latest ones that are available.Some drivers are available from the vendors websites but for most of them you need to go to the Dell Drivers & Downloads Selection page and either select your Service Tag number in the left field, or in the right column select "Choose from a list of all Dell products", then click "Continue" and follow the links to your model and operating system.

 

> Vista Anti-Lag. This little utility program helps eliminate the wireless problem, but if the solutions above work then you don't need it. Forum member aleywwu explained it this way: "From what I understand, it somehow prevents your wireless card from looking for a new network every 3 seconds by 'optimizing' your card.  It's temporary, and you have to re-run it every time you restart your computer, but it has completely, albeit temporarily, solved my problem."  You can google for a download or use the link below to go to one site that has a download available.

http://www.mapmodnews.com/article.php/Vista-Anti-Lag-VAL-1.1.1-Wireless-Spikes

> XP Anti-Lag. The XP equivalent to Vista Anti-Lag is to disable the Wireless Zero Configuration Service. Go to Start/Run and type "services.msc" (without quotes )then hit the 'Enter' key (or click 'ok'). The Services window will appear and you can disable the service. (Tip posted by AlienKay.)


> Power: reduced power can caused poor audio performance, so run the laptop on ac (mains) power while attempting fixes, not batteries.

> Disable All Power Management schemes. There can be multiple schemes on a laptop because they are intended to extend battery life. They can exist for the operating system, for the graphics card, for the audio, etc.

To disable Sigmatel power management , go to Start>Control Panel>Sigmatel Audio>Advanced and uncheck "enable  power management".

To disable IDT power management , go to Start>Control Panel>IDT Audio Control Panel>Advanced  power setting, etc.

To disable Realtek power management, go to the power management settings on the Advanced tab of the Realtek HD Audio Manager.

On some models you can turn off "Enable Dell Extended Battery Life" in the Battery Meter window. (Tip posted by cmespinoza.)

> Power Settings on Inspiron 1501 and other models with AMD Turon processor:  change power plan to "Power Saver" or "High Performance" rather than "Balanced". You can do the power plan change at Start>Control panel > Power option. (Tip posted by Japan 2ch on 4-10-07.)

> Powernow in BIOS of Inspiron 1501: "Disabling this took care of my video skip/noise popping problem". (Tip posted by gmckeehan on 11-21-07.)

> nVidia Powermizer Setting on Latitude D830 & E6400, Precision M4300 and other models: should have the Powermizer turned off. "The setting is configurable via the NVidia Control Panel. You should be able to get to that via the appropriate icon on your Taskbar, via an option on the menu that appears when you right click on your desktop, or through your advanced display settings. The only option in the Mobile group is "Change Powermizer settings" and I disabled it there. I also adjusted my 3D settings for Performance (as opposed to Quality) in the 3D settings group, as that was a recurrent, associated suggestion in posts about Powermizer problems." (Tip posted by dml2912 on 9-05-08.)

> Latitude E6400 & 6500 w/Vista, IDT power management:  A lot of owners confirmed this as the problem on these models. It should be turned off.

 

> Inspiron 1501 or Vostro 1000 computers with a Vista ATI Video Catalyst driver, go to this thread for a solution posted by forum member znalim.

> Studio Models with Fingerprint Reader can make clicking noises. Try updating to the latest driver. (Tip posted by Dell_ Bill B on 01-19-09.)

> Inspiron 600m audio distortion and low volume: power off and remove the battery and put it back in. (Tip posted by bigtom79 on 12-30-05.)

> Latitude E5420, E5510, E5520 with Fingerprint Reader: "I have just disabled Biometric Devices AuthenTec Inc. AES2810 ...and the drop-outs disappeared!" (Tip posted by Hoffmannos on 5-08-11 and confirmed by several other posters.)

Disable the Biometric Device in Device Manager OR go to the AuthenTec site and install the WBF driver. (Tip posted by Joe in LA.)
http://support.authentec.com/Downloads/DownloadManager.aspx?EntryId=75


> Latitude E6500 w/Dell Connection Manager: "I realized last night that the Dell Connection Manager redundantly and annoyingly has its own power saving features. My adapter started working correctly when I disabled these features which include a feature that specifically slows down network speed to save power! (Tip posted by allon.)
1. Open Dell ControlPoint
2. Click on Power Manager
3. Click on Manage Power Setting
4. Click on Advanced Setting
4. Uncheck the two boxes

> Latitude E6400, E6410 & 6500 w/Vista and Intel Matrix Storage Manager: there were many posts about this. The consensus was to try a different version, either an older or a newer one. Both approaches worked. A similar problem exists now in Windows 7 with the Intel Rapid Storage Technology that replaced the Matrix Storage Matrix.

> Latitude E6400 & 6500 ATA mode: "I go into bios and set HD controller to "ATA mode" (other two modes still causes it), and then reinstall clean Vista OS, plus all normal drivers (minus intel matrix stuff) and now I have no pops anymore."  (Tip posted by melovescotch on 12-16-08.)

> Latitude 6500 w/Vista BIOS tweaks: forum member jayce1983 posted a link to Evrim Sen's blog (http://www.evrim-sen.com/html/dell-latitude-e6500-sound-prob.htm) with the following instructions: Restart your DELL, keep pressing F2 until Bios comes up. Make these changes:
1. System Configuration > Miscellaneous Devices > uncheck Enable eSATA Ports
2. Performance > Intel SpeedStep > uncheck Enable Intel SpeedStep
3. Virtualization Support > check Enable VT for Direct I/O

> Latitude E6500 graphics driver w/Vista Ultimate SP1: "The video chip is the nVidia Quadro NVS 160M.  When I roll back my video driver from the 7.15.11.7607 A01 to the standard VGA driver in Vista, the popping and skipping are no longer apparent in music.  Of course, I lose some of the functionality offered by the nVidia driver. "  (Tip posted by calvin0399 on 2-3-09.)

> Latitude E6520 with chirping in headphones: "The noise occurs at all times on my Windows partition (at all times meaning regardless of power configuration), and only when power is disconnected and running on battery when booted in Linux.... I had BIOS A04 installed ... I updated to A05 and the problem persisted, so I updated to A17 (A05 was required to make the jump to A17). Now my headphones make the sound once on startup, and once on shutdown, with no chirping in between."  (Tip posted by justbinfishin on 2-17-14.)


 Other tips that were posted:

> Anitivirus. On a 1525 with Vista, forum member Oxceraniod found that crackling on his computer was caused by the PC-cillin Anti-Virus that came with it. The solution was to exit from the program on the taskbar. Another poster thought his AVG antivirus contributed to the problem.  Forum member mgh0815 with a Studio 1555 wrote that removing the pre-installed CA Associates antivirus cured a buzzing noise and solved a problem with awakening from sleep mode.

> Uninstall or Update the Dell Quickset Utility - you may wish to try uninstalling it as a test and reboot, and if that helps then update to the latest version. (Tip posted by Groove75 on 3-30-07.)

> Inspiron B130/1300  the A10 BIOS supposedly fixed intermittent pops or stutters while playing music.  [CAUTION: a failed attempt to update the BIOS can ruin the motherboard.]

> New BIOS for XPS M1330, Vostro 1400, XPS M1730 (but reportedly does not help M1720 or M1710) install the newest version of BIOS and to cure crackling noise. (Tip posted by kingink on 2-7-08.)  [CAUTION: a failed attempt to update the BIOS can ruin the motherboard.]

> Set BIOS sound level to bypass: "I went into the BIOS and made sure that the HDD sound level was set to 'Bypass'. Usually, there are three options in the Dell BIOS's: Bypass, Quiet, and Performance. Even if your drive is set to 'Bypass', set it to 'Quiet', reboot into windows, and then set it back to 'Bypass'." (
Tip posted by Geirskogul.)

> Registry edit for M1330 and Inspiron 1720 with the nVidia 8400M GS video adapter. Open the Registry editor and navigate to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{**unique to you for nvidia**}\0000\

find PerfLevelSrc and change it from 0x3333 to 0x3332.  (Tip posted by stopgap on 12-21-08.)


> Configure
XPS M1710 for line-in. Plug a mic or headphones into the mic/line-in port on the laptop and when the pop-up box appears asking you how you would like to configure the port, choose Line-In. Doing so might resolve a problem with clicking, hissing, crackling and humming. (Tip posted by encrypter on 8-24-07.)

> XPS M1730 w/Vista tweaks:  Go to Start>Run and type msconfig and click OK. Then under "Startup" tab disable IDT Audio. Under the "Services" tab disable Andrea ST Filters Service and Sigmatel Audio Service. (Tip posted by noetzelmann.)

> XPS M1730 w/Vista: "Locate these two programs in the windows control panel/software and un-install them: Advanced Audio FX & Advanced Video FX." (Tip posted by noetzelmann.)

> Lower Volume on an Inspiron 1520. Maximum volume on this model can cause skipping or freezing. Lower the volume level to below 80% of max and compensate by raising volume of external speakers. (Tip posted by Eng.A7md  on 10-28-08.)

> Bad Power Adapter on Inspiron 1720. "I decided to unplug the laptop from the wall, and suddenly the skipping went away! Plugged it back in, and the skipping returned. Tried a different power supply, and the skipping is also seemingly gone. So it seems that the power adapter, at least in this case, was the problem." (Tip posted by TailsFurse).

> Aero Theme. Deactivating this theme might result in less noise. (Tip posted by FrancoisH on 2-2-08.)
Similarly, StereoHeathen got an improvement by ending the Desktop Window Manager (dwm.exe) which eliminated Aero.

> Disable Enhancements: Go to the Sound properties and under the "Enhancements" tab check "Disable all sound effects".

> Install the native Vista or 7 audio driver.  This is a basic driver that will lack some of the features of the regular (vendor's) driver, but it is a different driver and can improve or degrade the audio quality, or make no change. If you try this driver and still have audio glitching then you can rule the vendor's driver as the cause of the glitching. There are several ways to install the native driver:

> Go to Device Manager and uninstall the vendor's audio driver (Sigmatel, IDT, Realtek, or Conexant) driver and select the option to delete the files. When done, reboot.

> or Go to Start>Control Panel>Uninstall a Program. Find the vendor's audio driver then right click on it and uninstall it. When you reboot the computer Windows will install its native audio driver. Check that it is installed by going to the Sounds properties. If it says "High Definition Audio Device" on any of the tabs then it is the native driver. If it says "Vendor's Name High Definition Audio" then it is still an the vendor's driver, so repeat the procedure. (Windows will keep installing the vendor's drivers until all that have been downloaded are removed.)

> or  Browse to c:\dell\drivers\
Expand all folders and sub-folders there. Delete all folders that have a sub-folder named "WDM". Those will be the audio driver folders and it is safe to delete them. If they are not deleted Windows will re-use them to build the audio driver.

> or follow these 10 steps:

1. Open the Device Manager (type devmgmt.msc in the search box and hit Enter).
2. Expand the "Sound, video & game controllers" and right click on the vendor's audio driver which will be one of these:

  • Realtek High Definition Audio
  • IDT High Definition Audio Codec
  • Conexant High Definition Audio
  • Conexant SmartAudio HD
  • Sigmatel High Definition Audio Codec

3. Select to "Update Driver Software".
4. Click on "Browse my computer for driver software".
5. Click "Let me pick from a list of drivers on my computer".
6. Put a check in the box "Show compatible hardware" if not already checked.
7. In the list of devices, click "High Definition Audio" (the native driver).
8. Click "Next".
9. On the Update Driver Warning box, click "Yes" (install the driver).
10. Restart the laptop if prompted. If not prompted, then no need to restart.
[To get back to the vendor's driver, do it again but reverse the names in steps 1 and 6.]

 

****************************************************************************

****************************************************************************

Section 3

Older Laptops That Started Having Audio Noise Over Time

 

 > Check for Ultra DMA mode on the IDE drives. [Note: this is for older laptops. Newer ones have SATA drives.] For several reasons the IDE hard drive or cd/dvd drive can stop operating in DMA mode and start using PIO mode. In PIO mode there can be crackling, popping and stuttering, and possibly generally sluggish performance. To check:

1. Go into the 'Device Manager' (in XP the path is: Start>Control Panel>System>Hardware>Device Manager).
2. Click the + sign next to 'IDE ATA/ATAPI controllers'.
3. Right click on 'Primary IDE Channel'.
4. Select 'Properties'.
5. Select the 'Advanced Settings' tab.
6. Check that the 'Current Transfer Mode' says Ultra DMA. If it says PIO then use the 'Transfer Mode' dropdown box to select for 'DMA if available'. If you can't make the change in the dropdown box then it must be done in the Registry. See the "Note" below.
7. Click 'Ok' to save your changes, or 'Cancel' to exit the Properties if you made no changes.
8. Next check the optical drive (CD/DVD). Right click on the 'Secondary IDE Channel' and repeat steps 4 through 7.

Note: If you get to step 6 and find you cannot make changes in the dropdown box, go to http://winhlp.com/node/10

They have a little script program to reset to DMA mode. Click on the link in their 1st step. (Note: for best results use Internet Explorer when executing the vbs script in Step 1). Read the instructions in their steps 2-5 and then run their program. It makes edits to your Windows Registry to try to reset the drive(s) back to using DMA mode. If you want to know exactly what the program does, scroll down to "Re-enable DMA using the Registry Editor" for the full explanation.

The rest of their article describes the problem in great detail and discusses possible causes and solutions for it. You don't need to read the entire article unless running their program doesn't get your drives back into DMA mode.

(Forum member bacillus first posted this tip years ago in a basic form. Anne in Pennsylvannia found the link to http://winhlp.com/node/10.)



> Dell's PC Restore and Factory Image Restore. If your computer did not have any of the problems mentioned in this thread when it was brand new, then something has changed to cause the problem. In that case it might be easier for some people to return their computer to the exact condition it was in when new, instead of trying all of the possible fixes above. For others this should be regarded as only a last resort because it will wipe out any data and applications you have added and stored on the hard drive. In either case this will cure the problem -- but only on those computers that did not originally have the noise. If your computer did originally have the noise then it will still have it after you perform the restoration.

Dell's PC Restore for XP is an image of your original operating system in a hidden partition on the hard drive. It's like a normal reformat in that you have to save all of your data to removeable media, but it is different because it includes all of the original drivers, applications and configuration settings of the computer when it was new. Whatever was working when you got the computer will work after PC Restore, except for any hardware problems that have developed over time.

To use PC Restore you restart and press Ctrl + F11 during the restart process and it should take you to the "PC Restore" menu. Anything that doesn't work afterwards either wasn't working when the computer was shipped or is the result of hardware malfunction. For that reason PC Restore can serve as an excellent diagnostic tool for distinguishing between hardware and software problems.

On computers that were ordered with Vista, 7 or 8 pre-installed, Factory Image Restore does the same thing as PC Restore. To use it:

1. Restart the computer.
2. As the computer restarts, press F8 until the Advanced Boot Options menu appears.
3. Press <Down Arrow> to select "Repair Your Computer" and then press <Enter>.
4. Specify the language and then click Next.
5. Log in as a user who has administrative credentials, and then click OK.
6. Click Dell Factory Image Restore.
7. In the Dell Factory Image Restore window, click Next.
8. Select the Yes, reformat hard drive and restore system software to factory condition checkbox.
9. Click Next. The computer is restored to the default factory configuration.
10. When the restore operation is completed, click Finish to restart the computer.

Note: If your hard drive has been replaced or if you have ever wiped your original hard drive clean of all partitions, then you will no longer have the option to restore to factory condition.

 

 > Updating the firmware for a TS-L462C Cd rom/burner to version DE07 chops up the audio when not playing a cd, because that firmware revision is defective. To diagnose, place a commercial music cd in the drive (not a homemade mp3 or data cd -- just use a store bought cd or a copy of one). If the problem lessens then read this thread for instructions. Note that using PC Restore or Factory Image Restore (above) will not fix bad firmware.

To see if you have a TS-L462C open Audio Properties (right click on the volume icon on the taskbar and click 'adjust audio properties', or go through the Control Panel/Sounds & Audio Devices Properties). Select the Hardware tab. Look for DVD/CDROM in the device column. The name of the drive should be there.

To see which firmware revision you have,

 In Windows Vista go to Start then right click on My Computer and select the Manage option.
Expand Storage, then double-click Disk Management.
Right click on the CD-ROM/R/RW and choose Properties>Details.
Select Hardware Ids from the Property drop-down menu.
Your firmware version is located to the right of the of your drive name, usually combination of numbers and letters.

In Windows XP go to Start then right click on My Computer and select the Manage option
Expand Storage, then expand Removable Storage and then expand Libraries.
Right click on your optical drive name and choose Properties>Device Information. The Revision is your firmware #.

**************************************************

**************************************************



Section 4

Windows Media Player Skipping

 If you have an old version of Windows Media Player

> Disable Enhancements. If you experience skipping near the end of a song while using Windows Media Player in Vista, check the box that is labeled "Disable all enhancements". Go to the Sound properties and under the "Enhancements" tab check "Disable all sound effects". Just shutting off the enhancements individually won't work. The obvious drawback is that you lose the enhancements. (Tip posted by smittyofdhs on 2-20-07)

 > Disable Visualizations. You might get some improvement by disabling all visualizations under the Now Playing tab of Windows Media Player. (Tip posted by hovaslash on 2-28-07.)

> Crossfading and Auto Volume Leveling. Along the same lines, you might get some improvement by disabling Crossfading and Auto Volume Leveling. (Tip posted by wewake17 on 4-12-07.)

> Lightfx Plugins. Similarly, Dell tech support suggested removing the lightfx plugins completely. (Reported by forum member fhwfhi on 2-13-08.)

Jim Coates -- senior forum member


Verified Answer
  • Please do not reply in this thread which is a FAQ.

    If you have comments or questions please start a new thread or send me a private message. I will post additional tips & solutions when I get them.

    Thanks, I appreciate it.

    Jim Coates -- senior forum member


All Replies
  • Please do not reply in this thread which is a FAQ.

    If you have comments or questions please start a new thread or send me a private message. I will post additional tips & solutions when I get them.

    Thanks, I appreciate it.

    Jim Coates -- senior forum member