Dell XPS 15z no audio output through HDMI

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 15z no audio output through HDMI

This question is not answered

I am having problems getting an audio output from my LG tv through a HDMI connection. My laptop is able to detect the tv and had no problem displaying the video. There is no "HDMI output" option available in the playback devices list under audio options. I have tested the hdmi cable with 2 other dell laptops (studio 15 and inspiron 14). Both are able to deliver a sound output through the tv. Any help would be greatly appreciated.

All Replies
  • Click Here to get some information on how to hook up HDTV with HDMI cable.

  • Sivabalan
    There is no "HDMI output" option available in the playback devices list under audio options.

    There are dozens of reasons why HDMI audio doesn't work, so it is impossible to give an answer that could cover all situations, but the 1st thing I would try is going to the playback tab of the Sound Properties and right click in the white area. Look under "Disconnected Devices" and see if the HDMI audio option is there.

    Jim Coates -- senior forum member


  • @ Bay Wolf, I am able to get a video output...its the audi output that i am having a problem with...

  • @ Jim,  HDMI audio is not showing up in disconnected devices either.

  • I have collected dozens of tips from people about what worked for their particular combination of model, operating system, & graphics device, but don't have one for the 15z. Here are my general instructions, compiled from many posts left on the Laptop Audio discussion board.

    Preliminary steps:

    1. Plug the laptop into a power source. Some of the models have a power management scheme that will not allow for HDMI audio while running on batteries. Later, after you get your HDMI audio working, if you find that it still does not work on batteries you can change your power management settings in the Control Panel.

    2. Turn off the computer and TV before connecting the HDMI cable. Later, after you get your HDMI audio working, if you disconnect the cable while the computer is running and lose your audio, try closing and then re-opening whichever program you were using that generates audio.

    3. Every time you try a different solution you should reboot the computer. HDMI audio is extremely finicky and seems to usually need a reboot.

    Make the Connection:

    1. Connect the HDMI cable to the computer and TV.  If the TV has a "DVI/HDMI" port do not use it. Use a port for HDMI only.

    2. Turn on the TV and select the HDMI port you are using. Adjust the TV settings to receive HDMI audio if any.

    3. Turn on the computer. (Optional, some people close the laptop lid immediately after hitting the power button but I am not sure why. Most people should not need to do this.)

    4. Optional. Some models do better if the TV is set to be the primary display. To set, repeatedly press Fn+F8 (or ctrl+alt+F4) to cycle through the settings (laptop display only/laptop display plus external display/external display only). Reboot the laptop.

    5. Go to Start>Control Panel>Sound>Playback tab. Make "HDMI" the default device. (If "HDMI" is not there, right click in the white area and look under "Show Disconnected Devices" or "Show Disabled Devices" and see if it is there.)

    Post Connection Problems:

    1. If there is still no option to select "HDMI' as the default audio playback device, try re-installing or updating the graphics driver, or even try an older version. The graphics driver is the driver for HDMI audio, not the regular audio driver. Some people with Intel graphics had better results by uninstalling the graphics driver, rebooting, and letting Windows look for a driver -- instead of downloading the driver from the Dell support site.

    2. Try disconnecting and then reconnecting the HDMI cable.

    3. If you are using Windows Media Player or Windows Media Center but get no HDMI audio even after it is selected as the default playback device, go to

    Control Panel>Sound>Playback tab>Audio/Playback device>HDMI>properties>Advance>Exclusive Mode and uncheck "exclusive mode".

    4. Try a different HDMI cable.

    Jim Coates -- senior forum member


  • @Jim, tried all the  steps you have mentioned but still the HDMI option does not show up in the playback devices...same problem with xps 15 which also has the same graphics driver...can anyone having a xps15z  confirm that hdmi audio output is working fine for them?

  • Sorry, but I'm here to report that I have the same problem -- no audio output via HDMI to my TV even while video works fine.

  • Sorry, but I'm here to report that I have the same problem -- my XPS 15z is sending no audio output via HDMI to my TV even while video output to the TV works fine.

  • i have the same problem and i found the solution.FIRST CONNECT YOUR HDMI ok go to CONTROL PANEL/SOUND then press PLAYBACK then right click the high definition audio device and make it as your default device

  • I think it has somthing to do with software conflicts etc. Mine was working ok when I bought it and lost my HDMI sound after I installed couple drivers and softwares. If I only knew which one is to blame.

  • Same computer, exact same problem, there seems to be no available option other than the default Realtek HD Audio device (and yes, I am showing and looked for disconnected devices) ... have you had any success finding a solution?

  • You should visit NVIDIA control panel. There is an option there, under display, to configure HDMI sound.

    XPS 15z  BIOS A12 │Intel Core i7 2620M8 GB │ nVidia GeForce 525M│ 256Gb SSD │ Windows 7 Home Premium SP1 X64

  • BlackPie

    You should visit NVIDIA control panel. There is an option there, under display, to configure HDMI sound.

    I guess it helps if the NVIDIA driver is installed... doh! don't I feel like an idiot...

    Downloaded driver and most recent update from the Dell web-site and it works just fine. Thanks for pointing me in the right direction...

  • I can join you in the idiot corner.  I was looking for a hard, obscure problem and solution, when the problem was actually easy:  when plugged into the TV, I needed to go into Control Panel / Sounds and set the TV to "default device."  That's it.

  • I'm having the same issue now.  I'm sure it used to work fine in the past, now I've tried again and I have no audio through HDMI.  I've tried all of the following tips above and am getting nowhere.  In audio playback options, I only have "speakers" (as in the laptop speakers) as an audio option, I've made sure disabled options are visible, I've been in the NVIDA control panel and specifically made sure that "HDMI (with audio)" is highlighted and still can't get my laptop to discover that there is a TV attached WITH audio.

    I have updated my nvidia drivers recently and like I say, I'm sure I've had it working with no problems in the past, so can only think this is the problem.  Can anyone else confirm whether it stopped working for them after updating drivers? 


    Anything that's been discovered since would be much appreciated.

    Thanks.