Echo in my audio

Laptop

Laptop
Laptop computer Hardware and Software discussion

Echo in my audio

This question is answered

Please help me..I am using a DELL netbook and I am having a trouble using it for SKYPE to LANDLINE call...they usually say as if I am in a tunnel and ther's too much echo...I have tested my headset with other laptops and it is working good..Thanks..hope you'll reply soon. Have a good day!

Verified Answer
  • sarahmarie07
    it possible that there;s a prob with my sound drivers

    If you are using a Latitude D430 you probably have XP and the Sigmatel R171789 audio driver which is 4 years old now and known to be a pretty good driver. You could try doing a basic un-install/re-install of it which will reset it settings to their default configuration. You should not need to download a fresh copy of it unless its files have gotten corrupted and I doubt that has happened.

    A simple test you could do is to open Windows Sound Recorder and record some speaking into it and play it back. If there is no echo in the recording then probably all of the hardware is okay and the problem is more likely to be with the Skype configuration. Windows Sound Recorder can be found under Start/Programs/Accessories/Entertainment.

    Another thing that you might consider is that the D430 was originally shipped a piece of pre-installed software called Knowles Acoustics Intellisonic Speech Enhancement. I don't know much about that, but one of its features was microphone echo cancellation. If you do not have it then you should download and install it and see if it helps. If you already have it, then un-install it and see if that helps. I honestly don't see how it would affect echo unless your voice is coming through the speakers and being picked up by the mic.

    Is your voice coming through the speakers? If so then it is most probably being caused by skype sending your mic input back to the soundcard's output, where the mic would pick it up again and cause an echo. If that is happening look for a setting in Skype with "monitor" in the name and disable it.

    sarahmarie07
    i am using a DELL23 NETBOOK and my OS is windows vista..

    Needless to say this is confusing. If you have a Latitude D430 with Vista then your audio driver should be the Sigmatel R171788. There wasn't a Vista version of the Knowles software so skip that part of the above.

    Jim Coates -- senior forum member


All Replies
  • I am not sure what features your model has (don't know which model you have or its operating system) but you might have audio effects. See if you have them by trying to follow this path:

    Start>Programs>Dell Webcam>Laptop Integrated Webcam>Dell Webcam Console

    Look for a tab on the top left saying "effects", under "audio effects" and unclick the enable box.

    If you do not have that path then you do not have the effects. Look through the settings in Skype and try different ones.

    Jim Coates -- senior forum member


  • hello again i am using a DELL23 NETBOOK and my OS is windows vista..this doesn't have a cam ..i can't see the path u have mentioned (Start>Programs>Dell Webcam>Laptop Integrated Webcam>Dell Webcam Console)..i have tried diff settings in skype and i still have that echoes...pls help me..is there any other way to check it or is it possible that there;s a prob with my sound drivers..argghh not that techy actually..:(

  • oh sorry i am using a Dell Latitude D430 notebook

  • sarahmarie07
    it possible that there;s a prob with my sound drivers

    If you are using a Latitude D430 you probably have XP and the Sigmatel R171789 audio driver which is 4 years old now and known to be a pretty good driver. You could try doing a basic un-install/re-install of it which will reset it settings to their default configuration. You should not need to download a fresh copy of it unless its files have gotten corrupted and I doubt that has happened.

    A simple test you could do is to open Windows Sound Recorder and record some speaking into it and play it back. If there is no echo in the recording then probably all of the hardware is okay and the problem is more likely to be with the Skype configuration. Windows Sound Recorder can be found under Start/Programs/Accessories/Entertainment.

    Another thing that you might consider is that the D430 was originally shipped a piece of pre-installed software called Knowles Acoustics Intellisonic Speech Enhancement. I don't know much about that, but one of its features was microphone echo cancellation. If you do not have it then you should download and install it and see if it helps. If you already have it, then un-install it and see if that helps. I honestly don't see how it would affect echo unless your voice is coming through the speakers and being picked up by the mic.

    Is your voice coming through the speakers? If so then it is most probably being caused by skype sending your mic input back to the soundcard's output, where the mic would pick it up again and cause an echo. If that is happening look for a setting in Skype with "monitor" in the name and disable it.

    sarahmarie07
    i am using a DELL23 NETBOOK and my OS is windows vista..

    Needless to say this is confusing. If you have a Latitude D430 with Vista then your audio driver should be the Sigmatel R171788. There wasn't a Vista version of the Knowles software so skip that part of the above.

    Jim Coates -- senior forum member


  • thank u very much problem solved jimco..i have installed  Sigmatel R171788..:)