XPS15 L502X: Realtek HD Audio Manager eats 13% of CPU

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

XPS15 L502X: Realtek HD Audio Manager eats 13% of CPU

This question is answered

I have a spanking new XPS15 L502X with Core I7-2720QM and 8GB of memory. My task manager reports that the Realtek HD Audio Manager is constantly eating 13% of my CPU. My audio features (sound is on) are turned on but I am not processing any audio. Isn't this resource consumption a bit much? Do I have a faulty setting? Any suggestions?

Verified Answer
  • So I disabled startup of the Realtek software via System Configuration and disabled via Device Manager and rebooted. The result was no CPU usage and no sound at all. I then re-enabled all of the above items, re-booted, played a CD via Windows Media Player, Played an internet TV show via Windows Media Center, and played a DVD via CyberLink DVD. Task Manager reported the original 13% CPU usage on Image Name rtkngui64.exe. Now after the above fiddling, that Image no longer shows on Task Manager. Instead, RAVBg64.exe, Realtek HD Audio Background Process, is displayed with no appreciable CPU usage. That Image did not appear before.

    In summary, it appears that the basic disabling and re-enabling of the tasks cleared up the problem.

    Go figure!

  • so yeah, i know this thread is kinda old, but my laptop had the same issue. 

    the issue is that the ravbg64 service is looking for a registry key that isn't there. it keeps looking and not finding it over and over. 

    you can see this by using a tool called procmon.exe (Process Monitor). Just google it. 

     

    You need to add two registry keys. to do this: 

    Click the Windows Orb button thing (Start Button)

    In the search bar, type regedit

    Navigate to HKEY_LOCAL_MACHINE/SOFTWARE

    Right click "SOFTWARE" and left click "New", then "Key"

    Name it "SRS Labs" (without quotes)  - that's one

    Next, right click "SRS Labs", left click "new" then left click "Key" again

    Name it "APO" (without quotes)

    once you do this, it should get rid of the processor usage. 

     

    Hope this helps someone.

  • I am the original poster and just happened to check back in and found this great fix and it works!

    Thanks much again cheshirecat!

All Replies
  • So I disabled startup of the Realtek software via System Configuration and disabled via Device Manager and rebooted. The result was no CPU usage and no sound at all. I then re-enabled all of the above items, re-booted, played a CD via Windows Media Player, Played an internet TV show via Windows Media Center, and played a DVD via CyberLink DVD. Task Manager reported the original 13% CPU usage on Image Name rtkngui64.exe. Now after the above fiddling, that Image no longer shows on Task Manager. Instead, RAVBg64.exe, Realtek HD Audio Background Process, is displayed with no appreciable CPU usage. That Image did not appear before.

    In summary, it appears that the basic disabling and re-enabling of the tasks cleared up the problem.

    Go figure!

  • Your version does not work!

    After all done, still eats 13% CPU

     

    Please Help!

     

    (Sorry for my English)

  • Yep, now again, when I view Task Manager I find that RtkNGUI64.exe is eating  up 13% of my Core i7-2720 2.2Ghz system. This hardly seems acceptable to me. My sound is muted, speakers are off. So, I sent the following email to Realtek:

    Normal 0 false false false EN-US X-NONE X-NONE MicrosoftInternetExplorer4

    Sent: Saturday, April 30, 2011 9:57 AM
    To: 'pctech@realtek.com'
    Subject: RtkNGUI64.exe consumes 13% of CPU

    Realtek PC Tech Support:

    I have a brand new Dell XPS15 laptop (L502X) running 64bit Windows 7 and containing a Intel Core i7-2720QM CPU. For your reference, I have attached a Dell Support Center generated full System Information.html file to this email.

     I have my sound muted and have executed no audio applications since shutting down and restarting my computer. Under these, and every other condition that I have checked in recent weeks, RtkNGUI64.exe shows up on my Task Manager as consistently consuming 13% of the CPU.

     I went to Device Manager -> Sound, video and game controllers ->r Realtek High Definition Audio -> executed Update Driver and received the response: “Windows has determined the driver software for your device is up to date.”

     This constant and consistent 13% CPU usage on this system seems entirely unreasonable.

     I will be posting this email and subsequent responses in the Dell Laptop Community Forum so a well reasoned response will be much valued.

    Thank you...

  • I have the same problem with RealTek's ALC665 High Definition Audio CODEC.  I had installed the latest Dell Driver v.6.01.6312, A04, released on 4/7/2011 before noticing the problem.  So I wonder if the older driver has the same problem.  Orrinsmith, which driver version do you have?  (Version at:  Dell Stage-Shortcuts-Dell Support Center-Detailed System Information-Multimedia / Sound Card - Realtek High Definition Audio)

    I even uninstalled and reinstalled the driver - same 13% CPU use in Task Manager.  I will say it took several days after reinstalling the driver before the problem appeared again.

    Have you heard anything from Realtek?  You may try a chat with Dell Support.  Believe it or not, they can be of help.  The chat does take time because the technician is multitasking with several customers.  That may be one of Dell support's biggest problems - attention is not exclusive to you and your problem at the time you are chatting.   So the tech has to reformulate the problem after every customer contact when he comes back to you.  It does help though.

    Tacoslammer - eating too many tacos too fast: - slammin'  'em down Ick!  

    Signature now approved by Dell  Big Smile

    If you can read this, thank a teacher. 
    If you can read this in English, thank a Veteran
    and a Border Patrol Agent for keeping our borders secure.

    XPS 15 L502X, i7 6230QM, 8GB, GT525M, 640GB 7200rpm, WIN 7- 64bit, Security:  MSE, MalwareBytes free on both systems

    XPS 720, Intel Q 6600quad CPU, 4GB, 750GB, 3@ 160GB, Nvidia 7900GS, WIN 7 64bit Home Premium Edition

  • You need to RUN  MSCONFIG, Selective Start Up, Start Up Menu tab, and Uncheck the Reatek HD Audio Manager.  Reboot.  Walla, extra 13% CPU use is gone.  The RtKNGUI64.exe will not show up in Task Manager.   However, if you Push the Waves Button on the Control Strip, that will start the Realtek HD Audio Manager.  The Realtek Audio Mgr is designed is to remain ON as a background process.  Dumb design but that's the way it is.  Now since you turned it on, it will stay on until you reboot.   Since you unchecked it in the Start Up Menu, it will be OFF when Windows reopens.

    U must be sure it is unchecked from the Start Up Menu.  Cool

    Tacoslammer - eating too many tacos too fast: - slammin'  'em down Ick!  

    Signature now approved by Dell  Big Smile

    If you can read this, thank a teacher. 
    If you can read this in English, thank a Veteran
    and a Border Patrol Agent for keeping our borders secure.

    XPS 15 L502X, i7 6230QM, 8GB, GT525M, 640GB 7200rpm, WIN 7- 64bit, Security:  MSE, MalwareBytes free on both systems

    XPS 720, Intel Q 6600quad CPU, 4GB, 750GB, 3@ 160GB, Nvidia 7900GS, WIN 7 64bit Home Premium Edition

  • so yeah, i know this thread is kinda old, but my laptop had the same issue. 

    the issue is that the ravbg64 service is looking for a registry key that isn't there. it keeps looking and not finding it over and over. 

    you can see this by using a tool called procmon.exe (Process Monitor). Just google it. 

     

    You need to add two registry keys. to do this: 

    Click the Windows Orb button thing (Start Button)

    In the search bar, type regedit

    Navigate to HKEY_LOCAL_MACHINE/SOFTWARE

    Right click "SOFTWARE" and left click "New", then "Key"

    Name it "SRS Labs" (without quotes)  - that's one

    Next, right click "SRS Labs", left click "new" then left click "Key" again

    Name it "APO" (without quotes)

    once you do this, it should get rid of the processor usage. 

     

    Hope this helps someone.

  • Magic! Did Process monitor actually show the value of the keys required by the ravbg64 service?

    Thank you so much for posting this. seems to have fixed my problem - and hopefully also 118 sec additional boot time (according to Soluto) for loading RealTek HD Audio Driver ...

  • yes- it showed the service looking for the registry keys but them being "not found". once you make the keys, ravbg64 "Sees" them and stops looking for them over and over (which is what causes the 13% cpu usage). glad to hear it worked out :)

  • Thanks Man, this is awesome. The processor graph dived as soon  as I created the key "SRS Labs".

  • glad to hear it :)

  • Thanks, cheshirecat!  I'm embarrassed that I didn't think to fire up ProcessMonitor, especially b/c i ran ProcessExplorer when I noticed my laptop fan running high.

    This is a self-inflicted wound.  I ran jv16 Power Tools' Registry Cleaner to get rid of some useless keys.  The SRS Labs key is useless -- but also necessary...

    Thanks again!

    Adding in my laptop model for search purposes: XPS L702X

  • I am the original poster and just happened to check back in and found this great fix and it works!

    Thanks much again cheshirecat!

  • Great it works for my new Dell XPS L520X. Thank you so much.

  • I was worried because BatteryCare was showing battery usage as 35-40 W whereas normally it's within 20 W. Then, I found out this '13%' cpu usage problem and fixed it up. Battery usage is back to normal. Thanks.

  • Just wanted to thank you for posting this solution... We all appreicate the time it takes to give directions this detailed.